New install 11.1 Keep losing sound

I installed 11.1 on my laptop and everything went fine. I had sound working, but i lost it after an software update took place.

I followed the trouble shooting tips in the newbee install and i was able to get it to work by running the following commands and making other updates as indicated by the document.

rcalsasound restart

the guide said to add this statement to /etc/init.d/boot.local which i did, but when the pc reboots the sound does not work until a manual execution of the statement is run again. Now there has been a time or two that the manual execution did not work. then I rebooted and ran the command and i was working once again.

Any help would be apperciated.



Additional information:

rpm -qa | grep alsa


uname -a

Linux linux-uppb #1 SMP 2009-08-15 17:53:59 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.Xr0+ey1p7G5:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

Your ALSA information is located at

Please inform the person helping you.

When you state the “rcalsasound restart” command does not work for sound when placed in your /etc/init.d/boot.local, what is your criteria for stating there is no sound? Please do not use the start up sound as your criteria as that is quite possible a separate issue. Instead try ALL of the speaker tests from step-1 of the audio troubleshooting guide, and if ANY one of them work, then your sound functions. … You can go here for those 3: SDB:AudioTroubleshooting - openSUSE - How to test your sound
**If you use those tests does your sound work without the rcalsasound restart a second time?
If those prove your sound does not work, can you please post the contents of your /etc/init.d/boot.local file. ie post the output of:
cat /etc/init.d/boot.local

Thanks. I see your hardware is identified as a CX20549(venice) which has been renamed to the Conexant 5045.

I did a search on Conexant, and CX20561 and 5045 and did not see any specific updates in alsa for this device.

There are model options one can apply for the Conexant 5045 (with this list and descriptions from the HD-Audio-Models.txt file):

Conexant 5045
  laptop-hpsense    Laptop with HP sense (old model laptop)
  laptop-micsense   Laptop with Mic sense (old model fujitsu)
  laptop-hpmicsense Laptop with HP and Mic senses
  benq		Benq R55E
  laptop-hp530	HP 530 laptop
  test		for testing/debugging purpose, almost all controls
		can be adjusted.  Appearing only when compiled with

But before applying any fixes, can you answer my questions above?

You note your sound stopped working after an update. … Next time something like that happens for any application, it is very useful if one can figure out WHAT in the update caused things to stop working. A useful command to help there, is to type:
rpm -qa --last > rpmlist.txt
and then open up rpmlist.txt and look at the list of rpms for the specific day when the update was performed.


sorry for late replay, long day.

No, I am not basing my sound issues on the jingle played during the login process.

I have tried the sound test from the troubleshooting guide and when I run the commands the first fails and the second works and i here the right left voice. I have run this test right after the reboot before any action is taken.

speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.18

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 262144
Period size range from 32 to 131072
Using max buffer size 262144
Periods = 4
Unable to set hw params for playback: Invalid argument
Setting of hwparams failed: Invalid argument

speaker-test -c2 -l5 -twav

speaker-test 1.0.18

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 16384
Period size range from 1024 to 1024
Using max buffer size 16384
Periods = 4
was set period_size = 1024
was set buffer_size = 16384
0 - Front Left
1 - Front Right
Time per period = 2.680819
0 - Front Left
1 - Front Right
Time per period = 3.007955
0 - Front Left
1 - Front Right
Time per period = 3.008089
0 - Front Left
1 - Front Right
Time per period = 3.007944
0 - Front Left
1 - Front Right
Time per period = 3.050639

I am basing the my lose of sound on the following; playing a video in, youtube, online radio, and Amarok (a burl ives christmas cd) and kaffien playing a dvd. Which all five provide no sound after a reboot and after running the above test.

I shutdown firefox and any application the uses audio. I then run the below command and then all five work.

rcalsasound restart

Shutting down sound driver done
Starting sound driver: hda-intel done

restart amarok and Burl Ives plays and I here the wonderful Christmas music. video will have sound. Internet radio works just fine and kaffein play a a dvd with sound.

All is well until the next reboot.

The contents of /etc/init.d/boot.local is listed below.

cat /etc/init.d/boot.local

#! /bin/sh

Copyright (c) 2002 SuSE Linux AG Nuernberg, Germany. All rights reserved.

Author: Werner Fink <>, 1996

Burchard Steinbild, 1996


script with local commands to be executed from init on system startup

Here you should add things, that should happen directly after booting

before we’re going to the first run level.

rcalsasound restart

I have also went as far to add a startup script to /etc/init.d/rc3.d/SS99sound with the restart statement above to see if it made a difference for placement in the startup process. The problem is, I am not sure if ~/rc3.d is called after the execution of boot.local on the startup process, but felt it was worth a try. which had no success.

I think I answer your questions and provided the detail ask for.



If the second test works, you have sound.

I suspect what is happening is some device upon boot is locking up the sound. Possibly a process that survived the reboot (ie is being launched again at every reboot).

IMHO you should try to determine what application has seized the sound device when this happens. We will use the method documented here to help provide this indication: SDB:AudioTroubleshooting - openSUSE

Reboot your PC without the “rcalsasound restart”. Type in a konsole or terminal:

 lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

and record the output in a text file. Annotate so you know EXACTLY what the PC configuration was when you ran that.

I assume then you have no sound, EXCEPT you have sound if you run the speaker test:

speaker-test -c2 -l5 -twav

Then restart alsa with “rcalsasound restart” and again

 lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

and record the output in a text file. Annotate so you know EXACTLY what the PC configuration was when you ran that. I assume you now have sound in your applications.

Compare those. What is the difference?

Also, try changing the output audio model in your various multimedia applications to use “alsa API” as alsa will allow sharing of an audio device, while other sound daemons/servers will not (pulse is supposed to share, but pulse is buggy as of this date).

Be certain to remove this since it did not work.

My guess is something gets loaded, possibly by your desktop/GUI which may be monopolizing on the sound.

… Now we could apply model options to force your PC’s boot configuration to a specific alsa module, but I’m suspicious that may not be tacking the root cause … still, if all else fails, we can try go down that route. Another route we can follow is to update alsa.


you have an intersting point and i think you may be right about something else locking or casuing the device to show busy.

i say this because, i noticed if i where to run the restart commands and tryied to play video via firefox or one of the four tools before, which where not closed before the restart of the driver. i receive a device busy messages. I would then have to stop all and run the restart.

i will follow the steps you provided and get back to your with results later this evening.

thanks for the help.



I ran the commands to see what may have the sound device open. after the reboot i see the below applaictions have the sound devices open.

pulseaudi 4116 brian 18u CHR 116,9 0t0 3681 /dev/snd/controlC0
kmix 4192 brian 10u CHR 116,9 0t0 3681 /dev/snd/controlC0

I run the restart command and the the above applaictions disconnected from the device.

I also notices that the pulseadui is the deamon being used. you menetion to change output audio module in the applaictions to als, but i am not clear on how to do that. if you could provide a quick example it would be apperciaterd.



This suggests to me that when you boot your PC, there may be a mixer (kmix) setting that has muted your audio, and you need to go into your mixer and unmute the setting.

It depends on the application. Each is different. Typically if it can be controlled it will be under preferences or settings.

My issue is resolved and it was not with kmix having muted the sound. The issues was resolved by adding the user to the audio group. logged out and than back in and the problem was resolved.

Now, beside this new laptop I have three other pc’s I use for business, that run the same version 11.1, which had the same exact problem. I never use the sound on them so I never realized it to be an issue.

I made sure the troubleshooting steps where followed, but in the end, the add of the user to the audio group was the final action taken and then the problem was resolved.

I did find the options behind kmix will change and are very different depending on the sound board. go figure.

but for now i am good.

Glad to read your problem is resolved.

Usually the symptoms, indicating a user has to be added to group audio, is when sound works with root permissions, but not with regular user permissions. You did not report that symptom, and hence that is why I did not recommend it.

However I did put that as a step in the audio troubleshooting guide wiki (that I wrote).

I never did try logging in as root and seeing if i had the sound issue. I do not make it a practice to log in as root or system unless a installation or specific procedure requires it. I normally just su.

I think it is a good idea to add to the doc along with the rest.

Once again, thanks for the time and assistance.