new only file system

hi guys…

just got a new 2TB hdd yesterday and no matter what i seem to format it to, it won’t work. i formatted first to ext3 and it wouldn’t work, didn’t appear in my computer, so i found the device id in the partitioner and said to mount it in /media/mybook and it worked, i put a few files on there, and after each transfer it said could not change permissions for filename (whatever the file path was). i then formatted to fat32 through gparted, upon restart, it froze at ‘unmounting read-only filesystems’ so i had to hold in the off button. upon booting in, it was not in my computer, and mounting it worked, but it still said it was read only file system. since when was fat32 read only? i have tried chmod 777 -R /media/mybook but to no avail.

please please help me!


hmmm slight update…i formatted it back to ext3 and if i boot with the drive plugged in i can read and write to it (after chmod -R 777 /media/mybook) but strangely it still doesn’t appear in my computer, and if i unplug the drive and replug it, it won’t read it, yet says read only file system. so there is something wrong with the hotplug settings (fstab entry a bit wrong)

please help someone. i am transferring data to it now and it seems fine, it’s done about 150gb so far…but i still have another 800gb or so to go so… lol!

any ideas what the fstab entry should be for the drive?