New Firestorm Viewer (Second Life) does not start

Hello,

I downloaded the new Firestorm viewer (Phoenix-Firestorm-Releasex64-7-1-9-74745) for Second Life.
I’m using “OpenSuSE Leap 15.5 64 bit” with the nVidia graphics driver, not the “Nouveau” graphics driver.

I unpacked the downloaded file in a new folder and tried to start the program in the terminal with “./firestorm”
The following error messages appear.

xxxxxx@localhost:~/Programma's/Phoenix-Firestorm-Releasex64-7-1-9-74745> ./firestorm 
64-bit Linux detected.
LIBGL_DRIVERS_PATH is /usr/lib64/dri:/usr/lib/dri:/usr/lib/x86_64-linux-gnu/dri:/usr/lib64/xorg/modules/dri
Running from /home/xxxxxx/Programma's/Phoenix-Firestorm-Releasex64-7-1-9-74745
which: no gconftool-2 in (/home/xxxxxx/bin:/usr/local/bin:/usr/bin:/bin)
Warning: Did not register secondlife:// handler with GNOME: gconftool-2 not found.
which: no kde-config in (/home/xxxxxx/bin:/usr/local/bin:/usr/bin:/bin)
which: no kde4-config in (/home/xxxxxx/bin:/usr/local/bin:/usr/bin:/bin)
Using jemalloc
bin/do-not-directly-run-firestorm-bin: /lib64/libc.so.6: version `GLIBC_2.34' not found (required by bin/do-not-directly-run-firestorm-bin)
bin/do-not-directly-run-firestorm-bin: /lib64/libc.so.6: version `GLIBC_2.32' not found (required by bin/do-not-directly-run-firestorm-bin)
bin/do-not-directly-run-firestorm-bin: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by bin/do-not-directly-run-firestorm-bin)
bin/do-not-directly-run-firestorm-bin: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by /home/xxxxxx/Programma's/Phoenix-Firestorm-Releasex64-7-1-9-74745/lib/libfreetype.so.6)
bin/do-not-directly-run-firestorm-bin: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by /home/xxxxxx/Programma's/Phoenix-Firestorm-Releasex64-7-1-9-74745/lib/libSDL2-2.0.so.0)
bin/do-not-directly-run-firestorm-bin: /lib64/libc.so.6: version `GLIBC_2.32' not found (required by /home/xxxxxx/Programma's/Phoenix-Firestorm-Releasex64-7-1-9-74745/lib/libSDL2-2.0.so.0)
bin/do-not-directly-run-firestorm-bin: /lib64/libc.so.6: version `GLIBC_2.34' not found (required by /home/xxxxxx/Programma's/Phoenix-Firestorm-Releasex64-7-1-9-74745/lib/libSDL2-2.0.so.0)
bin/do-not-directly-run-firestorm-bin: /lib64/libc.so.6: version `GLIBC_2.32' not found (required by /home/xxxxxx/Programma's/Phoenix-Firestorm-Releasex64-7-1-9-74745/lib/libapr-1.so.0)
bin/do-not-directly-run-firestorm-bin: /lib64/libc.so.6: version `GLIBC_2.33' not found (required by /home/xxxxxx/Programma's/Phoenix-Firestorm-Releasex64-7-1-9-74745/lib/libapr-1.so.0)
bin/do-not-directly-run-firestorm-bin: /lib64/libc.so.6: version `GLIBC_2.34' not found (required by /home/xxxxxx/Programma's/Phoenix-Firestorm-Releasex64-7-1-9-74745/lib/libapr-1.so.0)
*** Bad shutdown ($LL_RUN_ERR). ***
xxxxxx@localhost:~/Programma's/Phoenix-Firestorm-Releasex64-7-1-9-74745>

(For security/privacy reasons i changed my real username in "xxxxxx¨.)

Can anyone help me to fix this, so that i can use the new Firestorm viewer ?
Thanks.

Best regards,

Flash2020

@Flash2020 What version of glibc in Leap 15.5 ldd --version I just tested here on Leap 15.6 GNOME/Wayland on AMD Mullins GPU, it started fine;

Did you peruse the README-lunux.txt file? Did you peruse the log less .firestorm_x64/logs/Firestorm.log for any other clues?

Can you paste the output here from inxi -GSaz

Hello,

My “glibc” version in “Leap 15.5” is :

xxxxxx@localhost:~> ldd --version
ldd (GNU libc) 2.31
Copyright (C) 2020 Free Software Foundation, Inc.
Dit is vrije software; zie de programmatekst voor de kopieervoorwaarden.
Er is GEEN garantie, zelfs niet voor VERKOOPBAARHEID of GESCHIKTHEID
VOOR EEN BEPAALD DOEL.
Geschreven door Roland McGrath en Ulrich Drepper.
xxxxxx@localhost:~>

The “README-linux.txt” file has a lot of technical information, but i did
not find any usefull information to solve the problem.

I did not find any error related messages in the “.firestorm_x64/logs/Firestorm.log” file.

The output of the “inxi -GSaz” command is :

xxxxxx@localhost:~> inxi -GSaz
System:
  Kernel: 5.14.21-150500.55.65-default arch: x86_64 bits: 64 compiler: gcc
    v: 7.5.0 parameters: BOOT_IMAGE=/boot/vmlinuz-5.14.21-150500.55.65-default
    root=UUID=7abe35aa-bcfc-4b53-aafc-1313b1a7f6dc splash=silent
    resume=/dev/disk/by-uuid/0dcab183-1a38-401f-90c7-9761dc70ed58
    preempt=full quiet security=apparmor mitigations=auto
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 7 dm: SDDM
    Distro: openSUSE Leap 15.5
Graphics:
  Device-1: NVIDIA GM206 [GeForce GTX 950] vendor: Micro-Star MSI
    driver: nvidia v: 550.90.07 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-19 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: none off: DVI-I-1 empty: DP-1,DVI-D-1,HDMI-A-1
    bus-ID: 01:00.0 chip-ID: 10de:1402 class-ID: 0300
  Device-2: Microdia USB 2.0 Camera type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-7.4.2:12 chip-ID: 0c45:636b class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 1.21.1.4 with: Xwayland v: 22.1.5
    compositor: kwin_x11 driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,vesa alternate: nouveau,nv
    gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 95 s-size: 513x292mm (20.20x11.50")
    s-diag: 590mm (23.24")
  Monitor-1: DVI-I-1 note: disabled model: Idek Iiyama PL2390
    serial: <filter> built: 2015 res: 1920x1080 hz: 60 dpi: 96 gamma: 1.2
    size: 509x286mm (20.04x11.26") diag: 584mm (23") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6.0 NVIDIA 550.90.07 renderer: NVIDIA GeForce GTX
    950/PCIe/SSE2 direct render: Yes
xxxxxx@localhost:~>

I hope this helps to solve the Firestorm problem.

Best regards,

Flash2020

@Flash2020 On Leap 15.6 GLIBC is 2.38, my suggestion look at upgrading your installation?
https://en.opensuse.org/SDB:System_upgrade

Hello,

Thanks for your reply.
Upgrading to OpenSuSE Leap 15.6 should fix the problem.
Thanks for the suggestion.

Best regards,

Flash2020