New computer build, new Tumbleweed install: root user ok, normal user slow, cannot restart/shutdown

I am writing this in the hope that someone may have a clue about what’s happening

I have recently built a new computer with relatively nice components (AMD Ryzen 7, 32 GB RAM, 500 GB SSD, 4 TB RAID HDD). Installed Tumbleweed (20210128) as I have it running since two years ago in two other machines and I am very satisfied.

At first it took sometime for me to get used to the new EFI boot logic, which is different from what I have used until now usual computer. No problems, got around this new for me stuff with no problems. Used the 500 GB SSD for the OS, EFI, BIOS and SWAP partitions/volumes. No problems here. Assigned the 4 TB RAID 1 to /home. Tumbleweed installed and restarted without issues.

After reboot I installed some things using the root user, tested around. Things worked nice and fast. No problems.

Then went on to configure myself as a normal user and copy my stuff. There began the problems. The first sign of problems were that things are very slow and sluggish. Firefox and Thunderbird take sometimes long time to start and are often difficult to close. When closing, a sign appears telleig that the application is busy and does not respond (this does not happen as root). Also, Firefox may work ok in single tab, but opening and using another tab is a nightmare. Once killed, both firefox and thunderbird remain as defunct processes and new instances cannot be started at once, but one must wait several minutes.

Another irritating issue: copying my backup from a USB 3 external drive takes ages. It begins at normal USB 3 speeds (up or even surpassing 100 mb/s) but then grinding to an almost halt at less than 10 Mb/s. This does not happen if I test copying the files to the /home directory as root, in which case I may copy 1 Tb in less than 3 hours.

Lastly, the normal user cannot reboot or shutdown, despite having the same privileges as in my other computers where this is possible. This, I believe, is the first time I see in a fresh openSUSE install.

I am completely baffled. I have disconnected all components, rearranged, connected again, installed and nothing. Changed the location of SATA connectors, nothing. Installed using different file systems (ext4, XFS, BFRS) nothing.

I have some doubt that may be there are hardware issues. One possibility is that the 5400 rpm HDD are sort of bottlenecking the rest, but this is hard to believe as file copy to the HDD works fast and well when using the root account. Also for example, watching a short video stored in the HDD is not a problem.

Now, if anyone has a clue I will be thankful.

In case this is of interest:

systemd-analyze blame
10.266s systemd-fsck@dev-disk-by\x2duuid-bd680a10\x2dca05\x2d438e\x2da2cd\x2debddba4559e1.service
 2.535s smartd.service                                                                           
 2.311s home.mount                                                                               
 2.196s udisks2.service                                                                          
  894ms dracut-pre-udev.service                                                                  
  769ms dracut-initqueue.service                                                                 
  620ms display-manager.service                                                                  
  411ms user@1000.service                                                                        
  253ms firewalld.service                                                                        
  210ms initrd-switch-root.service                                                               
  205ms postfix.service                                                                          
  136ms plymouth-quit-wait.service                                                               
  115ms plymouth-switch-root.service                                                             
  114ms upower.service                                                                           
  101ms user@0.service                                                                           
   89ms initrd-parse-etc.service                                                                 
   59ms sysroot.mount                                                                            
   55ms dev-disk-by\x2duuid-a38191b7\x2d872b\x2d48ed\x2d84cd\x2da807ae0820d4.swap                
   54ms systemd-udevd.service                                                                    
   51ms systemd-udev-trigger.service                                                             
   42ms polkit.service                                                                           
   42ms apparmor.service                                                                         
   34ms systemd-journal-flush.service                                                            
   27ms NetworkManager.service                                                                   
   25ms ModemManager.service                                                                     
   25ms chronyd.service                                                                          
   25ms systemd-logind.service                                                                   
   22ms boot-efi.mount                                                                           
   22ms kbdsettings.service                                                                      
   19ms systemd-journald.service                                                                 
   19ms systemd-random-seed.service                                                              
   19ms dracut-cmdline.service                                                                   
   18ms avahi-daemon.service                                                                     
   13ms mcelog.service                                                                           
   13ms plymouth-start.service                                                                   
   13ms systemd-tmpfiles-clean.service                                                           
   13ms modprobe@fuse.service                                                                    
   13ms auditd.service                                                                           
   12ms systemd-fsck@dev-disk-by\x2duuid-8A37\x2dFD8E.service                                    
   11ms plymouth-read-write.service                                                              
    9ms issue-generator.service                                                                  
    9ms modprobe@configfs.service                                                                
    9ms systemd-tmpfiles-setup.service                                                           
    9ms initrd-cleanup.service                                                                   
    9ms systemd-vconsole-setup.service                                                           
    8ms user-runtime-dir@0.service                                                               
    8ms alsa-restore.service                                                                     
    7ms nscd.service                                                                             
    7ms sys-fs-fuse-connections.mount                                                            
    7ms user-runtime-dir@1000.service                                                            
    7ms systemd-update-utmp-runlevel.service                                                     
    7ms \x2esnapshots.mount                                                                      
    6ms boot-grub2-i386\x2dpc.mount                                                              
    6ms systemd-update-utmp.service                                                              
    6ms systemd-fsck-root.service                                                                
    6ms dev-hugepages.mount                                                                      
    6ms boot-grub2-x86_64\x2defi.mount                                                           
    6ms dev-mqueue.mount                                                                         
    6ms modprobe@drm.service                                                                     
    6ms systemd-tmpfiles-setup-dev.service                                                       
    5ms accounts-daemon.service                                                                  
    5ms opt.mount                                                                                
    5ms systemd-sysctl.service                                                                   
    5ms sys-kernel-debug.mount                                                                   
    5ms root.mount                                                                               
    5ms sys-kernel-tracing.mount                                                                 
    5ms srv.mount                                                                                
    5ms kmod-static-nodes.service                                                                
    4ms usr-local.mount                                                                          
    4ms systemd-remount-fs.service                                                               
    4ms systemd-modules-load.service                                                             
    4ms var.mount                                                                                
    4ms mdmonitor.service                                                                        
    3ms sound-extra.service                                                                      
    3ms systemd-user-sessions.service                                                            
    3ms initrd-udevadm-cleanup-db.service                                                        
    3ms rtkit-daemon.service                                                                     
    2ms dracut-shutdown.service                                                                  
    1ms tmp.mount                                                                                
    1ms sys-kernel-config.mount 

Just to rule out the obvious, do you mean that you logged in as root in a console terminal to do the above and you worked with the command line or did you a graphical login as the user “root”?

Thank you for your answer. I logged as root in the GUI to do the above. I have now deactivated smartd and the delays above are substantially lower.

1.710s systemd-fsck@dev-disk-by\x2duuid-bd680a10\x2dca05\x2d438e\x2da2cd\x2debddba4559e1.service
897ms dracut-pre-udev.service
813ms udisks2.service
767ms dracut-initqueue.service
589ms display-manager.service
444ms user@1000.service
364ms home.mount
252ms firewalld.service
229ms initrd-switch-root.service
192ms postfix.service
102ms initrd-parse-etc.service
101ms plymouth-quit-wait.service
96ms plymouth-switch-root.service
96ms upower.service
61ms systemd-udevd.service
51ms sysroot.mount
50ms systemd-journal-flush.service
50ms systemd-udev-trigger.service
48ms apparmor.service
46ms dev-disk-by\x2duuid-a38191b7\x2d872b\x2d48ed\x2d84cd\x2da807ae0820d4.swap
43ms polkit.service
32ms ModemManager.service
29ms systemd-logind.service
25ms chronyd.service
24ms boot-efi.mount
22ms NetworkManager.service
20ms systemd-journald.service
20ms kbdsettings.service
17ms systemd-random-seed.service
17ms dracut-cmdline.service

Never ever log in as superuser in the GUI, that way you can change ownership and permission to internal files of the desktop environment and forbid “normal” users from properly using some functions…
You can do everything you need logging in as normal user and then get superuser permissions when you need them.
Since this is a new install, I would consider a reinstall just to be sure you don’t have problems in the future. But you may take the risk and go ahead, it’s your system and your choice.

It may be the file indexing going on it takes a while to index the world

check top and see what is eating CPU

Also add a new user and check them

Thanks for the advice. I understand this, but I am confident it is not the problem here. I installed two or three times already, not always logging in as root first, and the behaviour is consistent with what I described.

The problem is not so much you doing this (it is your system), but people here are reluctant to give advice about such a system.

Thanks for your answer. This may be a reason, of course. The task manager shows that sometimes firefox is big as a monster.

We cannot help you based on vague info. Is there a general problem for a “non root” user? Or is it just a Firefox problem? What is the meaning of "normal user slow (there is nothing obvious in the log you posted)? And “as big as a monster” provides no technical info.
Is there a disk problem (possibly file-indexing related) or just the cpu clogged by an application gone astray?
Posting here the first few lines of “top” might help us understand what you mean.

Thanks everyone for your interest and help. The problem was the difference in speed between the ssd (OS) and hdd (/home). Solved now by using ssd for /home as well.


some observations

on my installs, PCs and laptops,

Firefox and Thunderbird are very slow to close down, hence when closed they cannot be restarted within a couple of minutes,
here its quicker when required to logoff and login again (about 10 seconds)

similar with OpenOffice, if worked carried out on spread sheets >200k

this is independent of whether the machines are ssd-hhd or ssd-ssd for /, /home



partitions are ext4

I’m about to add a small (240GB) ssd to my system. The purpose is to increase speed. I thought /home would go onto the hdd because of the large amount of available space for programs, documents etc. This is a question, not a criticism: if everything is on the ssd, what is the point of having a hdd? Sounds like I should get a bigger ssd and ignore my 1TB hdd.

You don’t have encrypted discs. And how are you placed with the permissions

I ordered a new SSD (1 Tb) for /home and left the HDD raid for archival storage (things that are not often used).

In the ~/ folder (AKA /home/<username>/) you find several “dot folders” like .config or .cache where applications store their settings, preferences and the like. Some applications, firefox is a good example, make an extensive use of .cache (check your ~/.cache/mozilla/firefox/ as an example) and if /home is on a slow disk you may feel those applications as “choppy”. Virtual machine disk images might be another frequent example.
Some of us may still put their /home on a small SSD, but then link to separate /Documents, /Downloads etc. folders actually placed on a larger (and slower) HDD, or even on a remote storage. Or just store large archives (say, photo collections or movies) on the slower disk.
The OP likely found that the root user was “faster” just because the root’s home is (and was) at /root, so on the SSD from the beginning; for example, the .cache folder for user root is at /root/.cache

PS: that was somewhat relevant, but please avoid stealing someone else’s thread.

This is an oxymoron. If you have only one disk, you do not have RAID (Redundant Array of Independent Disks](

No, it is not. I have two HDD’s in RAID 1 configuration.