new ATI driver released

Hi all,

more of a news item. The new ATI 9.10 catalyst driver has been released. From what I’ve read its supposed to support the kernel used in 11.2. I haven’t tried it yet (activity for the weekend), but thought I’d let the other ati users out there know about it

ATI Catalyst™ Proprietary Display Driver

Thanks gavinto. My HP ProBook 4710s is just bursting to try it out, but as a newbie to the ATI scene I’ll look for tips from you after the weekend.

Installed on v11.1 and it enables my HD5870 correctly.

However, not sure if it is related but my HD3870 in the same machine is not fully enabled since 9.9.

Make sure that you have kernel-desktop/server/xen-devel that matches your kernel if you want to use the Linux Catalyst driver auto-builder (otherwise you will have 3D issues because the modules won’t build due to incomplete-source errors). I ran into this with a fresh install of 11.2 RC1; installing kernel-desktop-devel that matches my kernel let me go back and rebuild the modules (/lib/modules/fglrx/build_mod/./ and /lib/modules/fglrx/./, in that order, and each run using sudo or as root) and solve the performance woes (and even let me use compiz).

I wasn’t able to get this to install using 11.2. I followed my usual procedure

./ --buildpkg SuSE/SUSE112-AMD64

Except I’ve put 112 for the buildpkg (instead of 111 now that I’m running 11.2).

I get a crappy non specific error:

Generating package: SuSE/SUSE112-AMD64
Package build failed!

Yea, that confused me too. And when I did manage to successfully install it, it hung when starting X11. I tried a number of things and it finally worked (I’m not sure how). Note that I have a Radeon 4870 and I’m running the 64-bit version of the OS.

  1. Firstly, I think it may have gotten fixed when I installed glibc-32bit and glibc-devel-32bit.
  2. Moreover, I installed the driver directly instead of creating a distribution-specific package. This might not be as important.

So try 1 first. If that doesn’t work, try 2 as well to see if it works. Note that if you install it directly, you can use /usr/share/ati/ to uninstall the driver.

Ok, well I did 1, but same result. Then tried 2, but when I dropped to runlevel 3, then did Sax2 -r -m 0=fglrx and went back runlevel 5, everything looks like I’m using a VESA mode driver.

Windows paint really slow, can’t turn on 3d effects in KDE.

hmmm, that’s unfortunate. I needed to do a full reboot before it was working.

Anyway, thanks for the help. I’ve got it working. Hopefully the next driver release will do the package building.

Out of curiosity, do you still need step 2 after reboot or did you go back to making a distribution package?

Also, note that you can check always whether or not the driver is there properly by typing the following in console:

$ glxinfo|grep OpenGL

hello i try to install the Ati driver in RC.1 but a i get this error when a i put this glxinfo|grep OpenGL.

X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 135 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 16
Current serial number in output stream: 16

install without errors and is like no driver is intalled

Thanks for the information. Could anyone decipher for me: is it worth installing the driver for a built-in ATI Radeon x200 on an ASUS P5RD1-V main board and for a built-in ATI Mobility Radeon x1250 on an ASUS A7U notebook? I can’t understand what are those “families” in the release notes :frowning:

Hi all,

finally got some time to try this out. I confirmed that I had the requisite libraries installed (freetype wasn’t installed by default)

I ran the script in GUI mode selecting automatic. No error messages were in the shell. When it finished I ran aticonfig – initial. Again no special errors.

I rebooted, and no 3d! anyone have luck with this yet?

name of display: :0.0
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 135 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 14
Current serial number in output stream: 14

One suse person appears to have had some luck, but its not clear to me what version they used

ATI Catalyst 9.10 - Suspend - openSUSE Forums

Is there a chance that this is a bug. The forum poster in this link seems to think so…
AMD Catalyst 9.10 Released - Page 4 - Phoronix Forums

If so is it an Opensuse issue or an ATI bug?

gavinto wrote:

> Is there a chance that this is a bug. The forum poster in this link
> seems to think so…
> ‘AMD Catalyst 9.10 Released - Page 4 - Phoronix Forums’
> (
> If so is it an Opensuse issue or an ATI bug?

No chance this can be an openSUSE bugs because openSUSE does not provide the
ATI drivers, they are still a bit “proprietary” :slight_smile:

OTOH, openSUSE does not address any bug comming from ATI or Nvidia “closed”
drivers, they are automatically “ignored” in bugzilla.



ATI no longer provides the proprietary drivers for cards older than the radeon2000 series after the Catalyst 9.3 release. They have been moved to legacy status.The Open Source radeon driver meets or beats the 2D performance, and the 3D performance is slowly closing the gap.

For the people whose driver is not loading after install (i.e. “glxinfo|grep OpenGL” doesn’t give the right stuff), you probably want to look for any lines starting with (EE) in your /var/log/Xorg.0.log to get a hint on what is failing.

You might also want to look at this thread:

Made a fresh install of RC2 and… After some troubleshooting i was changing the digital cable to a analog one between radeon 3650 card and my flat-screen. The flickering was gone. Still the system was very slow switching between windows, scrolling etc.

Downloaded latest ati driver ( installed it and went to /lib/modules/fglrx/ and run “./”. After that i had working fglrx and Desktops effects.


I have a Mobility Radeon HD 4500 Series with kernel on Dell studio laptop.

Just upgraded to OpenSuse RC2, downloaded the new ATI catalyst driver and after installing the driver I got the same error as gavinto (# 12).

I uninstalled the driver and followed PGHammer (# 2).

Thanks! Everything works (and looks) great now.

I have a Radeon 2600 (mobility?), and haven’t had luck. I submitted a bug to the ATI site, and received an email from a developer saying that Opensuse 11.2 won’t be supported until the 9.11 driver is release… not good news for those of us who still have troubles.

any other users of this card out there get things working?

One last note, The developer at AMD/ATI has indicated that Catalyst 9.11 supporting Opensuse 11.2 should be released by the end of November