New AMD Catalyst 15.5 for openSUSE released

As Thread Title said AMD released the new AMD Catalyst™ 15.5 Proprietary Linux x86 Display Driver, anyone tried them ? link here

Distributions supported:


  • Red Hat Enterprise Linux Suite 7.0, 6.5, 6.4
  • Ubuntu 12.04.4 LTS, 14.04 LTS
  • SUSE® Linux Enterprise 11 SP3, 12
  • OpenSuSE 13.1 <— I wonder why still 13.1 though


I will try them when I get home ( around Sunday ) but I would like to know if anyone tried them ( I will on my R7 250x ).

On a side (kinda) note I noticed too late they are only for x86 …so they aren’t for x86_64 ?

The drivers above support English only.
The display driver requires POSIX shared memory to be enabled on the system.
Kernal Sources package is no longer required if Kernel Header package is installed.
32-Bit packages must be installed for 64-Bit Linux drivers to install or work.

Have you seen this:–-new-makerpm-amd-script-is-available?highlight=Catalyst

The new driver is now available in the standard repo,
amdcccle (Catalyst Control Center) reports Driver Package version 15.101.1001.

I have just begun to evaluate, after reboot.

Passes my first test, STR (sleep) now sleeps and restore properly with Desktop Effects (Compositing) enabled.
One cycle, at least.

Tested here as well on openSUSE13.2_64, Kernel and KDE 4.14.8 on AMD A8-3880 APU (GPU 6550D).

Haven’t run in to any problems so fare.