New 64-bit openSUSE-11.4 KDE installation on my main PC (Core i7-920)

7-months after 11.4 is released and only then do I install 11.4 ? Yes - I’m conservative. Very conservative ! And after some hours I have to say it runs great !

Why wait so long ? I like stability. All the apps I want are now packaged (and have been packaged and running for some time, and many debugged/improved over that time). And finally this was a long weekend where I don’t have other commitments (which does not happen all that often). An ideal time for an openSUSE install. :slight_smile:

It was a successful installation (albeit not a perfectly smooth configuration experience) of openSUSE-11.4 on my main PC - an Intel Core i7 920 with a nVidia GTX260 graphics card.

1st do Backups

Before installing I backed up. Not only everything on /home, but also key files from /etc and /boot. ie fstab, 50-sound.conf, menu.lst … and some others. I also put on a USB stick easy to get copies of my bookmarks from firefox and my /home/oldcpu/.thunderbird email directory. I made a list of the custom programs I use the most, to help me check off programs as I re-installed. I then I installed.

Disconnected Webcam

I unplugged my webcam before installation. I did not want it confusing the openSUSE installer as to the order of sound devices upon install

openSUSE installer installation

Now I have a test partition with 11.4 on it already on this PC and I’ve booted to 11.4 liveCDs many times, so one WOULD expect installation to be smooth. And installation was smooth for all open source aspects. Perhaps the only noticeable mentions were I did NOT use the automatic configuration, I selected a ‘new’ installation with KDE desktop, changed the kernel from kernel-desktop to kernel-default (my personal subjective choice) and I had to tune the partitioning to put openSUSE-11.4 on top of my old openSUSE-11.3 install. Since openSUSE-11.4 has been out for 7 months, the update download was LONG in duration - it took 23-minutes, and I have a VERY high speed internet connection. But I anticipated that, and use the time to wash dishes and do some household chores.

Sound worked immediately ! :slight_smile: Wired Ethernet worked! Nouveau driver worked coming up at the maximum 1920x1200 resolution !

Argggg … Proprietary Driver Installation Problems

I downloaded the proprietary nVidia driver ( and then went to YaST > System > /etc/sysconfig/editor > system > kernel and set ‘no_kms_in_initrd’ to YES. I rebooted, typed ‘nomodeset 3’ and after the kernel load the screen went black. No text messages. Nothing. It stayed black. It continued to stay black. After some minutes I concluded it was going to remain black. <CTRL><ALT><Delete> appeared to have no effect. I did a hardware reset. Rebooted, removed the ‘nomodeset 3’ and again after the kernel load the screen went black. No text messages. Nothing. It stayed black. Ouch. My face turned into a scowl and I turned into Mr.Grump in our apartment for the 10 minutes in which it took me to sort this. My wife retreated to the far corner of the apartment during this time.

I rebooted (hardware reboot) again, and I chose ‘failsafe’ boot. That worked ! … So, clearly I needed a boot code to get the normal boot to work. I looked through the ‘failsafe’ boot codes, trying to figure out which one allowed failsafe to work when a regular boot fails. My eyes settled on ‘highres=off’ and I pondered that. Pondered it some more and decided to try it out.

SUCCESS Installing proprietary driver !!

So I rebooted with the boot code ‘highres=off nomodset 3’ and after the kernel load text could be seen ! :slight_smile: … The PC booted nicely to run level 3. I then installed the proprietary nVidia driver the manual way (used to be called ‘the hardway which is not hard’) and rebooted and the PC came up nicely to openSUSE-11.4 with the proprietary nVidia driver.

That black screen WAS strange - but it no longer appears and it is ancient history now with the driver now working with no such black screen faliures. I have a nice fast 1920x1200 resolution with special desktop effects on this KDE4.

Application install smooth

My remaining install was smooth - standard multimedia apps from packman (mplayer, vlc, xine, avidemux), microchips repos (xvidenc, divxenc, h264enc, audenc), plus installed skype, x11vnc (and tested it and it works taking over an 11.3 KDE desktop), nx, virtual box (taking over an existing Virtual install of another OS), wine (virtual dub with deshaker plug) … etc … My webcam works, My mic works. My wireless network printer works. My wireless network scanner works. Hotplug USB works.

I still have a few more custom programs to install, but overall (with the exception of the black screen of death delay) this was pretty painless.

My current assessment - its better than the openSUSE-11.3 KDE4 (also on this PC) that I replaced. I have the perception of a slight speed improvement. I like the fonts better (which is strange as I kept my old /home, but I figure the newer nVidia driver with the newer KDE is the reason).

Really like pulse audio

BUT most of all, and I know, this is absolute heresy to some, but MOST of all I like pulse audio on this PC. Sound worked immediately. Worked well immediately. I installed pavucontrol and configured 5.1 sound. I like it.

I installed the packman packaged pulseaudio-equalizer. Pulseaudio-equalizer looks like this:](
[click on above image for larger view]

The control for that works well on this old Core i7 920 PC. Sound worked in Firefox. Sound worked in smplayer. It worked in Skype. First time. Every time (thus far).

This is only a few hours after the install. I have the remainder of this long weekend to play with it. I’m sure I’ll encounter some hiccups along the way, as I have some custom compilations ahead of me.

But right now I’m a happy camper.

Some detail on my system:

oldcpu@corei7:~> inxi -F
**System:**    Host: corei7 Kernel: x86_64 (64 bit) 
           Desktop KDE 4.6.00 Distro: openSUSE 11.4 (x86_64) VERSION = 11.4 CODENAME = Celadon
**Machine:**   Mobo: ASUSTeK model: P6T DELUXE V2 version: Rev 1.xx Bios: American Megatrends version: 1108 date: 09/21/2010
**CPU:**       Quad core Intel Core i7 CPU 920 (-HT-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) 
           Clock Speeds: 1: 1600.00 MHz 2: 1600.00 MHz 3: 1600.00 MHz 4: 1600.00 MHz 5: 1600.00 MHz 6: 1600.00 MHz 7: 1600.00 MHz 8: 1600.00 MHz
**Graphics:**  Card: nVidia GT200 [GeForce GTX 260] 
           X.Org: 1.9.3 drivers: nvidia (unloaded: nouveau,vesa,fbdev,nv) Resolution: 1920x1200@50.0hz 
           GLX Renderer: GeForce GTX 260/PCI/SSE2 GLX Version: 3.3.0 NVIDIA 280.13
**Audio:**     Card-1: Intel 82801JI (ICH10 Family) HD Audio Controller driver: HDA Intel Sound: ALSA ver: 1.0.23
           Card-2: Logitech driver: USB Audio
**Network:**   Card-1: Marvell 88E8056 PCI-E Gigabit Ethernet Controller driver: sky2 
           IF: eth1 state: down speed: N/A duplex: N/A mac: 00:24:8c:7e:ee:38
           Card-2: Marvell 88E8056 PCI-E Gigabit Ethernet Controller driver: sky2 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 00:24:8c:7e:ee:39
**Drives:**    HDD Total Size: 1500.3GB (62.8% used) 1: /dev/sda ST31500341AS 1500.3GB 
**Partition:** ID: / size: 29G used: 5.8G (21%) fs: rootfs ID: / size: 29G used: 5.8G (21%) fs: ext4 
           ID: /home size: 1.2T used: 856G (76%) fs: ext4 ID: swap-1 size: 6.82GB used: 0.00GB (0%) fs: swap 
**Sensors:**   Error: You do not have the sensors app installed.
**Info:**      Processes: 181 Uptime: 1:51 Memory: 795.7/5973.6MB Client: Shell inxi: 1.7.23

Webcam is a Logitech C910:

Bus 002 Device 002: ID 046d:0821 Logitech, Inc.

and network printer/scanner is an HP Photosmart Premium C309a.

Custom guvcview Compile/Build

I performed my first custom build on this new 64-bit openSUSE-11.4 install, this time of the application guvcview (a webcam application). My experience is this is a SUPERB application that works well with my uvc webcams. So I downloaded from GTK+ UVC Viewer the file guvcview-src-1.5.0.tar.gz

I uncompressed/untarred the tarball guvcview-src-1.5.0.tar.gz and then in a terminal changed to the directory where the uncompressed files were located. I read the README file, skimmed through the standard INSTALL file, and then proceed with a custom build running:

./configure --prefix=/usr

and I obtained this error:

configure: error: Package requirements (gtk+-2.0 >= 2.14.0 glib-2.0 >= 2.10.0 gthread-2.0 gdk-2.0 >= 2.10.0 gdk-pixbuf-2.0 sdl >= 1.2.10 portaudio-2.0 libpng libavcodec libv4l2 libudev) were not met:

No package 'sdl' found
No package 'portaudio-2.0' found
No package 'libavcodec' found
No package 'libv4l2' found
No package 'libudev' found

so I then installed libSDL-devel, libudev-devel, portaudio, portaudio-devel, libffmpeg (many dependencies), and libv4l-devel.

I then again tried:

./configure --prefix=/usr

And this time success!! So I followed it up with:


which succeeded !

Then since I have ‘checkinstall’ installed, rather than run ‘make install’ as user root, I instead ran with root permissions:


and I filled in the various fields. That completed successfully and in /usr/src/packages/RPMS/x86_64/ it created the rpm guvcview-src-1.5.0-1.x86_64.rpm

I then installed guvcview-src-1.5.0-1.x86_64.rpm and it runs nicely from the command ‘guvcview’. !

Some screen images:

Image Controls tab:](
[click on above image for larger view]

Video and Files tab:](
[click on above image for larger view]

Audio tab (note I have not checked the guvcview recorded audio yet) :](
[click on above image for larger view]

So success there and it is nice to see such an EASY build on this 64-bit openSUSE-11.4.

Reference checkinstall, note the rpms it creates are NOT for distribution outside of one’s own PC !

FlashPlayer custom install

I modified the custom openSUSE flash player setup using the Fix Your Flash 11.4 guide created by caf4926 as guidance, although I did not precisely follow it.

FAQ Guidance:

The excellent caf4926 FAQ guidance has one remove one’s current installed flash-player and then download the beta (now release candidate) version of flash-11and install (the downloaded) to the directory /usr/lib64/browser-plugins

What I did

I did remove the rpm ‘flash-player’ and remove the rpm ‘pullin-flash-player’ per the caf4926 FAQ guidance. I did go to the Adobe site for Flash-11 and download the plugin for 64-bit (for flash-11) from that site. It comes as a tarball and I uncompressed and looked inside. Inside the tarball were more than one file. Some that I noted were:

    (in the tarball root)
  • flash-player-properties
    (in a directory in the tarball /usr/bin )
    (in a directory in the tarball /usr/lib/kde4/ )
  • flash-player-properties.desktop (in a directory in the tarball /usr/share/applications/ )
  • kcm_adobe_flash_player.desktop (in a directory in the tarball /usr/share/kde4/services )
  • many icons ( in subdirectorys in the tarball /usr/share/icons/hicolor/ )
  • flash-player-properties.png (in a directory in the tarball /usr/share/pixmaps)

Using that tarball directory, and caf4926’s faq as guidance, I copied only the 3 files I highlighted above with root permissions via the command:

cp flash-player-properties /usr/bin/. 
cp /usr/lib64/kde4/. 
cp /usr/lib64/browser-plugins/. 

where only the last of those 3 commands is the caf4926 FAQ recommendation. Note that since this is a 64-bit PC I copied two of the files into lib64 and not lib.

My personnel view is only the last of those 3 commands (which is precisely from the caf4926 FAQ recommendation) is absolutely necessary, but I suspect ‘flash-player-properties’ and ‘’ add something minor ( ? ) to the configuration of flash. The files I did not copy appear to me to be more in support of putting a flash-player icon on the desktop, which I am not interested in doing. Hence I did not copy them, although I believe that one could.

Flash performance

So, how does flash player run on this 64-bit openSUSE-11.4 ? It runs GOOD ! REAL GOOD ! … IMHO in both firefox and google-chrome in full screen it is running superior than what I had previously experienced on openSUSE-11.3.

Installed OCR programs gImageReader and Tesseract

As an expat living in a country where my language skills in the important official language are very limited, it is imperative that I can scan and translate documents that arrive in the mail. Hence I wanted the capability to scan/translate German, and since I also take French lessons weekly I wanted the capability to scan/translate French language (both into English). The first step in this is to get a good scan in a foreign language and then later I can copy the scanned/OCR’d text into a translation program.

So I installed the OCR program teseract and the OCR front-end program gImageReader which is a front end to tesseract.

In openSUSE-11.3 I only had version 2.x of tesseract installed, so for 11.4 I decided to go with the updated OCR engine 3.0 of tesseract. This installation is not straight forward, as one needs to grab the apps and dependencies from different repositories. Fortunately EVERY package needed has already been compiled by openSUSE community volunteers, so it was only a matter to add the repositories (incrementally as it turned out), sort the dependencies and errors, and then when done, remove the extra repositories. I have done this before with openSUSE-11.3 (with some help) and here are the previous threads on this subject: OCR and Linux and How does one meet a python2-devel dependency requirement on openSUSE-11.3

So first I did a search for tesseract and then gImageReader, found their packing and added their associated repositories. Note I am NOT a believer in the one click install, as I prefer to have more step by step control over the installation, as I learn more that way. With more knowledge, I am able to debug better, and I believe that saves me time in the long run.

I decided to try the ‘factory’ (for openSUSE-11.4) version of tesseract, which I concede is a bit risky:

zypper ar contrib-factory

and I added malcomlewis’ python directory to obtain gImageReader:

zypper ar malcolmlewis-python

I also, since I was working on this translation/OCR subject, installed a number of German and French language dictionaries. So I installed from YaST aspell-en-huge (this was automatically added when I added the factory contrib repository), tesseract, tesseract-traineddata-deu, tesseract-traineddata-fra (all from factory contrib), aspell-fr, aspell-de, ispell-fr, ispell-german, mspell-french, mspell-german (all from oss). I noted igerman98-loc was picked up as a dependency. Also I had previously as part of the basic openSUSE-11.4 install already had aspell, aspell-en, hunspell, hunspell-tools, ispell, ispell-american, libenchantl, myspell-american.

Then I attempted to install python-gimagereader from malcomlewis repository, but I encountered the error ‘nothing provides python-enchant’. I recall now seeing this earlier, and after searching I realized this error is a result of my choosing to go for the ‘factory’ contrib repository instead of the ‘standard contrib’ repository’. So I then added the standard contrib repository :

zypper ar contrib-standard

and tried again to install ‘python-gimagereader’ from the malcomlewis repository. This time it worked picking up as dependencies the applications python-gimagereader, gtkspell, python-ReportLab, python-egg, python-enchant, python-gnome-extras, python-gtk-spell, python-imaging-sane, python-poppler !

After the install was complete, I opened a terminal and typed ‘gimagereader’ and it did NOT run, but rather I received the error

oldcpu@corei7:~> gimagereader
Could not load sane or twain, scanning will not work.
Failed to load gImageReader modules, check your installation: No module named Image

I then retreated into ‘think mode’ . Why did this not work ? I know I have sane and python-imaging-sane installed and that I can scan. So gImageReader must need some ‘image’ program, and also some ‘scanning’ or ‘ocr’ program. But which one ? I launched YaST and took a look at what python applications are NOT installed yet on my openSUSE-11.4 . I noted ‘python-imaging’ was not installed, and that made sense to me that it could be the ‘module named image’ that the error message was referring to.

So I installed ‘python-imaging’. I noted that install also picked up the dependencies: gocr-gui, python-tk, tix, tk. … which made me think that perhaps the missing gocr-gui is why I obtained the ‘could not scan’ message.

I ran gimagereader again, and it worked ! I took a scanned French document (jpeg file) and did an OCR on it, and it worked nicely for me. As soon as I confirmed it was working, with root permissions I removed the repositories I had added, as I like to keep my openSUSE repository list ‘lean and mean’ :

zypper rr contrib-factory
zypper rr malcolmlewis-python
zypper rr contrib-standard

Some gImageReader images:

First a translation of a scanned French document (where the scan is on the left, and the OCR to French on the right) :](
[click on above for larger version]

Note on the right of that image, the words underlined in red, where the spell check did not like the scan !

If I right click on the underlined red word (such as illustrated below) the spell check gives me some choices to fix the world:](
[click on above for larger version]

and finally after very quickly fixing the various underlined red words I see:](
[click on above for larger version]

after which it is a simple matter to save the file and/or immediately copy the text on the right into a translation engine to translate to English. Now the above is NOT a perfect spell check, and I also find it useful to copy and paste the text into Office Libre, and with a foreign language (French in this case) dictionary do another spell check.

Its good to now have this running in openSUSE-11.4.

[note the above images are with the ‘older’ gImageReader-0.8.1. There is also a newer version 0.9.0 available although it is not (yet) packaged for openSUSE].

Update to gImageReader (0.9.0) now available for openSUSE

[note the above images are with the ‘older’ gImageReader-0.8.1. There is also a newer version 0.9.0 available although it is not (yet) packaged for openSUSE].

The openSUSE forum moderator/packager malcolmlewis packaged today gImageReader version 0.9-1.1 (replacing the older version-0.8.1-4.1) with the updated version being in the same repository:

I installed it and it is working well (after test).

MANY thanks to malcolmlewis for this updated packaging.

The changelog notes these changes between version 0.8.1 and 0.9.0:

2011-01-01 Sandro Mani 
 * src/
   Last-minute bug where spellcheck could stop working >.<
 *** New release: gImageReader 0.8.1**

2011-01-02 Sandro Mani 
 * src/gimagereader.xml
   Change scrollbar policy for scrolled windows in configuration/dictionaries to avoid inconsistent display
 * */*.py
   Use correct GLP3 license header
   Also generate UTF-8 translations

2011-01-19 Sandro Mani 
 * bin/gimagereader
   Write gtk load errors to sterr instead of stdout, to make them appear in gimagereader.exe.log on windows.

2011-01-30 Sandro Mani 
 * src/gimagereader.xml, src/manual.html
   Change "dictionaries" to "languages" in an attempt to make it less confusing.
 * src/
   Improve tesseract path autodetection on windows.

2011-03-12 Sandro Mani 
 * gimagereader-win32-support
   Updated various modules, fixed crasher when opening certain PDF documents with images.
   Fixed issue where corrupt modules with the same name as bundled ones in the system directory would prevent the program from starting.
 * src/
   Blur downscaled images
   Fix possible inconsistent state of OCR button
 * src/gimagereader.xml
   Added various tooltips

2011-03-20 Sandro Mani 
 * src/
   Use unicode strings for non-ascii chars
   Added language profiles: chinese, korean, japanese, hebrew, arabic, croatian
 * src/, src/
   Added multipage-recognition support for multipage PDF
   Fixed selection frame border not displaying at certain zoom levels
 * src/
   Add all formats supported by gdk_pixbuf to file filter for open dialog
 * src/
   Added recent file chooser
 * gimagereader-win32-support
   Make uninstall entry appear also in control panel
 * src/, src/
   When auto-installing new dictionaries, new dictionaries would not appear in main language selector until program restart
 * po/*
   Many translation typo fixes and updates
 * src/, src/gimagereader.xml
   Added cancel button to stop recognition

2011-03-21 Sandro Mani 
 * src/
   Setting to not query dictionary autoinstallation was ignored
 * src/
   Fix backtrace which occurred when calling __position_canvas when canvas is not visible
   Fix selection frame moving if resolution changed
 * src/
   Make image controls insensitive when no image is loaded
 * gimagereader-win32-support
   Fix translations not working

2011-03-24 Sandro Mani 
** * New release: gImageReader 0.9**

I noticed that we have a function named _scout() defined in the environment. If you create a lib that has *.pc files in the pkgconfig directory, _scout hides them so I disabled my _scout().

Not sure how your second installation of “Custom guvcview Compile/Build” ever worked. :slight_smile: Unless it put the pkgconfig files in the /usr/share folder the second time, somehow.

Hey, I noticed that you have two suse 11’s but I have one suse 11.4 and one suse 10.0 and the bootloaders are incompatible.

I think the 11.4 bootloader should save and restore 18 blocks, not just 1.

Compare /var/log/YaST2/y2log_bootloader (hd0)1+17 ??? with /boot/backup_mbr.

Thanks for the great work you’re doing. I’ve read a few of your posts on 12.x developments, and I think you really have the right idea – actually setting aside a computer for test and seeing what it’s like from a user’s angle.

And compiling apps on suse 11.4. It’s kind of late in the game but then you’re not the only one on the team. I think others should have tried that too, maybe even spot checking some of the RPMS that COULD NEVER HAVE BEEN COMPILED on the system they are used on.

I’m recompiling kde, for example. :wink: [Interesting effects as the two systems occasionally collide. :slight_smile: I’m putting the new one in usr/local (symlinked to the real folder and easily un-symlinked as these effects become more… how shall I say, “pronounced”) and will move it to the main system folders on a second or third pass.]

Anyway, thanks for the dedication, sweat, and almost blood which comes with the kind of work you’re doing here.*

Howdy - I am trying SUSE or openSUSE as my base OS and putting VirtualBox on that base OS. On that VB I intent to run W7U64b and other Linux OSes (to explore them). Does this makes sense to you? I now know almost nothing about Linux or VB. I do not know where to ask this question that is why I am here. Is there a better place to ask it?:

freeCat, I recommend you go to our Virtualization forum and ask those questions.

I have installed other OS on under VirtualBox on my openSUSE PC and I’m happy with it, but I am no expert. As noted that forum area is a good place to ask.