New 42.2 domain name resets in network settings

I’m doing a clean install of 42.2. I have a fixed IP and a domain name. In Yast Network Settings in the Hostname/DNS tab I enter the machine name in the Hostname box and my domain name in the domain name box. (Initially the domain name entry is “home.”) I select “No” for “set domain name via DHCP”. However, every time I re-open Network Settings the domain name is set back to “home.” My old 13.1 system with equivalent settings on this same network retains the domain name, including after reboots. What do I need to do to make 42.2 retain the domain name setting?

Are you using “wicked” for network? Or are you using “NetworkManager”?

If you are using NetworkManager, try switching to “wicked”. That’s because “NetworkManager” doesn’t really follow the settings that you configure with Yast. It sets hostname and domain name its own way.

Yes, I am using wicked.

Then I’m puzzled by what you are seeing. I have never had that problem. Setting hostname and domainname in Yast Network Settings has always worked for me, and the settings have stayed.

I have no clue - everything else is just as it set itself up save that I had to specify mydomain name in postfic/ to get it to send mail, and even so it sends “sigma.home” as the "from address"and amavisd dies on startup complaining that “sigma.home” is not a valid FQDN. I am guessing that whatever is resetting it in Network Settings is responsible for these other problems as well.