New 12.3 cannot find the repositories

Hello. I am a newcomer to OpenSuse. I have installed 12.3 KDE. I logged in for the first time this morning and the system did an “automatic configuration.”

I was then presented with a list of packages which need updating. When I applied the markings I got a series of messages indicating that the repositories cannot be found. That seems very strange because the version is so recent.

I was also warned that the system must be updated.

There was an internet connection.

How do I fix this? I don’t know what the problem is so I don’t know what to search for.

There is a bugaboo with network connection settings in openSUSE.
Here is how to solve it:
Go to your menu and go to “system” and open up YaST
In that go to “network devices” and from there click on “network settings”
In the first tab switch to the option “user controlled with network manager”
Hit ok and you are done

Your network may be Not Configured.

Thank You,

open konsole and use the command

su -
zypper clean --all
zypper ref -f

Thanks for the replies. I will try those fixes. I had trouble locating an iso file to download because the first published links I tried were incorrect and I wondered whether the repository locations may also have been incorrect.

Well, they may be correct or not. Pleas show them:

zypper lr -d

In any case, do not forget to Disable the one that points to the dvd.

Hello. Thanks to all. The procedure outlined by madmanRB got downloading working. I’ll mark this particular issue solved. [EDIT: no can do] I ran the command suggested.

ender@linux-mua2:/data/sets> zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | repo-debug | openSUSE-12.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/12.3/repo/oss |
2 | repo-debug-update | openSUSE-12.3-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/12.3 |
3 | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss | No | Yes | 99 | NONE | Index of /debug/update/12.3-non-oss |
4 | repo-non-oss | openSUSE-12.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.3/repo/non-oss |
5 | repo-oss | openSUSE-12.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.3/repo/oss |
6 | repo-source | openSUSE-12.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/12.3/repo/oss |
7 | repo-update | openSUSE-12.3-Update | Yes | Yes | 99 | rpm-md | Index of /update/12.3 |
8 | repo-update-non-oss | openSUSE-12.3-Update-Non-Oss | Yes | Yes | 99 | rpm-md | Index of /update/12.3-non-oss

Glad to help, lemmie guess former Buntu user?
Yeah its a shame you cant really mark threads as solved here.

No, no 'buntu, thanks. :wink:

I’m still using another distro as my working one. I have other issues with OpenSuse which will take some time to resolve. I had to download and install an rpm manually earlier because neither Yast nor the other software application could find it.

Why? We simply do it different. When you think it is a shame, you are free to go elsewhere.

I mean it more from an admins perspective, seeing issues resolved is a good thing methinks :smiley:

I think we cannot mark it solved because

It is explaned elsewhere. When the OP posts that he is satisfied, everybody can read. Also we hope that the OP does not simply say: “solved”, but that (s)he explains which of the many advises (s)he followed and/or what (s)he did to become happpy. This so that all can benifit from the solution.

But that does not mean that the discussion is closed. The discussion is not “owned” by the OP. The dicussion is “owned” by the community. And others may whish to continue with more clarifications, or may be try to get someone to report a bug, or … In other words, even if the OP thinks it is solved, others may not.

For anyone wishing to express that the issue is solved, you can/could do three things:

  1. First, you may add the word solved to your final message title. See this message title. It does not extend to the original title, but it is easy to see for all new message posts.
  2. You should not only express that the issue is solved, but if you know, what fix did the trick? Many potential fixes may be expressed and just saying solved does not say which one was the fix for others here to read.
  3. You or anyone can tag the entire message thread with the term solved, look for it towards the bottom of the forum page. Just press the Add/Edit Tags and put in solved, any way you like:

Thank You for using openSUSE,