New 11.3 install, video playback brief freeze (Desktop effects issue)

kde4 stock install
kwin effects
With video playback, standard .avi: Going fullscreen or coming out of full screen causes brief freeze 2-3 seconds. (smplayer)
If I switch off effects. All is good.

This is a replication of my previous 11.2 install - Which worked flawlessly yesterday with the latest nvidia driver and effects.

I’m really just wondering if anyone else has experienced this, as I’ll be working on troubleshooting this in the morning. No time right now and the Mrs is using it.:slight_smile:

Will actually be able to let you know in about an hour. FINALLY the weekend so no homework and no work :). Reinstalling 11.3 on my box with Nvidia graphics card. KDE 4.5 kept freezing up whereas stock install usually works fine. Will test this after it’s done updating.

Take care,


So if you set a screen saver active, do you notice the same issue when you stop the screen saver? I have one PC with 11.3 that does this, but not all do this. I use all nVidia cards, but the issue I think is going on with a PC that were upgraded from 11.3 RC2, but that was just what I think I am seeing.

Thank You,

Wow, it just did it with Kaffeine. It’s kind of random though. When I first booted up with everything installed, it fullscreened and exited fine. But I just tried it again and the computer froze for about 2 seconds. Weird.

Take Care,


I never use a screensaver and don’t even plan to go there, in the past they have been nothing but trouble.

I just booted to gnome to see there. I tried enabling effects and it said my hardware does not support it, the screen froze for a second and then it proceeded to let me say Yes to keep the settings and enable them.:stuck_out_tongue:
And with effects running I can do ‘whatever’ - without issue.

glxgears runs fine
and all the indications are that I am running the driver correctly.

I’m going to kde now and will try compiz there instead of kwin…

Compiz in kde
No issue…

Ian I kind of expected you to be using Compiz? But were you?

I’m fairly certain it’s down to kwin, as for me it only happens with desktop effects using kde’s native kwin. But it’s doesn’t happen on my Intel laptops which use kwin. It didn’t happen in 11.2.
Only thing I didn’t do is add the kde4 stable repo, so that’s my next move I guess. As I had that in 11.2 and have it on my laptops (11.3) too.

For those interested, you might want to check back in this thread because I have made a number of posts in succession.

I updated to the kde4 stable repo and all is well in the world now. So the issue seems assuredly to be kwin in the release or any updates that may or may not have been applied.

No compiz for me. It was alsways so buggy with KDE4. Once Kwin started getting all of the plugins I use in compiz, then the effort wasn’t really worth the benefits. I still use it ever now and then to check on it, but other than that Kwin’s effects are sufficient for my needs.

I’ll update with the KDE4 stable repo and see if I get similar results.

Take Care,


I need a favor - can someone reproduce a very similar 11.3 problem for me and see if it’s fixed with the kde4 stable repo (see my laptop specs in my signature below)? I think I’ve got it narrowed down to “rdesktop and kwin do not like each other”. Whenever I have an rdesktop session open and then switch from the rdesktop window to another window by using the mouse - either clicking on the title bar of another window or switching using the task bar - my screen freezes 2-3 seconds. It doesn’t appear to happen when I use “Alt-Tab”.
The laptop is my work laptop so I don’t like experimenting on it, since my “test” partition is still sporting the old 11.2 install in case a showstopper in 11.3 pops up (not likely, but still).

Fresh install 11.3 installed 256.38.20 for nvidia card
Then updated kde 4.4.4 to 4.4.95 kde 4.5 beta

mouse freeze
computer freeze from 2 to 5 seconds and so on.

SOLUTION: REMOVE .KDE4 from your /home/username
restart kde4

Al is working as in 11.2 on the outside you see no differenses with 11.3
only much troubles with video cards mice and keyboard
to get them working as in 11.2

I was afraid someone was going to say that. And I was so happy when everything seemed to work when I migrated my 11.2 .kde4 folder to 11.3.

Notice susegebr stated it was after an update to KDE 4.5 Beta. If you’re using the stable repository or the KDE that came with 11.3 you should be fine. I happened to have also noticed this when I tried upgrading to the 4.5 beta. Which is why I’ve reverted back to Stable.

Then updated kde 4.4.4 to 4.4.95 kde 4.5 beta

Take Care,


I’m having this issue with 11.3 64bit KDE, this is a fresh install not an upgrade from 11.2.

When starting graphically intensive applications everything will freeze for 2-3 seconds. This includes starting all games, changing plasma themes, even showing an image fullscreen in Gwenview, the screen goes completely white for a few seconds then recovers. This is new in 11.3 I never saw anything similar in 11.2.

I have the 256.35 nvidia driver installed, in 11.2 it used to be 195.xx. I wonder if this is a driver problem ?

The only repo’s I have:

# | Alias        | Name                               | Enabled | Refresh
1 | Games        | Games (openSUSE_11.3)              | Yes     | No     
2 | Packman      | Packman repository (openSUSE_11.3) | Yes     | No     
3 | repo-debug   | openSUSE-11.3-Debug                | No      | No     
4 | repo-non-oss | openSUSE-11.3-Non-Oss              | Yes     | No     
5 | repo-oss     | openSUSE-11.3-Oss                  | Yes     | No     
6 | repo-source  | openSUSE-11.3-Source               | No      | No     
7 | repo-update  | openSUSE-11.3-Update               | Yes     | No     

Everything is updated.

I switched to gnome on main box
But switching off effects in kde did help before that.

Hello all

I have updated Xorg from the repo
Short freezes only with gkrellm and gpu temp activated but only once in the five minutes

Besides Xorg update i also updated the kernel to HEAD