New 11.1 Install...no sound

I just installed 11.1 and I can’t seem to get any sound working at all. I have been through some of the troubleshooting I have found here: checked volume settings, reconfigured the sound card, updated alsa using the zypper commands, nothing seems to work. I ran usr/sbin/alsa-info.sh twice, but it didn’t return me a specific URL that I could see…

I’m running a dual-boot setup, sound works fine on Windows. The sound is on the Intel 82801 chipset (ICH6) on a gateway desktop. Could this be a soundcard driver issue?

I had SUSE 10 installed previously, and I preferred using it to Windows, but I never got the sound working, and that’s a dealbreaker. I’d appreciate if someone who knows what they are doing could walk me through checking some things. With my skill level, it could be something simple I’m missing.

Thanks!

When you say you have been through the troubleshooting, did you try working your way thru the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

Ensure you moved both master and PCM volume and headphone controls up in your mixer to 95% when testing sound. After you have confirmed basic sound you can move those down to a lower level to remove distortion.

To test your sound I recommend you try each of these sound tests (as both a regular user, and with root permissions) to see if one might work:
speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you get basic sound established, you can back off those volume controls to lower levels to avoid distortion. Note the test for surround sound is different.

If that test yields errors, try instead this more simple test: speaker-test -c2 -l5 -twavTry as both a regular user and with root permissions. Ideally, you should hear a lady’s voice saying ‘FRONT LEFT’,‘FRONT RIGHT’ five times.

Quite often only 1 of those 2 tests will work, and often thats ok. If sound functions, you should hear a lady’s voice say ‘FRONT LEFT’,‘FRONT RIGHT’ five times.

If you have no success with the audio troubleshooting guide, then I will need more information if I am to make a recommendation … So can you provide more very detailed information so a good recommendation can be given? In the case of openSUSE-11.1, you can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing with root permissions twice:/usr/sbin/alsa-info.shthe first time it will update the diagnostic script, and the second time that will run the diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. Just the URL.
**
Note you get the URL only at the very end, after the script is complete. Pay careful attention to the terminal / konsole after it is complete.**

Also, please to provide additional information, copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

I worked through the troubleshooting guide and got down to the point where I was looking for info on the audio codec, and this is what I get:

linux:~ # cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.17.
linux:~ # cat /proc/asound/modules
0 snd_hda_intel
1 snd_usb_audio
linux:~ # cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0x501c0000 irq 16
1 [U0x46d0x8d7 ]: USB-Audio - USB Device 0x46d:0x8d7
USB Device 0x46d:0x8d7 at usb-0000:00:1d.1-1, full speed

I couldn’t find anything similar to “ALCxxx” so I got kind of stuck at that point.

Both of the speaker tests run, but I hear no sound, I have the mixer volumes in KMix turned all the way up.

I did /usr/sbin/alsa-info.sh twice, but apparently I failed to notice the URL, and now when run it in either Konsole or Xterm, it does nothing, just returns the command prompt again. Is there a way to repeat this or retrieve it somehow?

As for the rest of the info:

linux:~ # rpm -qa | grep alsa
alsa-utils-1.0.19.git20090319-1.1
alsa-plugins-1.0.19.git20090303-1.8
alsa-plugins-pulse-1.0.19.git20090303-1.8
alsa-oss-1.0.17.git20080715-2.23
alsa-tools-1.0.19.git20090317-1.1
alsa-1.0.19.git20090304-2.1
alsa-firmware-1.0.19.git20090317-1.1

linux:~ # rpm -qa | grep pulse
libpulse0-0.9.12-9.6
pulseaudio-module-zeroconf-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
pulseaudio-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
alsa-plugins-pulse-1.0.19.git20090303-1.8
libpulsecore4-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-jack-0.9.12-9.6
libxine1-pulse-1.1.15-20.8
pulseaudio-module-bluetooth-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6

linux:~ # rpm -q libasound2
libasound2-1.0.19.git20090304-2.1

linux:~ # uname -a
Linux linux 2.6.27.7-9-pae #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

linux:~ # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.qC2NI_tLMMC:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel

Hope this helps shed some light…

It says right in the initial screen that comes up when you run that script, that you can get the HELP menu, by typing:

/usr/sbin/alsa-info.sh --help

if you look at the HELP (always a good idea) you will see the option:

/usr/sbin/alsa-info.sh --no-upload

if you run that it will put the file under /tmp, called alsa-info.txt.

Then all you need do is go to /tmp and open that file “alsa-info.txt” with a text editor and paste it to a paste bin site such as general pastebin - simplified internet collaboration

The pastebin site will give you a URL. Then post that URL here. Just the URL.

OK, there is a problem there. I have to run to work, and can not give you a detailed answer, but you are missing alsa-driver-kmp-pae

The above and sound will NOT work without that.

alsa-driver-kmp-pae should have installed on the last half of the zipper commands, if I remember right. I’ll go back and look at that again, and I will look for that URL.

I’m in Seattle, it’s past my bedtime, so I’ll get back at it in the morning…

Thanks very much for your help

Good memory!

The last 3 zypper commands for the original pae kernel are:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1/ multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

Note in those last 3 zypper commands, the same name “multimedia” was assigned for the repos, as in the 1st 3 from the alsa update page Alsa-update - openSUSE , so it is important you removed the repos as part of the 1st 3 commands, before adding the repos for the 2nd three.

Also note those commands are for the “original kernel”. There is a kernel update available, and if and when you update the kernel, you will likely have to grab the appropriate alsa-driver-kmp-pae (which will be different) for the newer kernel.

Success!

Not sure why it didn’t work the first time around, but I went through the commands again again, installed the driver, and then when I ran the speaker tests, it was working.

So again, I really appreciate the help!

Great! Congratulations.