NetworkManager works but no connection in 12.3

Hello, and thanks ahead of time for any insights.

I have done a successful online zypper dup to openSUSE 12.3. The system boots and runs as expected and I am very impressed at that. However the connection to the internet is not able to succeed when using network manager.

I am able to connect to and ping my router over both ethernet and wireless. Though any program that tries to access the internet gives me something along the lines of Host Not Found. I tried enabling Google DNS to see if it was a DNS problem and had no success. I also forced ipv6 to be disabled using ipv6.disable=1 boot parameter (which was confirmed in dmesg) and still have no connection.

I then tried pinging an ip address instead of just a site name and it works correctly. Though oddly enough I already tried an alternate DNS to no avail. If I use ifup/dhclient via yast with network manager disabled my net works fine.


What network adapter do you have?
I have a Realtek PCIe Gigabit motherboard adapter and it does not work either in 12.3 RC2.
BUT, I went to the Realtek drivers website and the DO have a Linux driver to download…


My network adapter is called an AR9285, and it is fully supported by the ath9k driver for many kernel versions now. I also had this same device work using Linux Kernel versions 3.6 and 3.7 using openSUSE 12.2. Also, the device is detected and works properly (I can view my router with it over wifi). Just that I am not able to browse pages using programs such as Firefox and Links.

netconfig update -f ???

I set google dns manually in /etc/resolv.conf and now it works. Though I don’t think this is exactly a fix. As I am not sure what was wrong to begin with.


I reverted to my original resolv.conf that I backed up, tried this and rebooted, and had the same host not found error. Again setting the resolv.conf to google dns fixed it. Odd.

On 03/01/2013 12:16 PM, nightwishfan wrote:
> dale14846;2531081 Wrote:
>> netconfig update -f ???
> I reverted to my original resolv.conf that I backed up, tried this and
> rebooted, and had the same host not found error. Again setting the
> resolv.conf to google dns fixed it. Odd.

Your ISP’s name server is borked.

Were that the case I would have this issue on 12.2 as well. Not to mention ifup works fine with the default nameserver.

There is quite a discussion of NetworkManager issues in the “Comment thread - 12.3 RC2”. It seems RC2 handles networking differently depending on how it was installed. No one there mentioned doing online zypper dup. Installation from DVD looks like it is using NetworkManager, but it really uses ifup. There is a procedure in that thread at that gets NetworkManager working correctly. I did that on my system and things got back to normal.

I saw that earlier. I just get the result of file exists. I will keep playing with it though, thanks.

Hi, I encountered the very same problem after upgrading my openSUSE 12.2 VM test environment and I found help in the openSUSE 12.3 Release Notes ( In section 4.1 they describe how to enable the Network Manager and after a reboot I had my Network Manager problems sorted out. Hope it’s helpful.

BTW, just after upgrading to 12.3 I was still able to access the internet and get some more updates from Apper but after the first reboot I had no more connection until getting help from the release notes.

Thanks for the reply. I am not sure if it works for my issue or not as NwM seems to function, just not find my dns properly. Though I have sorted it now by manually adding google dns to /etc/resolv.conf.

I will do some more testing nearer to the weekend.

I have exactly the same problem but for me it depends on the Wlan I want to connect to. I can connect to all Wlans but on some I cannot open Webpages etc. All those WLans worked in the past under 12.2.