networkmanager with wired connection stuck on setting network address

Hi :slight_smile: , yesterday on my tuxedo TUXEDO InfinityBook Pro 15 v4, processor= Intel Core i7-8565U, RAM=32Gb, graphics card Model: Intel UHD Graphics 620 (Whiskey Lake), wired connection worked fine, today wired connection stuck on setting network address, I tried

netconfig  update -f

but without success, how can I solve?

@pier_andreit:

Is there anything in the systemd Journal indicating a network interface failure?

 # journalctl --this-boot

it seems not at my glance, this is the result of

journalctl --this-boot

as su -
https://susepaste.org/42183735

@pier_andreit:

You need to grep -iE the “this-boot” Journal for ‘r8169|eth0|NetworkManager’ …

You should notice that:

  • The Kernel has brought the “r8169
    ” interface as “eth0” up but, the Network Manager has problems with this physical fact …

Please check the settings of eth0 in the Network Manager GUI and the YaST Network module – you may have to temporarily change to “wicked” to make any changes related to “eth0” and “r8169” and then, change back to “Network Manager” …

  • Please also check the status of the “r8169
    ” module in the Kernel – ‘modprobe’, etc, etc …

[HR][/HR]Have you changed anything related to “r8169” or “eth0” in Policy Kit and/or anything else related to system security?

Hi :slight_smile:
the this-boot journal is herehttps://susepaste.org/58076613
in "this-boot” Journal I found:
SUSE Paste for r8169
SUSE Paste for eth0
SUSE Paste for NetworkManager

hecking modules I found:

pla4ST:~ # lsmod > /home/pla/lsmod and here are the ones with 8169
r8169                  94208  0
memstick               16384  1 rtsx_pci_ms
mii                    16384  1 r8169

I tried also googling but…:

pla4ST:~ # modprobe --list "8169"
modprobe: unrecognized option '--list'

I checked

Please check the settings of eth0 in the Network Manager GUI and the YaST Network module – you may have to temporarily change to “wicked” to make any changes related to “eth0” and “r8169” and then, change back to “Network Manager” “”

but didn’t worked

Have you changed anything related to “r8169” or “eth0” in Policy Kit and/or anything else related to system security?

maybe yes, yesterday din’t worked, then worked again (…after windows login…) I changed this:
Edited /etc/polkit-default-privs.local and add the following entry

org.freedesktop.NetworkManager.settings.modify.system auth_admin_keep:yes:yes

Saved then run (as root)

/sbin/set_polkit_default_privs

and after reboot worked, then after another reboot didn’t worked…

:Oonly to say that today works, nothing changed, resumed after suspend and wired works, same network same place…

In the past some hardware would receive deep changes from Windows that may get reset with a warm boot but should be reset with a cold boot. So do you see the problem with a cold boot or only a warm boot between OSs???

hi :slight_smile: what is the difference from cold boot and warm boot?
I also found this:
from my hardware informations taken with suse hardware information my ethernet should be:
Model: “Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller”
and in tuxedo repository using yast I found this:

r8168-blacklist-r8169 - To favour r8168 blacklist the r8169 device driver
On many Realtek Ethernet controllers the old device driver r8169 does not work reliably. To solve this the r8169 kernel module has to be blacklisted to enable the system to load the new device driver r8168.

r8168-kmp-default - Device driver for RealTek Gigabit Ethernet controllers
This is the Linux device driver released for RealTek RTL8168B/8111B, RTL8168C/8111C, RTL8168CP/8111CP, RTL8168D/8111D, RTL8168DP/8111DP, and RTL8168E/8111E Gigabit Ethernet controllers with PCI-Express interface.

do you think I have to install r8168 and blacklist r818169??
how to go back to unblaklist (…whitelist?) r8169 if it doesnt works?

do you think I have to install r8168 and blacklist r818169??
how to go back to unblaklist (…whitelist?) r8169 if it doesnt works?

Post:

zypper se -s r816

To answer your r8168 thoughts, using the information from this machine – which, quite happily, uses the r8169 driver included with the openSUSE Kernel:


 > lsmod | grep -E 'Module |8169'
Module                  Size  Used by
r8169                  94208  0
mii                    16384  1 r8169
 > 
 > inxi --network --extra 2
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: ASUSTeK P8P67 and other motherboards driver: r8169 v: 2.3LK-NAPI port: e800 bus ID: 02:00.0 
           chip ID: 10ec:8168 
 > 
 > inxi --machine
Machine:   Type: Desktop Mobo: ASUSTeK model: M5A78L-M LX v: Rev X.0x serial: <superuser/root required> 
           BIOS: American Megatrends v: 1603 date: 11/05/2013 
 > 

here is:

pla4ST:~ # zypper se -s r816
Loading repository data...
Reading installed packages...

S  | Name                        | Type       | Version                                 | Arch   | Repository        
---+-----------------------------+------------+-----------------------------------------+--------+-------------------
   | r8168                       | srcpackage | 8.048.00-pm151.2.9                      | noarch | Packman Repository
   | r8168-blacklist-r8169       | package    | 8.048.00-pm151.2.9                      | x86_64 | Packman Repository
   | r8168-debugsource           | package    | 8.048.00-pm151.2.9                      | x86_64 | Packman Repository
i+ | r8168-dkms                  | package    | 8.040.00-10.57                          | noarch | Tuxedo leap 15.1  
   | r8168-kmp-default           | package    | 8.048.00_k4.12.14_lp151.28.48-pm151.2.9 | x86_64 | Packman Repository
   | r8168-kmp-default-debuginfo | package    | 8.048.00_k4.12.14_lp151.28.48-pm151.2.9 | x86_64 | Packman Repository
pla4ST:~ # 


Aha!!
Bin it!! – throw it out – you don’t need it …

removed :slight_smile: …I will try to see what happen hopinglol!

pla4ST:~ # zypper se -s r816
Loading repository data...
Reading installed packages...

S | Name                        | Type       | Version                                 | Arch   | Repository        
--+-----------------------------+------------+-----------------------------------------+--------+-------------------
  | r8168                       | srcpackage | 8.048.00-pm151.2.9                      | noarch | Packman Repository
  | r8168-blacklist-r8169       | package    | 8.048.00-pm151.2.9                      | x86_64 | Packman Repository
  | r8168-debugsource           | package    | 8.048.00-pm151.2.9                      | x86_64 | Packman Repository
  | r8168-dkms                  | package    | 8.040.00-10.57                          | noarch | Tuxedo leap 15.1  
  | r8168-kmp-default           | package    | 8.048.00_k4.12.14_lp151.28.48-pm151.2.9 | x86_64 | Packman Repository
  | r8168-kmp-default-debuginfo | package    | 8.048.00_k4.12.14_lp151.28.48-pm151.2.9 | x86_64 | Packman Repository
pla4ST:~ #