Networkmanager will not follow a redirect to establish link

At school we have a network that authenticates through a web page. That is, first you connect to a wireless network without a password and when you start up a browser you are supposed to redirect to a login page. Sadly this does not happen if I use networkmanger. There are others in class using ubuntu and networkmanager that is capable of connecting, so I guess there is a problem with knetworkmanager or the openSUSE implementation of it.
If I switch to use ifup and set my system to connect to the network without a key, the web page pops up as soon as I launch my browser and I’m all set.
I’m running openSUSE 11.1 and KDE 4.3 from the factory repo at the moment, but I’ve also tried with openSUSE 11.1 and KDE 3.5 and its implementation of knetworkmanger. I’m running kernel 2.6.31 rc5, but I’ve tried with the stock kernel of openSUSE, as well as kernel 2.6.29 and 2.6.30.
Are there any knowledgeable persons out there capable of telling me what to do to get it up and running?

To get around the problem I connected to the network using the old ifup way. Bookmarked the logon page. Switched to networkmanager. Once it said I was connected I opened a browser, clicked the bookmark and got the logon page. In other words: happy days for a suse user. So if you are attending classes at NTNU in Trondheim, Norway, use the above method if you are having trouble with networkmanager under kde4