NetworkManager -- where is it and how to start it?

How do I turn NetworkManager on and keep it on boot to boot?

Watching the boot script, it indicates the Network Manager is being turned on, but when I go to YaST to set up to use the NetworkManager it indicates it is not running, and I need to start NetworkManager or nm-applet first.

So I end up with ‘wicked’ as the setup mode, and it is tenuous at best when starting with just WiFi. Sometime works most times fails. I am fairly sure I have all my IP’s,gateways, and DNS info correct, and the SSID is a no brainer.

A ‘network’ icon sometimes shows in the task area of the panel, then again next boot it is not there, and neither is my WiFI. And at times it has shown that I have 2 or 3 wlan0’s to choose from.

Trust me, I would rather run this HP Pavilion AiO wired, but I don’t have a long enough Ethernet cable to get down two and a half floors.
A lot of the time I have to ‘root’

service NetworkManager start

to get the network icon to show.

Yes, I have read the Leap15 ‘guide’ for Network Manager, but after a while my eyes glaze over with all the verbiage, and not enough illustrations.WAY too complicated, especially since it doesn’t show how to actually start the Network Manager. Can’t find nm-applet.desktop either.

Yast → System → Network Settings

Click the “Global Options” tab (near top of screen)

On the next screen, the top entry is “Network Setup Method”. And you will probably find that it is set to “Wicked Service”. The other selections available are “NetworkManager Service” and “Network Services Disabled”.

Set that to “NetworkManager Service” and click OK (at bottom right). And you should be set.

This reads like you have already got NetworkManager.service running, but it is the NM front-end (nm-applet) which may (or may not) be showing by way of a system tray icon on your (XFCE?) desktop. In such cases you should be able to start it from a terminal with

nm-applet

Assuming you’re using XFCE (I’m not), I would expect to see /etc/xdg/autostart/nm-applet.desktop or similar present which should get it started automagically at login. Is that the case for you?

Not necessarily.
Am assuming the @OP saw Network Manager loaded during boot, but wouldn’t have actually seen the Network Manager Service active and running.

That’s a quirk (probably intentional) that Network Manager is always installed, but not active by default.
Is why sometimes people see two network icons in the panel, one will actually report network traffic statistics and the other will say “disabled.”
Or, the User might see only one network icon, click on it and it will say “disabled” although networking is working fine.

And,
In some Desktops, clicking on the icon won’t identify itself as “Network Manager” but say something like “Network Connections” but that is also Network Manager.

TSU

I think I misunderstood what was being asked, in my first reply. And deano_ferrari helped straighten that out.

Yes, if I use Yast to switch to NetworkManager, it does warn me that a suitable applet needs to be running on my desktop.

I always ignore that warning. And the reason that I ignore it is that, by default, a suitable applet is running on most desktops. In particular there is a suitable applet running on Gnome, KDE, XFCE, MATE, LXqt. I don’t think there is an applet running with Icewm, though it is possible to manually start one.

For the others here, this is by default in Xfce.

The Network Icon should show up in the right side in the notifications area of the Xfce tray.

Looks like this (normal click)
https://susepaste.org/images/42841176.png

and this (right click):
https://susepaste.org/images/7547543.png

Bill, since you are saying it shows up sometimes, but not always, first try nrickert’s instructions.

If that does not solve it, you can also try right-clicking the network icon when it does show up, then choose “edit connections”. Check the settings for your preferred network. Might help?

But, it should show up there automatically,

… otherwise, we will need to look into your Services settings, as it should be running automatically.

Follow, Neil’s advice with respect to switching to NM if you haven’t done that already.

BTW, you can get the status of wicked and NetworkManager services with

systemctl status wicked
systemctl status NetworkManager

Only one should be active, and that should be NetworkManager.

As usual I wasn’t clear enough in OP. The HP AiO is running only KDE.
Using deano-ferrari’s commands:

**linux:~ #** **systemctl status wicked**
**●** wicked.service - wicked managed network interfaces
   Loaded: loaded (/usr/lib/systemd/system/wicked.service; enabled; vendor preset: disabled)
   Active: **active (exited)** since Tue 2018-08-07 17:08:20 CDT; 23min ago
  Process: 979 ExecStart=/usr/sbin/wicked --systemd ifup all (code=exited, status=0/SUCCESS)
 Main PID: 979 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/wicked.service

Aug 07 17:07:49 linux-vmd8 systemd[1]: Starting wicked managed network interfaces...
Aug 07 17:08:20 linux-vmd8 wicked[979]: lo              up
Aug 07 17:08:20 linux-vmd8 wicked[979]: eth0            up
Aug 07 17:08:20 linux-vmd8 wicked[979]: wlan1           setup-in-progress
Aug 07 17:08:20 linux-vmd8 systemd[1]: Started wicked managed network interfaces.

**linux:~ #** **systemctl status NetworkManager**
**●** NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
           └─NetworkManager-ovs.conf
   Active: **active (running)** since Tue 2018-08-07 17:07:50 CDT; 24min ago
     Docs: man:NetworkManager(8)
 Main PID: 978 (NetworkManager)
    Tasks: 4 (limit: 4915)
   CGroup: /system.slice/NetworkManager.service
           ├─ 978 /usr/sbin/NetworkManager --no-daemon
           └─2773 /sbin/dhclient -d -q -sf /usr/lib/nm-dhcp-helper -pf /var/run/dhclient-wlan1.pid -lf /var/lib/NetworkManager/dhclient>

Aug 07 17:08:43 linux-vmd8 NetworkManager[978]: <info>  [1533679723.4717] device (wlan1): state change: ip-check -> secondaries (reason>
Aug 07 17:08:43 linux-vmd8 NetworkManager[978]: <info>  [1533679723.4723] device (wlan1): state change: secondaries -> activated (reaso>
Aug 07 17:08:44 linux-vmd8 NetworkManager[978]: <info>  [1533679724.0451] device (wlan1): Activation: successful, device activated.
Aug 07 17:08:47 linux-vmd8 NetworkManager[978]: <info>  [1533679727.3457] manager: NetworkManager state is now CONNECTED_GLOBAL
Aug 07 17:09:29 linux-vmd8 NetworkManager[978]: <info>  [1533679769.9674] device (eth0): state change: activated -> deactivating (reaso>
Aug 07 17:09:30 linux-vmd8 NetworkManager[978]: <info>  [1533679770.0075] audit: op="device-disconnect" interface="eth0" ifindex=2 pid=>
Aug 07 17:09:30 linux-vmd8 NetworkManager[978]: <info>  [1533679770.0084] device (eth0): state change: deactivating -> disconnected (re>
Aug 07 17:09:30 linux-vmd8 NetworkManager[978]: <info>  [1533679770.0331] dhcp4 (eth0): canceled DHCP transaction, DHCP client pid 1247
Aug 07 17:09:30 linux-vmd8 NetworkManager[978]: <info>  [1533679770.0331] dhcp4 (eth0): state changed bound -> done
Aug 07 17:09:30 linux-vmd8 NetworkManager[978]: <info>  [1533679770.7256] policy: set 'NETGEAR83' (wlan1) as default for IPv4 routing a>

It looks like wicked was exited after NM started about the same time this evening. BTW, the icon was in the task area this evening, but I’ve had to start it manually the past few evenings.

**But if I go into YaST and try to change from wicked to NetworkManager, I still get the pop telling me I have to have an ‘applet running, please start it and retry’.

I will look at nrickerts posts(s) closer. **

Sorry, I must be one of the dumbest uers ever.
I can’t get past the YaST Global (ignoring the prompt) and continuing without it shutting both wired and WiFi down. I had to go back to wicked to get a network and then only after a restart.

So maybe a better question is how do I start network setup all over again with NetworkManager stated before I go into YaST or an applets setups.

@deano_ferrari

nm-applet

is ‘cnf not found’ when I enter that in a console as root.

If the network icon is not present on start up i do:

service NetworkManager start

and

chkconfig --level 345 NetworkManager on

which is suppose to make it come back after next boot.

I don’t remember where I found those.(Me being dangerous again no doubt)

On which machine?

Normally, “nm-applet” should be there on your XFCE box. It might not be there on your KDE box. For KDE, the normal applet is “plasma-nm5”. Well, “plasma-nm5” is the name of the package, but their might be a library that does most of the work.

Hi Bill

That output shows that wicked and NetworkManager are both running. That is going to cause problems. You can stop and disable wicked with

sudo systemctl stop wicked
sudo systemctl disable wicked

then only NM will be active.

As you’re using KDE on this machine, the KDE NM front-end is a plasmoid application (plasma-nm5 package).

This is your problem.
When you click on the dropdown are you sure you see three options?
One of the options disables networking completely resulting in what you described.
Another option enables Classic Wicked
Another option enables Network Manager.

Sounds like you selected the option that disables networking altogether.

TSU

YES

Global Options dropdown has:

  • NetworkManager Service
  • Wicked Service
  • Network Services Disabled

I am very sure I selected the 1st - Nerwork Manager Service
then the panel went all grey and I had to back out and reset to wicked again to even have a WIFI connection(after a reboot)

It is the HP Paviion AiO with only openSUSE Leap 15.0 and KDE. Unless the installer put icewim or other I don’t know about

Yes KDE on this HP Pavilion AiO.
I will give your codes a try. Can’t do anymore harm(I hope) than I have already done.

Nope shut down all connections. Had to enable wicked again. If wicked is the only way it will do WiFi then it is what it is.
I would rather it use the NetworkManager, but so far I can’t get it to do that. Unless I strip LeP out completely, and do the install via WiFi and I really don’t not want to do that.

@tsu2, I tried again to select the YaSt Global ‘NetworkManager Services’ and it stopped me in my tracks again!

Sorry folks, I get to this machine once a day. I only climb those steps once a day(bad heart and air), so I may not respond as quickly as you all do.

I have an icon in the task area, but I don’t know if it is NM or something else.
At any rate, every time I try change from wicked to NetworkManager services in YaST, I lose eth0 and WiFi and have to go back to wicked, then a restart to get a connection again.(About to wear out this new HDD with all the reboots I am having to do)

I simply do not know what to do next to get NetworkManager working so YaST doesn’t throw me errors and shut both down.
I need to move this machine to an area that does not have wired connection, so I need a reliable WiFi.