NetworkManager-wait-online.service dependency error when not utilizing NetworkManager

On boot I get a strange dependency info/error.

I am utilizing wicked, not NetworkManager. It is also on a wireless card.

kvm:~ # systemctl -l status NetworkManager-wait-online.service
● NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

May 17 18:35:31 kvm systemd[1]: **Dependency failed for Network Manager Wait Online.**
May 17 18:35:31 kvm systemd[1]: **NetworkManager-wait-online.service: Job NetworkManager-wait-online.service/start failed with result 'dependency'.**
kvm:~ # 

Here is the service that depends on this according to man systemd-networkd-wait-online.service

kvm:~ # systemctl status systemd-networkd.service
● systemd-networkd.service - Network Service
   Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:systemd-networkd.service(8)
kvm:~ # 

And all other NetworkmManager services are disabled:

kvm:~ # systemctl status NetworkManager.service
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

May 17 18:35:31 kvm systemd[1]: Network Manager is not active.
kvm:~ # systemctl status NetworkManager-dispatcher.service 
● NetworkManager-dispatcher.service - Network Manager Script Dispatcher Service
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-dispatcher.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

I cannot seem to determine any other dependencies on NetworkManager-wait-online.service

Anyone else running wicked seeing this dependency error.

I have not run into that problem.

Here’s my suggestion:

  1. Switch to using NetworkManager
  2. Reboot
  3. Switch back to wicked
  4. Reboot

and hope that the problem goes away.

I have run into a problem in the past where this double switch fixed it. I think something was not quite configured right, and it got fixed by these changes.

Or remove NM?

I use wicked and never install NM at all. I assume that the best way to avoid NM glitches is not to have it. :wink:

When “wicked” then, mask “Network Manager” …

 > systemctl list-unit-files | grep -i 'NetworkManager'
NetworkManager-dispatcher.service       masked
NetworkManager-wait-online.service      masked
NetworkManager.service                  masked

This Desktop machine …
[HR][/HR]BTW, on my laptop I use Network Manager – WLAN; movement; flight mode … >:)

Did you set these to masked, or were they automatically set that way when choosing wicked in YaST?

Mine are all set to disabled.

For what it is worth:

systemctl list-unit-files | grep -i 'NetworkManager'
NetworkManager-dispatcher.service          enabled 
NetworkManager-wait-online.service         disabled
NetworkManager.service                     disabled

Thank you for all the suggestions.

So, far I have:

Disabled the openvswitch.service and removed my ifcfg-* files to insure that was not an issue. It wasn’t

Switched from wicked to NetworkManager in YaST, rebooted, and made sure the network functioned. Then switched back to wicked in YaST, rebooted, and checked to insure the network was working. I still received the same INFO error when rebooting with wicked.

I enabled the NetworManager-dispatcher.service, and rebooted but this did not resolve the issue.

I understand that removing NetworkManager or masking the services would probably solve the issue. I am just not ready to give-up yet on trying to figure out what my system is doing :wink:

Thanks for everyone who is using wicked and confirmed they are not seeing the scenario I am seeing. I can certainly live with the issue since it does not affect boot time. However, I am like a dog with a bone. I will keep chewing on it when I have time, or until I move to version 15 :wink:

If I find anything I will report back.

I like the comparison with the dog. :wink:
Yes, it is bad for your sleeping when one has such an unresolved irritation.

We will be glad to hear of any explanation.

I had to set them to “masked” due to this issue …

Thanks! I now know I am not the only one seeing this. What desktop are you using (gnome, KDE, etc)?

I tried to remove it. An this is the output:

zypper rm NetworkManager
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following application is going to be REMOVED:

The following 19 packages are going to be REMOVED:
  NetworkManager NetworkManager-branding-openSUSE NetworkManager-lang NetworkManager-openconnect NetworkManager-openconnect-lang
  NetworkManager-openvpn NetworkManager-openvpn-lang NetworkManager-pptp NetworkManager-pptp-lang patterns-kde-kde
  patterns-kde-kde_imaging patterns-kde-kde_plasma plasma-nm5 plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
  plasma-nm5-pptp plasma5-session plasma5-session-wayland

The following 3 patterns are going to be REMOVED:
  kde kde_imaging kde_plasma

19 packages to remove.
After the operation, 19.9 MiB will be freed.
**Continue? [y/n/...? shows all options] (y): **n

Leap 42.3 standard KDE Plasma 5.

BTW: a year 2015 URL related to this issue: <>

Thanks. It still irritates me :wink:

Sorry, This is what I did earlier, but I now see I did not succeed in doing this from 42.2 on (never run 42.1).

I think it is a shame that you have to install Network Manager to get KDE on the system :(.

No problem.

I run TW. NM is instaled by default.
If it was not this thread I would not have checked if NM is installed on my system because I never use it. :slight_smile:

I am running a bind caching service. doing a:

systemctl disable named.service

Removes the issue. I assume that is a bug from looking at the URL below since it should conform to an either NetworkManager.service or :systemd-networkd.service

Can anyone confirm for me?

Given that, the system default, these days, is to use ‘nscd’, which seems to be reliable enough for folks such as myself and, it doesn’t seem to cause any issues with ‘wicked’ and also, none with ‘Network Manager’, why bother to setup BIND as a caching client?

Because all the other DNS servers in my develop environment are bind, and it is fairly easy to configure.

Does nscd even query root servers?

As far as I know, “nscd” just queries the configured local caching server.

I guess there are a couple of reasons to use a bind caching server then.

On a standalone it speeds up my web activity because most of my queries are to the same sites generally, and since places like youtube make around 250 web queries per page the time lag adds up.

In a production environment internal DNS servers are often tied to DHCP servers so doing split DNS and using a proxy and caching server keeps your internal DNS servers from cache poisoning and attempted malicious zone transfers.