NetworkManager.service

I see this message while booting if I press the ESC key - what does it mean?

linux-5o59:~ # systemctl status NetworkManager.service
NetworkManager.service - Network Manager
          Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled)
          Active: failed (Result: exit-code) since Thu, 09 May 2013 14:49:54 -0400; 2min 8s ago
         Process: 621 ExecStartPre=/usr/bin/test x${NETWORKMANAGER} = xyes (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/NetworkManager.service


Everything seems to work once booted up, though. I have Samba Server set up to share files with a Windows 7 PC, if that matters.
I’m running openSUSE 12.2 64 bit.

Sorry, I meant it shows a failure with Network Manager at boot, the code I posted was with the command


systemctl status NetworkManager.service

Are you using ifup ?

I set up networking in Yast, never used ifup.

Well, one of the first choices you have to make when you set it up in YaST is if you use ifup or Network Manager.

Thus ifup is not contrary to using YaST, it is set or not using YaST.

Ok, I found that, it’s set up for ifup. Actually, I don’t remember if I did any setup at all, or if it automatically set up the network card at installation, it’s been a while. So I assume there’s nothing to worry about?

switch to NM in YaST and reboot your machine and check whether there is an improvement in boot time.When i did that in 12.2 there was a huge improvement. This condition is not seen in 12.3 and i switched back to ifup in 12.3

It does boot faster! Thank you for you help!

If /var/log/journal exists on your machine then

try

https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/483150-slow-boot-time-opensuse-12-2-good-laptop-3.html#post2532089

Ignore if /run/log/journal exists

/var/log/journal doesn’t exist, neither does /run/log/journal (there’s no “log” subdirectory in /run)

This is not possible unless you did something drastic with your machine. Then again i might be wrong
Since openSUSE 12.2 does use systemd check this journald.conf

When you say it doesn’t exist, you’re not thinking it is a file are you? It’s a directory…

 ls -l /var/log/journal
total 4
drwxr-xr-x 2 root root 4096 Sep 10  2012 94919bff293c128118e745f100000a92

I must be getting tired! I’ll check that forum link again later, gotta go to bed…

I decided to try it before going to bed - it now takes about 8 to 10 seconds to boot! Thanks to everyone for all the help!

i don’t have that big journal entry now as it in /run. Only if i install “analyze” package systemd starts wreaking havoc :frowning:

You could also try to switch back to ifup and disable the NetworkManager.service:

sudo systemctl disable NetworkManager.service

Yes, when you decided to use ifup (even when that decision was made by using some installation default, but using it fits you), then I do nopt understand why NM is running at all.
I haven’t even installed it.

On 12.2 NetworkManager.service was enabled by default. It checked if it should start NetworkManager by looking at the variable NETWORKMANAGER in /etc/sysconfig/network/config (that was an openSUSE specific patch to NetworkManager.service). Switching between NM and ifup in YaST caused this variable to be changed.
This patch (and the NETWORKMANAGER environment variable) was removed for 12.3. The switch between NM and ifup is now done directly by enabling/disabling NetworkManager.service and disabling/enabling network.service.
That change caused the bug that YaST couldn’t correctly determine whether ifup or NetworkManager is to be used, btw… :wink: