NetworkManager-pptp for openSUSE 11.0


I have recently installed openSUSE 11.0 and could not find any way to setup VPN connection to Windows XP box. In openSUSE 10.3 I used NetworkManager plus pptp(d), but in the current version I could fin NetworkManager-pptp in any of the community repositories. I installed the version that was shipped with openSUSE 10.3, but it failed to work. NetworkManager (nm-applet) crashes when I try to create VPN connection using PPTP protocol.

Has any one set up VPN to Windows XP from openSUSE 11.0?

No one uses VPN to Windows XP?

Last time I checked (about a month ago), the PPTP plugin for NetworkManager 0.7 hadn’t been completed yet so it was not in the repos. I don’t know what it’s current status is.

Apparently the PPTP plugin was ported to 0.7 over the weekend, see here. Not sure when this will appear in the repos.

Thread moved to Network/Internet

I cannot find a link to download the version with pptp plug-in. Did you manage to download it?

You can install kvpnc, and pptp-client I use it to connect to the office network and it works like a charm.

You can also refer to below if that will help for you.
Bryan’s technical world: How to set up VPN Client on opensuse

No, I haven’t been able to find it in any of the repositories yet. I did upgrade NetworkManager, but found it crashed the main menu applet, so have since downgraded it.

The same is here - Main Menu crashed. So I needed to upgrade it back…

I also tried to use vpnc, but some Group Name is required to be entered. But I do not have it. As a result it fails to connect.

If you’re feeling adventurous, you could get the latest version from their subversion repository and compile it. I did so today, and have PPTP working. It requires a few extra packages to be installed. However the main menu applet still crashes, I’m assuming I need a new version to work with the latest networkmanager. As I am not sure where I can get that from, I’m using the normal GNOME menu applet for the time being.

OK I’ve just found the subversion repository (silly me I should’ve known it would be in the GNOME subversion repo). I’ve successfully compiled the main menu applet, and have everything working. If you want I can guide you through the process, that is if the PPTP plugin hasn’t already appeared in the openSUSE repositories.

could you write down the guide here?
I have the some problem.

OK here is a quick guide. However, please note that you may be unable to configure your network settings with NetworkManager if something goes wrong during this process. In which case, you should be familiar with ifconfig (for wired networks) and iwconfig (for wireless networks). These are command line tools for applying network settings.

  1. Install Subversion
  2. Read the instructions for compiling the latest NetworkManager here.
  3. If running the file fails, you more than likely are missing one or more packages. The script should inform you as to what package you are missing. Open up the package manager and search for the missing package. If the package is already installed, then most likely you need to download the development package, which ends in -devel. If you can’t find the package, post here and I’ll try to help. I’m not sure, but there might be a guide detailing the packages you need on the GNOME website hidden somewhere, but I didn’t see it.
  4. To install the PPTP VPN daemon, change directory to NetworkManager/vpn-daemons/pptp/. Then follow the same procedure as before of running (./ --prefix=/usr --sysconfdir=/etc --localstatedir=/var), make and sudo make install. PPTP should then be available when you add a VPN connection.

To install the latest main menu applet:

  1. Checkout the code from Subversion: svn co svn:// gnome-main-menu
  2. Change to the gnome-main-menu directory, and follow the same procedure as before (run with the parameters, make and sudo make install). You may have to install some additional packages again.
  3. You may need to remove the old version of the applet, and add it again.

I’m trying to compile NetworkManager from svn but when I’m running

./ --prefix=/usr --sysconfdir=/etc --localstatedir=/var

I received

checking for DBUS... configure: error: Package requirements (dbus-glib-1 >= 0.75) were not met:

Requested 'dbus-glib-1 >= 0.75' but version of dbus-glib is 0.74

How can I get correct version of this lib?

Maybe you are able to make rpm of pptp plugin for NetworkManager?

Here you are.
Index of /releases/dbus-glib

Thanks :slight_smile:

I tried few ways to force PPTP to work:

  1. NetworkManager latest revision (4047) compilation:
nm-named-manager.c: In function ‘rewrite_resolv_conf’:
nm-named-manager.c:457: error: passing argument 1 of ‘dispatch_netconfig’ from incompatible pointer type
nm-named-manager.c:457: error: passing argument 3 of ‘dispatch_netconfig’ from incompatible pointer type
nm-named-manager.c:457: error: passing argument 4 of ‘dispatch_netconfig’ from incompatible pointer type
nm-named-manager.c:457: error: too many arguments to function ‘dispatch_netconfig’
make[4]: *** [libnamed_manager_la-nm-named-manager.lo] Error 1
make[4]: Leaving directory `/home/tjr/Desktop/drv/linux/NetworkManagerL/src/named-manager'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/tjr/Desktop/drv/linux/NetworkManagerL/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/tjr/Desktop/drv/linux/NetworkManagerL/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tjr/Desktop/drv/linux/NetworkManagerL'
make: *** [all] Error 2

  1. Compilation of PPTP daemon - revision 3685 as my NetworkManager revision:
nm-ppp-starter.c:48:31: error: dbus-dict-helpers.h: No such file or directory
nm-ppp-starter.c: In function ‘nm_ppp_dbus_process_helper_ip4_config’:
nm-ppp-starter.c:1542: warning: implicit declaration of function ‘nmu_dbus_dict_append_uint32_array’
make[2]: *** [nm-ppp-starter.o] Error 1
make[2]: Leaving directory `/home/tjr/Desktop/drv/linux/NetworkManager3685/vpn-daemons/pptp/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tjr/Desktop/drv/linux/NetworkManager3685/vpn-daemons/pptp'
make: *** [all] Error 2

  1. Updating NetworkManager via Yast2 to revision 3913 (Factory repository) and compilation of PPTP daemon revision 3913.

Everything works! Well… almost everything. When I plug in network cable, Gnome Main Menu crashes.

Any ideas? I really need PPTP support.

To fix the gnome main menu crash you need to update it, it is available from svn. Or, you could use a different menu applet.

Hi hammettt,

How can i downgrade network manager to 0.6 to work with no problems with pptp vpn connection?

I need to use this until there’s a way to work with this under network manager 0.7 with no issues.

Best Regards,

I updated these packages

NetworkManager 0.7.0.r4115-1.2
NetworkManager-gnome 0.7.0.r4115-1.2
NetworkManager-pptp 0.7.0.r4060-2.3
NetworkManager-pptp-gnome 0.7.0.r4060-2.3
pptp 1.7.2-1.23

from openSUSE Factory repository, started NetworkManager but nothing happens after left-clicking on the systray icon. I would like to configure VPN to university network. That’s why I updated NetworkManager and installed NetworkManager-pptp packages.

Is there something missing? Is something wrong? Or is it another unstable release from Factory repository?