NetworkManager plasmoid freezes the whole desktop

Hi folks,

I have a really annoying issue with the NetworkManager plasmoid. I’ve been hoping that KDE 4.10 would finally fix it, but it didn’t. The plasma desktop simply freezes from time to time. The applications still run fine, I can even launch KRunner, but the panel and the desktop icons are all dead. I observed that the freeze happens about the time when NetworkManager loses a WiFi connection. In most cases, plasma resumes working after a good ten seconds, however, sometimes I have to log out and in to have a working desktop again. I can’t tell what makes the difference, but the permanent freeze usually occurs when I’m playing some game or have the Steam client opened, so I guess it’s some OpenGL matter. As I’m relying on a rather unstable WiFi connection, this is a severe issue to me.

I did some googling, and found an about one year old report on launchpad apparently describing the same issue I have; there they came to the conclusion that the bug was in the NetworkManager-plasmoid and it goes away with versions > 0.9.0. Now I installed 0.9.2 (openSUSE ships 0.9.0 by default), and the problem persists.

Anyone has an idea how to fix this (other than switching to Wicd, which I’d like to avoid)?

Have you tried deleting the plasmoid from the Task Manager


using the one in-bedded in the System Tray?

Hmm, not yet. I’ll give it a spin. Thanks for the tip.

Nah, still no good :frowning:

Do you see the NetworkManager in the System Tray?

Have you tried a re-install of all NetworkManager packages?

If that doesn’t work is it possible you have a crossed distribution install?

Do you see the NetworkManager in the System Tray?


Have you tried a re-install of all NetworkManager packages?

Yes too.

If that doesn’t work is it possible you have a crossed distribution install?

Well, I currently have from KDE:Unstable:Playground, so not a vanilla installation but it’s from a 12.2 repo.

I’ve been wondering if it’s possible to use the plain GTK system tray applet that XFCE or LXDE uses as well? I can’t find it (not nm-applet or NetworkManager-applet).

Unstable Playground. The name should make one expect things like this.

What also bothers me, is the word “currently”. It indicates you used other versions (correct?), which makes me wonder how you install/uninstall packages, and which repos they come from.


See package plasmoid-networkmanagement.

Suggest the outputs of the following cmds be carefully checked

zypper ve
(to verify correct install of all packages)

zypper lu
(to list updates)

If they show nothing amiss


zypper dup

but give the input n (not to install anything) at the first prompt
or your install might be trashed (extreme caution needed, with this one)

good luck


As I stated in the first post, this problem has been spanning through several package versions for me, upgrading to unstable was one of my attempts to fix the thing.


zypper ve & zypper lu say nothing interesting (“all deps are ok” and “no updates” respectively). I’m not sure what zypper dup is supposed to achieve; it wants to update a lot of packages, but NetworkManager or the plasmoid is not amongst them.

I’m really grateful for the help here, but it looks like a software bug after all. I think I’ll go ask the KDE guys about it.


Sorry about not being able to help.

If its any consolation my son has similar problems on WiFi. Wireless to the
dongle then dongle to 3G.
If the signal is unreliable the system tries to re-connect and requests the
root password, authentication, … etc.
His solution is to wait for a good 3G signal and then reboot.
This is not seen as a bug but safe operational necessity.

The time to the re-connect notice is dependent upon the set timeout.
The default on his laptop is 30 seconds.

For a cross-matched distribution my preferred solution is yast.
In yast program manager, repositories tab, system, look to
see if any packages are newer than the selected distribution (in RED). Those
indicated depends on the repositories selected and the priority given to each.

On this laptop there are about 70 such packages indicated but that’s the users

best of luck


Just a thought,

– do you have a file /etc/systemd/systemd-journald.conf?


– do you have a file /var/log/journal/<32bit-hex-#>/system.journal
if so what’s its size?