NetworkManager needs manual start!

Hello

I am new to Tumbleweed, installed fine, KDE edition, only have one issue, every time I reboot I have to run sudo systemctl restart NetworkManager in order to get my Wired net to show n connect. Although it shows in KDE settings all I can do is delete it not connect… I did not install wicked thing so I do not have it as an option…

Please help !

Is the NetworkManager and NetworkManager-dispatcher service set to automatic start?

YaST → System → Services

Yes that’s why I find it so frustrating xD

Reboot, before restarting NetworkManager capture full output of

sudo journalctl -b --no-pager --full

and upload to https://paste.opensuse.org/. Post link here.

Here’s paste
https://paste.opensuse.org/pastes/9dfd6fba0de1

Your system is too fast. NetworkManager starts too early, before interfaces are fully initialized and renamed by udev, and apparently it ignores renamed interfaces.

Jan 03 17:51:38 XPS-Station NetworkManager[1088]: <info> [1704297098.8475] NetworkManager (version 1.44.2) is starting... (boot:f4726069-41b6-4e9a-9aec-ba9cf7e72201)
...
Jan 03 17:51:38 XPS-Station NetworkManager[1088]: <info> [1704297098.9754] device (wlan0): driver supports Access Point (AP) mode
Jan 03 17:51:38 XPS-Station NetworkManager[1088]: <info> [1704297098.9760] manager: (wlan0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/2)
Jan 03 17:51:38 XPS-Station kernel: ath10k_pci 0000:3a:00.0 wlp58s0: renamed from wlan0
...
Jan 03 17:51:39 XPS-Station NetworkManager[1088]: <info> [1704297099.0481] device (wlan0): interface index 2 renamed iface from 'wlan0' to 'wlp58s0'
...
Jan 03 17:51:39 XPS-Station NetworkManager[1088]: <info> [1704297099.0850] device (wlp58s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')

On both my physical and virtual systems NM is started several seconds after interface initialization is completed (together with renaming).

I see several workarounds

  1. Brute force - just add several seconds delay to starting NetworkManager
  2. Disable interface renaming. NetworkManager does not really depends on the names, at least in default configuration. I do not know whether you have some applications that are bound to specific interfaces by name.

The best would be to tell NM to handle such cases, I do not know if it is possible.

Too fast ? It’s a laptop from 2015 with only an iGPU … Anyway how do I add delay ? It was fine on Arch/My own distro xD

May be it is too slow and takes too much time to load and initialize drivers. The end result is the same. GPU is irrelevant here.

mkdir -p /etc/systemd/system/NetworkManager.service.d
cat > /etc/systemd/system/NetworkManager.service.d/delay.conf << \EOF
[Service]
ExecStartPre=/usr/bin/sleep 5
EOF

Adjust delay as needed.

Thanks will test tomorrow, but what if it’s too slow ? That will make it even slower…

Well that broke things even further, it won’t startX have to do it manually and even after restarting network will not connect now I have to use nmtui to connect manually… Something ain’t right … I am starting to regret Tumbleweed xD

Pristine configurations of NetworkManager start without further ado. This behaviour made me try and delete all configuration files from directories /etc/NetworkManager/ and /var/lib/NetworkManager/. What doesn’t exist won’t break.

I just did that no go still have the same exact issue… I have resorted to creating an alias rnet to restart NetworkManager after every reboot … I think I will go back to Arch where that works at least xD

I really wanna like Tumbleweed but with an issue like this taking time to resort when it should be a straightforward thing make me have to re-think this…

P.S : Could it be because I am using a USB-C Dongle with Ethernet n USB-As ? This laptop only has 2 USB-C ports…

Without logs it is difficult to guess what happens.

The same thing so I thought it would be useless to send same logs… Long story short am back where I was … Your solution did not work… Time to move on to another