NetworkManager fails to launch when switching from wicked

Recent install of 15.3 on a laptop. Chose NetworkManager at install, but NetworkManager fails to launch and system defaults to wicked. Seems identical to this bug report, which claims to be fixed in later versions of NetworkManager and Augeas. I’m pretty certain the issue is that my PSK contains a “#” character, which possibly isn’t handled properly?

What options do I have to fix this? It is kind of annoying as I frequently connect to wifi networks while out and about, at the library, etc. And having to manually change network configurations each time via yast is a pain. I looked in to installing yast2-network from HEAD, but it wants to pull in a ton of repos and I’m not even sure if that is where my issue lies. Thanks!

How do you know it? Similar symptoms does not mean identical cause. Did you debug it to be sure?

which claims to be fixed in later versions of NetworkManager

It has nothing to do with Network Manager.

and Augeas.

No. It is claimed to be fixed in YaST if augeas is also fixed. There is no augeas release that includes commit that should fix it in augeas. And this bug is against Tumbleweed, not against openSUSE 15.3.

What options do I have to fix this?

Open openSUSE Leap 15.3 bug report, mention Tumbleweed bug and upstream https://github.com/hercules-team/augeas/pull/723 and ask if it is possible to backport this to 15.3.

it is kind of annoying as I frequently connect to wifi networks while out and about

If your question is how to switch between wicked and NetworkManager (as opposed to “fixing the bug”) - just disable wicked and enable NetworkManager as described in bug you mentioned, comment #3.

@arvidjaar, thanks for the advice. Filed https://bugzilla.opensuse.org/show_bug.cgi?id=1190843. In the mean time, I forgot to mention that manually starting the NetworkManager service (and killing wicked) as suggested in the TW issue does work for me.

As OP, I just wanted to follow up, this bug was fixed as part of https://bugzilla.suse.com/show_bug.cgi?id=1187512. My machine received the latest updates and the problem is solved.