NetworkManager disabled, KDE boots up slow

Hi community,

Wow! openSUSE is not going easy on me.
This time, after booting up my system, all of a sudden KDE boots up slow, and I am unable to access my internet. System was working great before this happened. NetworkManager (now changed to a blue icon) detects no wireless connection, same with LAN.
I tried to run/re-enable **NetworkManager **from the terminal and it throws up this error:

** (process:4416): CRITICAL **: lookup_or_register_specialized: assertion 'specialized_types_is_initialized ()' failed

This same error was generated exactly 27 times. I also noticed KDE boots up significantly slower now.
Before this error, my immediate installations were Yakuake, python-gst & gstreamer-python (for running deepin music player).
Help, good Samaritans!

My laptop specs: oS 13.1, 64bit KDE (latest stable build), 4gb ram and a core-i3 m370 processor.

Update: Wired works after changing to **Traditional Method with ifup **in the Network Settings.
KDE is still booting slow and Wireless still doesn’t work.

You did not say what WIFI chip??

Its an Atheros AR9285.
Do you know why this is happening?

When you installed python-gst, that was all that installed? If so you can probably remove it, since it wasn’t needed.

I think that wifi chip uses the ath9k module (check the output from lsmod).

You can analyse the booting via;

systemd-analyze blame
systemd-analyze critical-chain

Yes the wifi chip uses that ath9k module.
I removed the gst-python package. I also ran both the commands like you advised, this was the output.

(Some of the lines were bold red)         51.382s network.service
         29.894s network@enp7s0f5.service
         20.750s network@wlp3s0.service
          6.342s SuSEfirewall2_init.service
          2.235s apparmor.service
          1.952s cycle.service
          1.950s systemd-udev-root-symlink.service
          1.470s dev-hugepages.mount
          1.469s sys-kernel-debug.mount
          1.467s dev-mqueue.mount
          1.464s kmod-static-nodes.service
          1.272s xdm.service
          1.255s ModemManager.service
          1.243s systemd-vconsole-setup.service
          1.189s bluetooth.service
          1.182s avahi-daemon.service
          1.157s systemd-logind.service
          1.154s wpa_supplicant.service
           906ms systemd-remount-fs.service
           646ms systemd-readahead-collect.service
           646ms systemd-readahead-replay.service
           413ms postfix.service
           406ms systemd-sysctl.service
           384ms dev-disk-by\x2did-ata\x2dST9500325AS_6VE8RL7A\x2dpart1.swap
           369ms systemd-modules-load.service
           365ms plymouth-start.service
           337ms systemd-random-seed.service
           334ms var-run.mount
           326ms plymouth-read-write.service
           278ms SuSEfirewall2.service
           180ms user@1000.service
           150ms systemd-tmpfiles-setup-dev.service
           102ms systemd-tmpfiles-setup.service
            95ms polkit.service
            83ms systemd-update-utmp.service
            44ms smpppd.service
            39ms alsa-restore.service
            32ms rtkit-daemon.service
            27ms systemd-udev-trigger.service
            27ms udisks2.service
            21ms rsyslog.service
             7ms upower.service
             7ms systemd-user-sessions.service
             5ms rc-local.service
             5ms var-lock.mount
             4ms systemd-backlight@acpi_video0.service
             3ms systemd-journal-flush.service
             3ms systemd-udevd.service
             3ms systemd-update-utmp-runlevel.service
             2ms systemd-hostnamed.service
             2ms systemd-readahead-done.service

The second command:

The time after the unit is active or started is printed after the "@" character.

The time the unit takes to start is printed after the "+" 
character. @1min 8.461s

 └─ @1min 8.461s
  └─cron.service @1min 8.461s
   └─postfix.service @1min 8.047s +413ms
    └─ @1min 8.045s
     └─ @1min 8.044s
       └─network.service @16.662s +51.382s
        └─SuSEfirewall2_init.service @10.319s +6.342s
         └─ @10.289s
          └─ @10.288s
            └─systemd-tmpfiles-clean.timer @10.288s
             └─ @10.235s
              └─ @10.235s
               └─dev-disk-by\x2did-ata\x2dST9500325AS_6VE8RL7A\x2dpart1.swap @9.850s +384ms
                         └─dev-disk-by\x2did-ata\x2dST9500325AS_6VE8RL7A\x2dpart1.device @9.850s