NetworkManager at startup?

I would like to know how to launch NetworkManager at laptop startup.

At present I have to open a terminal window, change to root and then open NetworkManager. Setting up a properly working wlan connection has been very painful experience. It seems that this is the final obstacle on the way.

I am a linux newbie, running suse 11.1 on Lenovo sl400. So far this forum has been very helpful.

There doesn’t seem to be a great deal of information about this situation yet. I installed opensuse 11.1 on my laptop 2 months ago and everything worked great right out of the box. 2 nights ago I finally got my data backed up and performed a fresh install on my desktop. Everything works great but NetWorkManager doesn’t run at startup either. The ethernet still works and I have internet access but once I start NetworkManager and fire off Knetworkmanager it seems I lose my ability to gain access to the internet. I can login to my router but that’s about it until I reboot. No matter what settings I try I cannot get online unless I reboot and NOT start NetworkManager.

I would think for those that can get properly configured with Knetworkmanager once networkmanger has started, should be able to add networkmanager to a startup script thus having knetworkmanger appear in their taskbar when their desktop loads. It’s just a theory but I don’t see why it wouldn’t work unless Suse is already trying to start it and it’s failing. Perhaps it could start at a higher run level in that case.

Forgive me if I’m missing something here, but have a read of this thread. What desktop are you using?

For reference, I’m using KDE4.2.4 (openSUSE 11.0), and I have configured NetworkManager to control my network interfaces via YaST. So, it starts up at boot time with network interfaces. Additionally, I’m still using KDE3 knetworkmanager which has link in ~/.kde4/Autostart to start automaigically. (I haven’t yet tried the KDE4 front-end).

I am using KDE3.5 but the issue pertains to openSUSE 11.1. I had no issues with openSUSE 11.0.

Open Suse 11.1 NetworkManager Problem | Edmonds Commerce Blog

Thanks for the help and sorry for the trouble! Iam ashamed to admit that the solution to my problem was so simple. I simply changed Network Setup Method from “ifup” to “User Controlled”. I guess I should check the options more carefully next time.

Life can be full of embarrassing moments;)

Lucky you! I tried to change from “ifup” to “user controlled”, reboot and the configuration goes back to “ifup”. >:(

After many wasted hours I finally decided to backup my Data (again) and re-install 11.1 one more time before going back to 11.0. I have other issues with 11.1 but I’ll post them in their proper locations. I am happy to report that after a second install of 11.1, I no longer have the network issue but now my sound sucks…lol. Go figure.