NetworkManager applet not working

I’m not able to use to wifi connection after doing a distribution upgrade to 12.3 a couple days ago.

I’ve followed the instructions posted here:
https://www.suse.com/releasenotes/x86_64/openSUSE/12.3/#idm47311841257152

and here:
https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/484160-12-3-network-fix-post-install-announcement-sticky.html

with no luck so far. I also get a popup periodically asking for root password. The message is:
“System policy prevents modification of personal network settings”
Action: Modify personal network connections
Vendor: NetworkManager

Entering the password or cancelling has not visible effect.

When I click on the NetworkManager icon in my systray I get the screen, but can enable networking (“NetworkManager not running”). I’ve re-installed NM with no effect (and it’s selected in network settings through the yast gui). I can access the internet through my ethernet connection from a friend’s house, but the issue is that at home I don’t have physical access to the router (share with neighbor), so wifi is a must.

Output of lspci -nn:


lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c)
00:02.1 Display controller [0380]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) [8086:2a03] (rev 0c)
00:19.0 Ethernet controller [0200]: Intel Corporation 82566MM Gigabit Network Connection [8086:1049] (rev 03)
00:1a.0 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 03)
00:1a.1 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 03)
00:1a.7 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 03)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 [8086:2843] (rev 03)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 [8086:2845] (rev 03)
00:1c.4 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 [8086:2847] (rev 03)
00:1d.0 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 03)
00:1d.1 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 03)
00:1d.2 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 03)
00:1d.7 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f3)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801HEM (ICH8M-E) LPC Interface Controller [8086:2811] (rev 03)
00:1f.1 IDE interface [0101]: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller [8086:2850] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] [8086:2829] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801H (ICH8 Family) SMBus Controller [8086:283e] (rev 03)
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4227] (rev 02)
15:00.0 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev ba)
15:00.1 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 04)



Output of iwconfig:


iwconfig
eth0      no wireless extensions.


lo        no wireless extensions.


wlan0     IEEE 802.11abg  ESSID:"myqwest08011"  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

I couldn’t find any error messages for the card in dmesg. iwlist scan shows the network just fine.

Any pointers? Please let me know if I left out any info that might help.

Found in /var/log/messages:


  │2013-03-18T14:32:52.288078-06:00 laptop dbus[864]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.23" (uid=1000 pid=1980 comm="kdeinit4: plasma-desktop [kdeinit]   │ 
  │~           ") interface="org.freedesktop.NetworkManager" member="Enable" error name="(unset)" requested_reply="0" destination="org.freedesktop.NetworkManager" (uid=0 pid=889 comm="/usr/sbin/Networ│ 
  │~kManager --no-daemon ")                                                                                                                                                                             │ 
  │2013-03-18T14:32:52.877132-06:00 laptop dbus-daemon[864]: dbus[864]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.23" (uid=1000 pid=1980 comm="kdeinit4: plasma-de│ 
  │~sktop [kdeinit]              ") interface="org.freedesktop.NetworkManager" member="Enable" error name="(unset)" requested_reply="0" destination="org.freedesktop.NetworkManager" (uid=0 pid=889 comm│ 
  │~="/usr/sbin/NetworkManager --no-daemon ")

On 03/18/2013 03:46 PM, HHH100 wrote:
>
> Found in /var/log/messages:
>
> Code:
> --------------------
>
> │2013-03-18T14:32:52.288078-06:00 laptop dbus[864]: [system] Rejected send message, 2 matched rules; type=“method_call”, sender=":1.23" (uid=1000 pid=1980 comm=“kdeinit4: plasma-desktop [kdeinit] │
> │~ “) interface=“org.freedesktop.NetworkManager” member=“Enable” error name=”(unset)” requested_reply=“0” destination=“org.freedesktop.NetworkManager” (uid=0 pid=889 comm="/usr/sbin/Networ│
> │~kManager --no-daemon “) │
> │2013-03-18T14:32:52.877132-06:00 laptop dbus-daemon[864]: dbus[864]: [system] Rejected send message, 2 matched rules; type=“method_call”, sender=”:1.23" (uid=1000 pid=1980 comm=“kdeinit4: plasma-de│
> │~sktop [kdeinit] “) interface=“org.freedesktop.NetworkManager” member=“Enable” error name=”(unset)” requested_reply=“0” destination=“org.freedesktop.NetworkManager” (uid=0 pid=889 comm│
> │~="/usr/sbin/NetworkManager --no-daemon ")
>
> --------------------

Did you read the release notes? Does the work-around there help?

I take it you’re talking about this: openSUSE 12.3 Release Notes
and the instruction under 4.1?

Yeah, applied those (and re-applied just to make sure) to no avail unfortunately.

Have you tried removing your wireless connections and starting over? Make them ‘System Connections’ and use kwallet for secrets.

Sorry, where should I erase it?

Under yast2 -> network settings I get the notification that network settings are handled by NetworkManager. When I try to access the applet it notifies me that NM is not running although it is (see below).


ps ax|grep -i netw
  889 ?        Ssl    0:00 /usr/sbin/NetworkManager --no-daemon

Don’t you have a network management widget present? That’s the usual way. How did you have it configured with openSUSE 12.2?

If you have ‘system connections’ defined, they’re stored in the /etc/NetworkManager/system-connections/ directory. (User connections are within the user’s home directory).

The widget is running, but I can’t check the checkbox for “Enable networking” (it claims NetworkManager is not running). When I right click and go to “Network Management Settings” it lists no wired (which I’m using right now to post this) or wireless devices or connections at all…

What does the following report?

# systemctl status NetworkManager.service

NetworkManager.service - Network Manager
          Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
          Active: active (running) since Mon, 2013-03-18 17:42:42 MDT; 1min 5s ago
        Main PID: 776 (NetworkManager)
          CGroup: name=systemd:/system/NetworkManager.service
                  ├  776 /usr/sbin/NetworkManager --no-daemon
                  └ 1409 /sbin/dhclient -d -4 -sf /usr/lib/nm-dhcp-client.action -pf /var/run/dhclient-eth0.pid -lf /var/lib/dhcp/dhclient-96c0a097-03e0-43b1-80e8-aa02750446ad-eth0.lease -cf /var/ru...


Mar 18 17:43:13 laptop.site NetworkManager[776]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Mar 18 17:43:13 laptop.site NetworkManager[776]: <info> Activation (wlan0/wireless): access point 'myqwest08011' has security, but secrets are required.
Mar 18 17:43:13 laptop.site NetworkManager[776]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
Mar 18 17:43:13 laptop.site NetworkManager[776]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Mar 18 17:43:23 laptop.site NetworkManager[776]: <warn> No agents were available for this request.
Mar 18 17:43:23 laptop.site NetworkManager[776]: <info> (wlan0): device state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
Mar 18 17:43:23 laptop.site NetworkManager[776]: <info> Marking connection 'myqwest08011' invalid.
Mar 18 17:43:23 laptop.site NetworkManager[776]: <warn> Activation (wlan0) failed for connection 'myqwest08011'
Mar 18 17:43:23 laptop.site NetworkManager[776]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Mar 18 17:43:23 laptop.site NetworkManager[776]: <info> (wlan0): deactivating device (reason 'none') [0]


On 03/18/2013 06:56 PM, HHH100 wrote:
>
> Code:
> --------------------
>
> NetworkManager.service - Network Manager
> Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
> Active: active (running) since Mon, 2013-03-18 17:42:42 MDT; 1min 5s ago
> Main PID: 776 (NetworkManager)
> CGroup: name=systemd:/system/NetworkManager.service
> ├ 776 /usr/sbin/NetworkManager --no-daemon
> └ 1409 /sbin/dhclient -d -4 -sf /usr/lib/nm-dhcp-client.action -pf /var/run/dhclient-eth0.pid -lf /var/lib/dhcp/dhclient-96c0a097-03e0-43b1-80e8-aa02750446ad-eth0.lease -cf /var/ru…
>
>
> Mar 18 17:43:13 laptop.site NetworkManager[776]: <info> (wlan0): device state change: prepare → config (reason ‘none’) [40 50 0]
> Mar 18 17:43:13 laptop.site NetworkManager[776]: <info> Activation (wlan0/wireless): access point ‘myqwest08011’ has security, but secrets are required.
> Mar 18 17:43:13 laptop.site NetworkManager[776]: <info> (wlan0): device state change: config → need-auth (reason ‘none’) [50 60 0]
> Mar 18 17:43:13 laptop.site NetworkManager[776]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
> Mar 18 17:43:23 laptop.site NetworkManager[776]: <warn> No agents were available for this request.
> Mar 18 17:43:23 laptop.site NetworkManager[776]: <info> (wlan0): device state change: need-auth → failed (reason ‘no-secrets’) [60 120 7]
> Mar 18 17:43:23 laptop.site NetworkManager[776]: <info> Marking connection ‘myqwest08011’ invalid.
> Mar 18 17:43:23 laptop.site NetworkManager[776]: <warn> Activation (wlan0) failed for connection ‘myqwest08011’
> Mar 18 17:43:23 laptop.site NetworkManager[776]: <info> (wlan0): device state change: failed → disconnected (reason ‘none’) [120 30 0]
> Mar 18 17:43:23 laptop.site NetworkManager[776]: <info> (wlan0): deactivating device (reason ‘none’) [0]

On two of my systems, pulse audio prevented the NM applet from getting any
responses from dbus. For those, I had to use YaST to delete every package that
starts with “pulse” so that NM would work.

On two of my systems, pulse audio prevented the NM applet from getting any
responses from dbus. For those, I had to use YaST to delete every package that
starts with “pulse” so that NM would work.

Interesting. That’s a new one on me.

Interesting. I deleted the packages starting with pulse, but no change. Grepping in /var/log/* for anything related to pulse doesn’t really show me any error messages either. I wish I had a blank dvd to a clean re-install, super stuck…

Well this isn’t right

Mar 18 17:43:13 laptop.site NetworkManager[776]: <info> Activation (wlan0/wireless): access point
'myqwest08011' has security, but secrets are required.
Mar 18 17:43:13 laptop.site NetworkManager[776]: <info> (wlan0): device state change: config ->
need-auth (reason 'none') [50 60 0]
Mar 18 17:43:13 laptop.site NetworkManager[776]: <info> Activation (wlan0) Stage 2 of 5 (Device
Configure) complete.
Mar 18 17:43:23 laptop.site NetworkManager[776]: <warn> No agents were available for this request.
Mar 18 17:43:23 laptop.site NetworkManager[776]: <info> (wlan0): device state change: need-auth ->
failed (reason 'no-secrets') [60 120 7]
Mar 18 17:43:23 laptop.site NetworkManager[776]: <info> Marking connection 'myqwest08011' invalid.

Did you have kwallet (for secrets) running? You should delete the config in /etc/NetworkManager/system-connections/ and start over.

Can you get ‘Manage Connections’ up via the NM widget? Under ‘Other’, there is the option to store connection secrets in a config file (insecure) or via kwallet (secure)…

Yeah, I can get Manage Connections, but it doesn’t show any wired/wireless devices at all. I’ve deleted the config files for the network, but I can’t even get far along in the process anywhere to get to input any wifi data.

I do use kwallet. As a matter of fact I was having some issues with it after the first update and I removed the wallet and started a clean/new one (I have all the data in keepass anyway).

Let’s return to the terminal (regular user) and have a look at interfaces controlled by NM:

nmcli dev

The status of NM:

nmcli nm

Check any connections defined

nmcli con

nmcli dev returns:


DEVICE     TYPE              STATE        
wlan0      802-11-wireless   disconnected 
eth0       802-3-ethernet    connected

(Odd that it’s marked as disconnected since I can run “iwlist wlan0 scan” and see a listing of local networks just fine)

nmcli nm returns:


RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         connected       enabled         enabled    enabled         disabled 

nmcli con returns:


xxx                 7f347694-b049-4547-a736-f79ab51c2555   802-11-wireless   Thu 18 Feb 2010 02:53:04 PM MST   
xxx            8fd1e29c-bc86-42f7-bfcd-0304211da43a   802-11-wireless   Fri 26 Feb 2010 12:36:33 PM MST   
xxx                   f0fa2f0e-34c7-48a2-9a2e-001f64739870   802-11-wireless   Tue 08 Jan 2013 09:46:02 AM MST   
Android Tether            148564e5-c8e6-4c40-981e-ab0382e6ef3e   802-11-wireless   Thu 12 Jan 2012 09:33:14 AM MST   
<snipped>

No, that’s not odd at all - it means you’re not connected (aasociated) . Visibility of a wireless does not mean connected.

nmcli nm returns:

RUNNING STATE WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
running connected enabled enabled enabled disabled

The above looks fine

nmcli con returns:

xxx 7f347694-b049-4547-a736-f79ab51c2555 802-11-wireless Thu 18 Feb 2010 02:53:04 PM MST
xxx 8fd1e29c-bc86-42f7-bfcd-0304211da43a 802-11-wireless Fri 26 Feb 2010 12:36:33 PM MST
xxx f0fa2f0e-34c7-48a2-9a2e-001f64739870 802-11-wireless Tue 08 Jan 2013 09:46:02 AM MST
Android Tether 148564e5-c8e6-4c40-981e-ab0382e6ef3e 802-11-wireless Thu 12 Jan 2012 09:33:14 AM MST

So there are wireless connections defined.

I was able to resolve the issue, there’s 2 things could have fixed it:

  1. Delete the kwallet files.
  2. Log out from the desktop to kvm, and start a clean session (I noticed I kept getting an old session).

Wish I could pinpoint it further, but hopefully this will help somebody else.