Networking in RC1 not working

Hi all,

I have downloaded RC1 and it’s looking good so far. However, I’m having trouble getting networking (wired and wireless) to work. The connection progresses to the ‘IP configuration’ stage, and then it hangs for a minute or two before failing. I don’t have this problem with Kubuntu, but I’m keen to make the switch to opensuse, so any help would be really appreciated.

BTW I am using a D-Link DWA-556 (Atheros 5418) and Gigabit ethernet.


Well, I can’t get connectivity in KDE using KNetworkManger (KDE3) or Network plasmoid (KDE4), so I switched to GNOME’s nm-applet and everything’s working OK. Check if that is your problem.

The network plasmoid has some issues, try configuring your connection manually by searching for Network settings in the KDE menu.

Set it to ifup instead of network manager and it should work. Or I guess as mentioned, use gnome’s network manager… or maybe the KDE3 one?

Thanks for replying. :slight_smile:

After clicking ‘traditional method with ifup’ in network settings under Yast, I am not sure what I need to do next to set up my network connection. I’m new to this so any help would be great.

Alternatively, how might I install the Gnome network manager without internet access? (I could download the relevant files using another computer if you could point me in the right direction).

I’m having the same problem with the RC-1. kde networking is not working. Gnome says it is “active,” but firefox remains unconnected.

I have a wired ethernet connection within an Ubuntu-preinstalled Dell Inspiron 530N desktop.


I downloaded the 11.1 RC1 KDE liveCD for x86-64 and am having a similar network problem. I will try to fix it using suggestions on this page. But since network has always worked ‘out of the box’ for me w/ opensuse, including 11.1 beta 5, I suggest some effort be put into sorting this out. Today, not having network access is sort of like not having a computer for many.


One more thing - My opensue desktop has a wired connected to a router which gets inet access from a cable modem. This setup works for the mac laptop on which I write this.

For what it’s worth.

OK, I switched to ‘traditional ifup’ in yast network devices instead of kde net.mgr., and all is well. Perhaps this should be the default? Either way my problem is solved.

ifup is the default on all the installs I’ve done.

If you do a reinstall, use the auto configuration (which is also the default).

ifup worked for me also.

Thanks for the help.:cool:

Using ifup isn’t working for me, for both wireless and wired networking. Could someone please shed some light on what might be the problem?

My network connections work fine in Ubuntu.

It appears Networking in KDE4 is still broken. I downloaded KDE3 Networkmanager and used that. This seems to work.


Can you run ‘rcnetwork restart’ as root from a terminal and post what the output is?

Also use the lsmod command to see if the modules for your network devices are loading.

I was living the networkmanager nightmare until I upgraded to rc1. In the beta5, I could not get to the internet. Once I upgraded, I had to start networkmanager from the suse menu. That gave me the familiar greyed-out globe.

Right-clicking the globe popped up a box showing my home network at the top. I clicked on the home network and after what seemed like a very long time, it connected and worked as it had in previous releases. In other words, from my viewpoint, they fixed it in rc1. After that first, long, connection process, it connects pretty quickly now.

Maybe zypper up will help you out.

It is still broken for 3G modems:
My only internet connection is through a 3G modem… :’(