Network won't come back up

Hi. My router/adsl modem is not connected to a power supply so when power goes and comes the network will do a re-boot. Now the problem is my OpenSUSE network won’t come back on! I set the static ip as Autoeth0 to eth0 however when network updates I losse eth0. Why is this happening? Why doesn’t the PC simply re-connect? Can I do it via command line? (somehow ifconfig isn’t permanent)

Well, you didn’t provide a lot of information there.
Is your ISP using DHCP?
Maybe take a look at this; /etc/network/interfaces Ubuntu Linux networking example

Are you using NetworkManager, or are you using “ifup”?

Well our ISP has given us a static IP number.(Don’t know what this has to do with my network configuration on my PC). And is there really a “/etc/network/interfaces” isn’t that for Debian systems? I’m using network manager. What is ifup? Please do ask questions if it is need to answer mine.

For comparison, I am using “ifup” on my desktop system, and NetworkManager on my laptop.

If you go into yast, network settings, you can switch to “ifup”. But only try that if you are using a fixed network connection. A laptop is probably better off with NetworkManager, since it can be moved from place to place.

Here’s my experience. On my desktop system (actually, two different systems), the network has been rock solid. If I restart my home router, the network continues. However, on restarting the network it does not seem to be using DHCP - it just continues with it’s prior lease. This should not be a problem for you, since you have a static IP (and my router provides a static IP on the private home LAN).

A caution, however. If I restart the network, sometimes my wife’s desktop loses it’s network connection. It is running Windows Vista. The problem there seems to be network device related, rather than software related. If I unplug it from the network, and leave it unplugged for several minutes, then it recovers its connection when I plug in again.

On my laptop, using NetworkManager (and KDE), things have not done as well. At home, where it is connected with WiFi, it is usually okay. I did lose connection once. The laptop thought it was connected, but the data was not flowing. I was able to fix that with “disable network” followed by “enable network” on the knetmanager applet.

At work, with that same laptop and a wired connection, things were more iffy. On several occasions, I found it unable to pass data to the network, though it thought it was connected. In an attempt to fix this, I disconnected the ethernet cable, waited briefly, then plugged the cable in again. It never did reconnect. I had to logout from my KDE session, and then login again before the connection would recover. (Perhaps restarting knetworkmanager would have done the trick, but I didn’t try that).

I should mention that I am using opensuse 11.3. This seems to be a new problem. I never had a similar problem with opensuse 11.0, nor with opensuse 10.1 before that. NetworkManager seems to have received major changes between 11.0 and 11.3, and they have fixed some problems but seem to have created others.

Yes, /etc/network/interface exists in openSUSE. It is a universal directory. Try Googling it.
I don’t mind helping someone, but then when I do and I Google it, and you don’t … that’s annoying. I can tell you didn’t Google it, or do much, if any reading on the subject. Had you, you would have discovered the answer.

Here. Try this; “/etc/network/interfaces” - Google Search]("%2Fetc%2Fnetwork%2Finterfaces"“auto+eth0”
And maybe try this; /etc/network/interfaces - Google Search
Just because you see Ubuntu or Debian, doesn’t mean it won’t work. Read it. Learn from it. Apply it.