Network setup questions

I have installed 13.2 onto my wife’s HP desktop. It’s a fairly new computer and is a dualboot Windows 8.1/Opensuse.

I also installed it as dualboot on my HP notebook (i7,12gb). 13.2 stopped during installation and indicated both my wireless and wired connections were unconfigured. I clicked next to continue installation and the network issues sorted themselves out.

The issue is my wife’s desktop.
The installation stopped for unconfigured wired and wireless cards (as it did on my notebook), and I clicked continue to finish the installation but the cards never got configured after reboot.
The network icon on the bottom bar near the clock shows a broken connection with a red X.
No internet connection.

I went to Yast > Network Devices > Network Settings.
There in the Overview tab I saw both network cards as unconfigured.
I edited the wired connection to DHCP, applied it and reboot.
I now have internet access and installed all of the suggested OS updates and included the PACMAN repository.

I expected the taskbar connection icon to show connected, but odd how it still shows broken with a red X but actually has connection.

I click the taskbar connection icon and no connections are listed.

I tried to configure the wireless card by Yast > Network Devices > Network Settings as I did with the wired card but I can’t get the wireless to work, and available wireless networks remain blank.

I browsed this forum for information and I think my network manager may not be working. I opened terminal and put:

systemctl start networkmanager.service

But that command doesn’t seem to do anything.

If anyone can give a suggestion how to get her wireless connection working then it’s appreciated.
I’ve done some work in terminal but honestly, I am still learning the command line.
Thanks in advance.

This suggests to me that your network on this machine is set to use “Wicked”, the new replacement for ifup.

The Network Manager icon will still show on the KDE bar, but since it is not in control, will give the results you are witnessing.

You need to go back to Yast=>Network Settings and select the checkbox for User Controlled with NetworkManager

Then you can use the Network Manager icon to set things up.

On 2014-12-15 03:56, SteveFury61 wrote:

> # systemctl start networkmanager.service
> But that command doesn’t seem to do anything.

Most likely it simply says nothing about what it does or not. You have
to issue “systemctl status networkmanager.service” to find out.

Traditionally, in Linux, a command says nothing if it succeeds. The rule
is not always followed, but you can not assume that silence means failure.

Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

As Fraser_Bell indicated, you can switch to using NetworkManager. Problem solved.

But there’s also a different solution (linux gives you choices).

I am assuming that the computer is using KDE. Right click on the tray and select “System Tray Settings”. Then, in those settings, uncheck the box for “Network Management” and click OK. The network icon in the tray should disappear, and the red X will also disappear. Problem solved a different way.

… except that won’t fix the Wifi won’t connect issue.:wink:

This was the complete fix.
Thank you all so very much. Issue solved.


So pleased to hear it.:slight_smile: