Network problems

I have just upgraded from v. 12.2 to 12.3 (KDE) on my two i586 laptops. One works fine, the other one, a Toshiba Satellite constantly drops the (wired) network connection. I have set the network manager according to the “12.3 Network Fix - Post Install - Announcement Sticky” instructions and it makes no difference. Neither does if I try with the ifup methode. After the boot the network/internet is there, then its gone and all apps which used the network are frozen (e.g.Dolphin, Amarok, etc). lspci reveals that I have a “Ethernet controller: Atheros Communications Inc. AR8152 v1.1 Fast Ethernet (rev c1)” but I don’t know if this is relevant since on version 12.2 and before I had no problem. In fact this was the laptop from which I downloaded the 12.3 DVD. Checksum and media check are all fine.
Any ideas what could be wrong?

On Sun, 17 Mar 2013 01:46:01 +0000, fuerstu wrote:

> One works fine, the other one, a Toshiba Satellite constantly drops the
> (wired) network connection

Have you tried swapping the ethernet cables? What you describe sounds
like a bad cable or a bad connection.


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at

Yes, I tried swapping cables and tried connections from different sockets in the retwork - always the same result. My first thought was cables as well, but the one laptop always looses connection and the other computers have no problem.
I am just trying to figure out why the laptop sometimes drops out after only a few minutes, at other times it lasts up to 15 minutes. I run the network on NFS(v3) to a file server (a NAS). DHCP, internet connection, etc. runs on a Cisco 877 router.

The cable is one thing.

The contacts within the laptop are another.

It is hard to explain why it should run at least a few minutes (or 15 minutes at max) before it fails.

If it runs for a few minutes, then this most likely is a sign that this isn’t a failure of the software.

I wonder if you have a possible duplex mismatch between the Cisco port and your laptop? Sometimes, if they are both auto-negotiating, there can be problems.

What does the following report?

/usr/sbin/ethtool eth0

Now that I’ve had time to search further, perhaps this is a driver regression

I’ve seen various bug reports regarding this chipset/driver, but not found anything recent for kernel 3.7…

here is the result:
/usr/sbin/ethtool eth0
Settings for eth0:
Supported ports: TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Cannot get wake-on-lan settings: Operation not permitted
Current message level: 0x0000003f (63)
drv probe link timer ifdown ifup
Link detected: yes

And before someone asks both laptop run NFS(v3).

Yes that looks familiar - driver atl1c, network down with pings give “Destination Host unreachable” but IP address is there and I can ping myself. Do you know of any solution - different driver perhaps?

I would submit a bug report fir this, and consider rolling back to openSUSE 12.2.

Thanks, deano_ferrari, I will submit a bug report (probably tomorrow - it is evening now and I spend a day trying to sort computers), will roll back to 12.2

You might want to try capturing kernel messages relating to the driver

tail -f /var/log/messages|grep atl1c

Just noticed this thread. If it is an atl1x driver problem, they seem to have been updated between kernels 3.7.x and 3.8.x. Before downgrading it might be worth trying a 3.8 kernel.

(this is from memory, so be prepared for typos and mistakes)

zypper ar  Kernel:stable-standard
zypper mr -r Kernel:stable-standard
zypper up Kernel:stable-standard

You are a lucky person. Posted this in the wrong forum where the forum that says Network/Internet is prominantly displayed :frowning:

Nevertheless you got a lot of help. Yes, we are a nice bunch of people (in general). But my advice would be to post your next problem in the (sub)forum that seem best for the kind of problem and to give it a title that says a bit more then the one here, which in fact (and specialy if it would have been in Networkl/Internet) does not say any more then that you have problem. Which is rather normal in these help request forums :wink:

Why all this bureaucracy? It was a simple update and the problem was caused by this install on one laptop - on the other one everything was fine and in the previous version the network was fine. The network settings were taken over OK to the new version. You may as well say I should have put it in the hardware section since it seems to be a driver issue. I really appreciate the help I am getting and I agree that there are a nice bunch of people in the forums, but often it is not clear from the start in which forum it should go. Especially since there is the network setting issue prominently at the beginning of this forum.

It is not about bureaucracy, it is about you, as seeker for help, to get the best helpers.

I e.g. will not even look in the Virtualization subforum, because I do not use it, thus looking there is spoiling time that can be used to help were I can help. Thus posting in the most appropriate forum is important. For you. And using a title that has a short but to the point description on what the problem is about, has the same purpose., To advertise your problem to those that may see that and say: “Hey that is something I know about. maybe I can help”.

Strange enough, many people do not understand this and thus hide their problems (some even hang a problem at the end of a long solved other problem, They probably never will be seen :frowning: )
That is the only thing I try, to make posting here as efficient as possible, for everybody, but primaraly for the people needing help.

Thank you very much ent-int, I have now upgraded to the 3.8.3-1 kernel and the network is already up for approx 1hour. Before it never lasted so long, so I am hopeful this is OK now. The driver is still atl1c. That was certainly a much faster fix than downgrading, then installing all the additional programmes I use.

Good to know that the upgraded kernel worked for you. Always worth a try when there has been a regression with a kernel module, (although not always easy to discover if a desired bug fix has been incorporated).

Alas only too true. I could not find this in the changelogs at I did a “find -exec ls -l” in* /lib/modoles/3.[678].** for atl1* and noticed the changes in file size.

Good work :slight_smile: