Network problems

Hi all,

Since a week or 2 I am having problems with the network connection. I use a Samsung R730 laptop with wifi:

inxi -Nn
Network:   Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k 
           IF: wlp2s0 state: up mac: 4c:ed:de:eb:31:46 
           Device-2: Marvell 88E8040 PCI-E Fast Ethernet driver: sky2 
           IF: enp6s0 state: down mac: e8:11:32:0e:d2:ba 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 

The access point is about 2 meters away from it so I do have a strong signal. Phone and a laptop I have here from work, do connect fine to it.

I do use a Private Internet Access (PIA) VPN, and it’s with this that I do seem to have problems. Without the VPN it all works great, but with VPN it starts okay at boot. Networkmanager starts the wifi-connection which starts the VPN. I do have a connection as always, but after a while the dataflow stops. The VPN still says it is connected but there is no data anymore.
I contacted the PIA helpdesk where people really want to help you, but they do say that openSUSE is not the type of Linux they know and have an app made for so I do have to use Networkmanager with openvpn. I got some advice which I followed but it didn’t work. They have different settings I can use, different servers in different countries to connect to, but it is all the same. After a while data stops coming in, while my phone, which has the same VPN, does work great. Since I tried several servers with different settings and the problem stays the same I don’t think it is a PIA problem.

I use openSUSE on a daily basis from early October last year and the first months it was great, no problem at all. Then this started and I don’t know how to solve it.
Around the same time I had another problem: I have a NAS which I mount to my file-system using autofs, something I have used for 8 years or so on different distro’s. Also here in openSUSE it has worked great, till recently. Now I can’t connect at all anymore, not with and not without a connected VPN.
I use the same config files I use for ages already:

# Sample auto.master file

/mnt  /etc/auto.shares --timeout=10 --ghost

I did delete all the lines starting with the #-symbol cause that’s only text.
The auto.shares file looks like this:

NAS-WD                 -fstype=nfs,rw,soft,retry=0

As written, this is something I have used for ever and it always worked.

The NAS is always on so I thought about connecting it through fstab but I get an error saying the nfs protocol is not supported.

Has something network related changed a short while ago? Both problems I have seem to be network related so it might be one problem, also since it started around the same time. I don’t use the NAS every day so I can’t really say when that problem started though.

Thanks in advance for all your help.

Perhaps a measure of how busy the PIA gateways are in your region perhaps?

Thanks for your answer. I have been to that page already and did some tests. There is nothing wrong when doing the test, with and without VPN. The latter is a tiny bit slower but it’s hardly nothing.
As I wrote, I don’t think the problems are caused by PIA, it must be something in my laptop but I can’t figure out what it is.NAS-WD -fstype=nfs,rw,soft,retry=0

Are you using only NFS and not also “Windows Shares?”

A common problem with many NAS is that they’re set up to serve SMBv1, aka Windows Shares, CIFS.
SMBv1 is a common way for your shared data to be hacked, with the worst consequence becoming a Ransomware victim.

If your NAS can be re-configured to eliminate support for SMBv1 and support only SMBv2 or later
Use an alternative protocol like SFTP or FTPS, possibly HTTPS.

As for your VPN…
Without more info, it’s hard to guess… Could be related to your usage, an app, time of day, usage, more.
You should collect as much info as you can.

You can leave open a text console in your machine displaying your system events in real time, then notice what might be displayed when you have a problem. Run the following in a terminal app

journalctl -f

Try to note how you’re using your VPN when you have a problem and write down particulars, you’re looking for some kind of pattern.

If you’re torrenting or doing anything that is putting an unusually high load on networking resources, you can fix following what I describe in an article I wrote long ago… but completely applicable to today’s Linux (including openSUSE)


Are you able to test behaviour using a wired ethernet connection?

Over the years, I’ve seen numerous posts suggesting performance issues with some wifi chipsets using the ath9k driver. Some suggested settings that might be worth investigating perhaps…

I’ll leave you to investigate further.

I encountered this same issue at about the same time with autofs and a nfs ver 3 mount. My NAS handles both ver 3 and ver 4 so I switched to a version 4 mount:

nfs     -fstype=nfs4

If you search for recent threads in the forum you will find two that deal with the issue and spell out what the changes are and the current way to specify the version in the mount line.

Isn’t this related to /etc/nsswitch.conf ? Check the differences between that file and /etc/nsswitch,conf.rpmnew , merge them .

Hello all,

Thank you for your answers. I have read them but didn’t do anything with the answers, because I have done something else:
I downloaded and copied to a USB stick the latest Manjaro Linux which I then booted.
I setup the wifi and the VPN and used it for 4 hours straight and it just works: I did not have one problem with it at all.
I then installed it, keeping my home folder with all the settings files so I only had to install the programs I normally use and I was good to go.
As could be expected, also in the installed version no problems with the VPN. I’ve now been using it again for 4 hours and also now no issues.
Furthermore, and that too makes me very happy: autofs is working as it should work, also there no issues. I installed it, copied my config files (the ones I have been using for ever) and it just works.

That tells me one thing: something is wrong in openSUSE. Both issues are solved by changing (back) to a different distro, which I think is a shame cause in the last 4 months I really started to love openSUSE. Before starting to use it I read a ton of documents and webpages, I followed the update sequence to the letter and it has never gone wrong, but I want a working VPN and I need the NAS for backups. When openSUSE can not give that to me right now, I have to chose something else.

Again, thank you for your help. It is good to know people really want to help.

When I had the network problems I decided to return to Manjaro Linux, but that didn’t work perfect either. Not the same problems but other, small, things which irritated me.
In the meantime I downloaded the openSUSE Tumbleweed ISO a few times and used the live version to see if my problems were solved and yesterday I saw that they were indeed. Both of them.
So today I re-installed Tumbleweed and yes, both problems are solved. So if you wait long enough problems solve themselves.
Happy to be back.
Thanks again for the help I received when having these 2 problems.