Network problem - powerline adapter

I’ve had some problems with the network when it comes to internet on this machine. I use it primarily in the workgroup as a file server, but I use it when I want to go on the internet as well. in long periods it works fine, but suddenly it does not connect to the internett. I have maybe done something wrong with network settings. When I go to the network settings in Yast I get a error message that says:

More than one interface asks to control the hostname via DHCP. If you keep the current settings, the behavior is non deterministic.

Involved configuration files:
ifcfg-en2s0 dhcp

I thought the only interface I use is en2s0? I need some guidance with this problem, because it’s really annoying to wait or restart the adapter to get the internett up and running again.

Dag R

No stale config files?

ls -l /etc/sysconfig/network/ifcfg-*

I don’t know what you mean by stale in this connection, but in Norwegian understanding of the word we think of food getting old and start to rotten. But here is what output of what you asked for:

dagr@opensuse:~> ls -l /etc/sysconfig/network/ifcfg-*
-rw------- 1 root root 178 jan.  14 22:56 /etc/sysconfig/network/ifcfg-enp2s0
-rw------- 1 root root 147 jan.  11 17:15 /etc/sysconfig/network/ifcfg-lo

I meant some leftover (now irrelevant) config file lurking. That looks as expected.

Hang on - you mentioned en2s0, but your config file is named ‘ifcfg-enp2s0’. What is actually reported by ifconfig?


It’s nothing. There is’t anything in the file (/sbin/ifconfig).

Dag R

It’s not a file. It’s a command. Run

/sbin/ifconfig -a


/usr/sbin/hwinfo --netcard

Please enclose the output within code tags (refer to the ‘#’ button in the forum editor).

Good old ifconfig is not installed by default anymore :(.

One is supposed to use ip.

Normally a problem like this is checked from inside to outside. Thus the the first step is

ip addr

to see which NICs are configured and how.
As the OPs story seems to imply that he can connect within the LAN, I assume that that is OK, but nevertheless it is good to show it.

Next step would be a ping to an address inside the LAN to prove that connecting inside is OK. As I said above, that seems to be OK according to the OPs statement

ping -c1 <IP-address>

where must be replaced by an IP address of a functioning system in the LAN, preferable the router.

Then to go outside the LAN we need a route, most often the default route, pointing o the router that connects the LAN to to he outside world:

ip route

When a default route shows via the router, it must be possible to ping to the internet:

ping -c1

Whne that connection is OK, there is connection to the internet.

Last step is to check if DNS functions:

ping -c1

When one of these steps fails, testing next step(s) is useless. First that problem ust be solved.

So please @dagring

The first command said no file or folder, the second gave some more information.

Dag R

I have run those test, what does -c1 means?

Dag R

It is nice that you run those tests. But keeping the outcome a secret to us does not help much our efforts to help you.

As long as we are not clairvoyant, the idea behind we suggesting you to execute some commands is that you then copy/paste the whole thing (starting with the line that includes the prompt and the command, including of course the output and ending with the line with the new prompt) between CODE tags (you get them by clicking on the # button in the tool bar of the post editor) in a post. That is the only way that we can see what you see. The only way that this thread has any change to lead to a fruitful discussion.

It is s good thing that you want to know what commands will do before you execute them. You do that by consulting their man pages.Thus when you want to know what the -c1 means, you look in

man ping

Oh boy, I missed that.

You included the output in the QUOTE!!! Nice mess.
Of course I did not read inside that quote, assuming that is was just a repeat of my post.

When you QUOTE someones post (to show that you are specialy answering that post or part of it), you do not alter inside that.
You post your answer in your post, NOT in the QUOTE.

I posted

ip addr

You did something different:

ip adress

WHY??? Just copy/paste to avoid typos.

Ping to router is OK.

Default router is the same address. Fine.

Ping of did not work!!!

But ping to did work. That is very strange.

Now you report that sometimes it works and sometimes it doesn’t. Those are always the most difficult problems. In any case, you have now some commands to check when it does not work.
Report back whit their results when you have the problem next time.

Sorry about my answer in your quote. Thought in a bliss filled moment it was a good idea, but get your point. I run the tests when internet is not working, and report back to the tread with the findings.

Dag R

The internet connection was down some minutes and I ran the tests. Here’s the output:

dagr@opensuse:~> ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 9c:5c:8e:89:6a:f0 brd ff:ff:ff:ff:ff:ff
    inet brd scope global enp2s0
       valid_lft forever preferred_lft forever
Du har ny e-post i /var/spool/mail/dagr
dagr@opensuse:~> ping -c1
PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable

--- ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

dagr@opensuse:~> ip route
default via dev enp2s0 dev enp2s0 proto kernel scope link src 
dagr@opensuse:~> ping -c1
PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable

--- ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

dagr@opensuse:~> ping -c1
ping: Midlertidig feil i navneoppslag

ping forums.xx gives a norwegian respons, but it says the name search is not available at the moment. I hope you can see something here, which can be fixed.

Dag R

as I said, there is no use in doing the steps after one that fails. And this cleary fails.

It looks as if your router is unavailable. Thus I assume you have to look into your router’s behavior.

Another possibility is that your NIC looks fine, but fails. A ping to another system inside your LAN might test that (I hope you have another ssytem).

BTW if you want to avoid Norwegian output for a statement to post it here, precede it by LANG=C. e.g.:

LANG=C ping -c1

Connection loss happens several times a day here on Powerline. It has probably nothing to do with dhcp or indeed Linux networking setup. All my LAN hosts use static IP, only the WLAN clients use dhcp. It’s the powerline adapter that loses connection and it often takes about a minute until it connects back to base.

Nice to know it’s not only me experiencing this, but now I have made some radical changes to my network setup. I hope I get some more stability. We’ll see how this play out.

Dag R