Network Printer - unable to recognize - Failed to get a list of devices: 'Forbidden'

Hello all,

Fresh install of Leap 15 KDE. Trying to use the add printer dialogue. On the step “Click to add new printer”, it comes back "Failed to get a list of devices: ‘Forbidden’ ". This step works on Ubuntu and Fedora. Apparently for some reason (after 2 back to back password checks), I am forbidden to have a list of printers on my network.

Is there any work around for this? I’m liking Leap 15 so far but this is kind of a deal-breaker.

Thanks for any advice.

Welcome to openSUSE Forums tehelfnub! Adding a printer requires the user to enter root’s credentials. So add username ‘root’ and root’s password when prompted.

Thank you for the reply. However, the installer didn’t set up a root account during installation, only the user with sudo.

Sure it does…

In Unix/Linux systems there is a special user for system administration. This is the user with the uid of 0 and the username root. It is also known as ‘superuser’. In daily life it is simply called: root.

You can check this for yourself…

grep root /etc/passwd

Does it use the password I supplied for the user?

It could possibly be the same as your user password. IIRC, during an install it is possible that the first user name’s password can be the same as the administrator password. (I haven’t done a clean install for a few years now.)

Nothing has changed in the LEAP 15 installation.
During the installation, there is a checkbox (which is enabled by default) that sets the password for your created ordinary User to be the same as root. This is convenient for most Users, but should not be set this way on systems which require better security (eg Production machines, not hobby or personal machines).


I have the same problem. I don’t know how to run setting up printers as superuser. First time when I tried to add new printer, the driver name for my printer Brother DCP-7070DW was not in the list. Then I downloaded driver setup program from Brother download page and run installation program by instructions on this page. After this my printer was listed between drivers. I selected it. But printer doesn’t print. Then I run uninstalling packages for this printer which were in download directory after running setup. Now I cannot remove this printer and adding printer is showing message - Failed to get list of devices: ‘Forbidden’

I want to add that I am running OpenSUSE Leap 15.4 in VirtualBox on Ubuntu. Driver setup program for Brother DCP-7070DW was running in Ubuntu successfully and my network printer is printing and scanning. Can you help me? I want to say that installing OpenSUSE was perfect.

Please note that this is a five years old thread and probably nobody will look at it anymore. Also much things have changed since and this thread is definitely not about openSUSE Leap 154. Third, it is always better for the exposure of your problem to the community to start a new thread.

So please start a new thread, and describe what you try to do as precise as possible (do not assume that others walk the same way as you do to configure a printer and you do e.g. not mention what program/tool you start to do the things you tried).

This thread will be closed.