Network Printer Issues

I have local and remote networks that have various printers.

I can add any printer (local or remote) to any PC, except for one PC that’s refusing to allow remote connection (it used to, but doesn’t now!).

The problem PC has two printers connected and work OK as a local printer, but both display same problem when attempting to connect from any remote PC via YaST.

Using ‘Connection Wizard> CUPS Server’ connection method requires IP address of remote PC and printer name. But if I correctly select either of the two printers I get an error message:

"PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=1.12 ms

— ping statistics —
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 1.122/1.122/1.122/0.000 ms
Password for root on Password for root on
/usr/bin/lp: Unauthorized

Queue Steve_HP_LaserJet on host does not accept print jobs (queue may not exist or queueing disabled?)"

Both printers are set to ‘Accept Print Jobs’ and ‘Share Printers> Allow remote access’ permits all networks to connect.

I believe the problem relates to the entry:

“Password for root on Password for root on
/usr/bin/lp: Unauthorized”

but anyone got any ideas why this PC is requiring the root password?

What OS is the problem PC running?
What OS are the other machines running?

Sorry, forgot to mention…

All running openSUSE 11.4

have you tried to disable firewall?
is all hardware on the same subnet?

instead of “Using ‘Connection Wizard> CUPS Server’ connection method requires IP address of remote PC and printer name.”

try delete whatever you did and use

Yast->Printer->Print Via network (accept printer announcements from CUPS server TICKED ONLY)-> Connection Wizzard → TCP PORT (APP SOCKET / JET DIRECT) install your printers with these wizzard trying few different drivers…

The key file controlling remote CUPS connectivity is /etc/cups/cupsd.conf, so I would compare that to the machines that allow access.

This CUPS_printer_sharing#Manual_setup guide may be useful to you.

Make sure that the printer is shared as well (/etc/cups.printers.conf) ie ‘Shared Yes’ for the printer(s) concerned.

Go to yast,

From Novell AppArmor Screen, select “AppAmor Control Panel”
Under “Configure Profile Modes“, select “Set profile modes [Configure]”
In the Profile Mode Configuration screen, set the Mode to complain for:
usr.sbin.nmbd and usr.sbin.smbd

Hope this would help.

Since your target printer is an HP Laserjet (for that matter I recommend in all Printer config scenarios, not just HP), I recommend installing and utilizing the HP Device Manager aka HP Toolbox.

Once installed, it appears to run as an enhancement and extension of CUPPs, providing you more troubleshooting and config options when setting up and continued printer management later.

If not already installed

zypper install hplip

Once installed, you can invoke it several ways,
From the Start Menu (KDE)
Start > System > Monitor > hp toolbox
Opening CUPPs first, then selecting the HP Toolbox tab

A few things the toolbox will do for you

  • Automatically discover all discoverable printers on your local network
  • Automatically ping and discover connectivity for all discoverable printers on your network
  • Assist in configuring HP printers
  • Return decent troubleshooting error messages (at least I’ve found useful)

Gentlemen, apologies for not responding sooner.

I have HP Toolbox already installed, however, what I had not studied in detail was the /etc/cups.printers.conf file. Comparing it with all other PC’s I noted that the ‘OpPolicy’ for my problem printer was set to ‘authenticated’ (not sure why). Resetting to default - in common with all other printers - I can now print to my printer from anywhere on the local network or any VPN!

Thanks for everyones assistance.