Network OK, but no Internet when WPA enabled

Hello !

I just bought a modem-routeur (linksys wag54gs).

Under windows, network is ok (address works) and internet works too, with WPA2 enabled, or with WEP or without any protection.

Under opensuse 11.2, on the other hand, Network is ok (I can reach, and internet connection is fine as long as I don’t use any security (WEP, WPA1, WPA2).

When I use WEP, WPA or WPA2, internet is no longuer reachable.

Before, I had a modem and a router, and any security settings worked fine…

Could you please help me to figure it out ?

Thank you so much.

ps: sorry for my english…

How did you configure your security settings for the wireless? Are you using KDE’s network manager?
Also, do you use kwallet to securely keep the password?

Hello !

Thanks for your quick answer.

I configure my wireless through the webinterface (on with firefox).

I’m using Kde network manager to access the wireless.

I’m not sure about kwallet…I enter my user paswword at startup then no more.

The connection from the modem-router to the compuer is OK (since I can access the webinterface).

It only works if I don’t use WPA or WEP encryption.

My modem-routeur settings seem ok, since I can access the internet from the same computer, same hardware when using windows.

Thank you for your help.


Done some searching:

Is the router’s firmware up to date?

You might as well give WICD a chance, worked for me when the networkmanager was failing on me., search for wicd.

Then change the network settings in Yast from networkmanager to traditional method. Reboot, login on the desktop, start wicd-client from the menu, try to connect to the modem-router.

Good luck


Yes, my firmware is up-to-date. It’s the first thing I did.

I will try wicd as soon as I get home.

Thank you for the clue. I’ll get back to you in order to give feedback.



Make sure that when configuring the connection details in knetworkmanager, you enter the “WPA/WPA 2 Personal” password and the “Connect automatically” box checked. In my case, after doing this and saving it, I had to log out and log in (the knetworkmanager was not automatically re-reading it).
I am not sure this is the case with the latest knetworkmanager too.

I totally forgot that…:wink: Assumed the OP would know.

Hello Yan

My steps do debug this would be:

  1. Start with the configuration that works. Note the output of the following commands (from the command line):
/sbin/ifconfig -a
/sbin/route -n
cat /etc/resolv.conf | sed -e "/^#/d"
  1. Then re-configure with security enabled. Do the above steps again and look for the significant differences.

Hello !

Thank everyone for the help.

The problem is fixed: I updated opensuse, reboot the modem-routeur, my computer and everything was fine…

I don’t get it…

Anyway, what matters is that it works !

Thanks again, and sorry for the trouble !