Network not working.

No, it’s a function the windows driver has and the linux driver does not have (yet).

If you don’t use WOL, it makes sense to deactivate that function on shutdown, IIRC keeping the card in a WOL-responsive state will need (although only a little) energy although the machine is “powered off”.

It’s just another example where linux still has some problems (all ACPI related stuff is nasty to implement, ask $KERNEL_HACKER_OF_YOUR_CHOICE for more information).

I use DHCP, I do not have any fixed IP… It keeps changing. And yes. I am not sure if I have a router or not. I connect to the net using a cable which is connected to a dish through this device: PowerDsine PD-3001/AC — VoIP Supply.

This is what I said in my “SEVENTH” post.

And now?

Do you expect me to read the whole specification instead of you stating “this is a DSL modem” or “this is a router”?

Instead you should state what type of connection you used for all your other machines (presuming you have any, which is indicated by your statement “never had problems before”).

If these need a DSL connection configured, then your laptop will also, if they don’t then why should your laptop need one?

P.S.

At first glance this device has nothing to do with the type of network connection actually taking care of connecting to WAN so it is completely irrelevant. Still, doing the exact same thing for your laptop like for the other machines would be the logical thing to do, now wouldn’t it?

Akoellh,

Do you want me to keep writing my specifications after every post or in each post?
I had a problem which I can not resolve on my own, that is why I put it in the forum… If someone can think he can help me after asking questions, they can ask me. But I am not so intuitive as to think what others want from me. Is it so hard to believe me when I say I “DO NOT KNOW” anything about networking! wlan0, eth0,network cards etc, etc didn’t mean anything to me before yesterday when I started having this problem. I bought this system last week, before that I had a Compaq Pressario V6218TU and I just had to plug in the same cable from same modem from same provider and it “JUST WORKED”. Now it is NOT working on this machine and I do not know why! Yes, doing what I did for my other laptop will be the most logical thing and that is what I had already done in the first place…

I am googling since two days for any solutions and am trying in hope that any one of them will do the trick. In the mean time I am hoping that someone will tell me what is wrong and what things should I do to make them right…

Yes, or at least state them clearly once, which you did not.

And Yes, for decent help it would be also necessary to post every change you made and to show the “is state” (in this case the output of the script) every time you changed something which very likely means in every reply.

And did you have to configure a DSL connection for that?

If not (sounds like it) why on earth did you even try after asking for help and with the people trying to help you not even mentioning that with a single word?

If you had to, then you “did not do the same as before” as the DSL connection is missing in the first output of the script.

And what also annoys me, you don’t seem to really read my suggestions carefully, I told you to have a look at the site considering the dual boot problem (link from Gentoo Wiki) and then maybe install the other driver.

And you did first install the new driver package and then wrote about that you now will have a look at “the remedy”.

Now there are more potential variables to consider, so you are making it more complicated by not doing things as you are suggested to do.

Do you really think this makes it more likely your problem can be solved?

I certainly don’t.

Akoellh

When I post something I do expect help, but I do not keep just watching the forum. And if there are no replies for some time I do try other things that are on the net.

And I do keep the post “updated” as much as I can. I am even kept posting when there was no reply just so that if I am doing some mistakes people who may face problem in future will know “what not to do”. In between this I have to continuously switch between my windows and suse partition so that I can look for solutions through windows and then I have to log in to suse partition to apply those things. That does take time.

And if I made you think that I have not been listening to your suggestions, I am really sorry for that. But I have been googling a lot on your post about dual booting with windows. The “Shutdown wake-on-lan” was already enabled which is a work around as per Gentoo Wiki Archives - RTL8168.

I will just give you a status update and before that let me tell you about my system as far as I know:
I connect to the net using a DSL cable which is connected through a modem, I am not using any router.

  • I have just done a clean install of suse 11.1, kde 4.1(64 bit) on my system
  • Disabled wlan0
  • Right now I am not using traditional method with ifup but have set it to automatic mode

I had gone through your thread Choosing the correct kmp-package for your installation - openSUSE Forums and here is the output of the commands:


linux-x3zq:/home/vivek # uname -r
2.6.27.7-9-default
linux-x3zq:/home/vivek # cat /etc/SuSE-release
openSUSE 11.1 (x86_64)
VERSION = 11.1
linux-x3zq:/home/vivek # lspci -nn | grep -i net
08:00.0 Network controller [0280]: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)

So I think the rpm I had chosen was correct one? (refer: Network not working. - Page 2 - openSUSE Forums)

I have just found this thread [SOLVED] Gutsy install selects wrong driver for Realtek RTL8111C [Archive] - Ubuntu Forums](http://ubuntuforums.org/archive/index.php/t-671614.html) which is related to the same problem. I am thinking of trying this out…

Please tell me if I am missing anything or what more information can I provide to you.

Can you try plugging in your laptop straight into the dish? As in remove the above and plug the RJ-45 from the PD-3001/AC input into your laptop? I am just wondering is it causing problems. I don’t know anything about it but when it comes to network problems I always like to elliminate as many devices between me and the internet.

Also, what do you use this device for? It’s used to provide power to network devices so unless you need this function I don’t see any reason for having it. (Maybe as an extention lead ;)) It is also likely that the dish will have a router attached and if this is the case a DSL connection will not be needed. You should only have to set up a network connection, not a DSL connection.

No it did not work if I connect directly to the dish. But if it would have worked it would have saved me a lot of electricity bill :slight_smile:

vendetta18 wrote:

> I use DHCP, I do not have any fixed IP… It keeps changing. And yes. I
> am not sure if I have a router or not.

This is the first problem I can see on your setup.

Your ethernet card is not getting any ip/netmask/gateway (and probably dns
servers) from any device in your network.

Can you please boot into windows and look for the network card setup here?

If your windows system is using dhcp, then your suse has to use dhcp. If
your windows system is using a fixed ip address, then most surely your suse
has to use that, too.

In any case (dhcp or fixed ip), both systems (windows and suse) have to have
the ethernet card properly configured and setup, I mean, the ethernet card
has to be assigned an ip address, network mask and gateway.

> I connect to the net using a
> cable which is connected to a dish through this device: ‘PowerDsine
> PD-3001/AC — VoIP Supply’ (http://www.voipsupply.com/pd-3001-ac).
> Right I am connecting to the net through Windows OS which I am dual
> booting with SUSE. So it might take some time till I get back after
> doing what you have told me.

That seems a device for powering ethernet devices, but not the dsl modem or
the router itself. Can you please post further information (brand and
model) about your DSL device? Your DSL device is the one connected to the
phone line.

Greetings,


Camaleón

Which you forgot to mention until now, I suppose, or did you just try that out now (then I must ask myself, why did you tell me you don’t ignore my sugestions).

Which is in contradiction to this statement here:

And maybe also to this here:

Beacuse if this is really a connection to a DSL modem, this will not “just work” without setting up DSL via YaST, entering some credits (user and some passwd given to you by your ISP), so it is still not clear what we are dealing with here.

Also (that’s why I wrote “maybe”) DHCP on the ethernet device mostly will not work for “real” DSL connections via DSL modem, in most cases the Interface needs a static “dummy IP” which then will be changed.

Also very confusing:

I connect to the net using a cable which is connected to a dish through this device: PowerDsine PD-3001/AC — VoIP Supply.

I connect to the net using a DSL cable which is connected through a modem,

How shall one answer this?

Anyhow, now you should at least be able to remember what you had to do with your last machine, from the information given above I don’t even have a clue what we are dealing with, because it’s just not consistent for me.

(Who knows, maybe this is even something similar to a “cable modem”, these need only using DHCP to connect, but again, this is just guessing.)

Automatic mode? You mean NetworkManager?

(With the output of the script, I would not have to ask.)

AFAIK NeworkManager can not handle DSL automatically, it will point you to the DSL setup via YaST, so again, unsufficient information, the output of the script (which I explicitely mentioned in my last reply) is also missing.

As in this output there is no information what so ever which rpm package you actually installed (or any output which module is being used, which btw. would be given by the script), I have no way in answering this question (again, due to insufficient information).

Anything except the “powering off for a while” which really sounds worth a shot (there are other cards with exactly the same behavior) the rest of the thread is completely irrelevant or Ubuntu-specific (blacklisting on openSUSE WILL work if needed, although it won’t be needed, which I can say from my own experience with this card and both modules).

No, I am giving up on this, I told you several times and you seem to miss it again and again.

Good luck and have a nice day.

Thannks Akoellh

Yes, I made it… finally :slight_smile: Network is up and running on my suse machine.
The problem was with the wrong network card driver(At least with me). I have RTL8111/8168B PCI Express Gigabit Ethernet controller network card where as suse was installing r8169 as default driver(It should have been r8168).

Here are the steps on how to fix this.:
First I downloaded the driver from Realtek (As per your kernel).
Then:


#stop the network
rcnetwork stop

#remove r8169 driver
rmmod r8169

Now I moved to my $HOME directory where I had just downloaded the driver r8168 from Realtek site. Unzip the file.


$ cd 
$ tar xjf r8168-8.014.00.tar.bz2
$ cd 8168-8.014.00

After that I compiled the code. (This may fail if kernel headers
and other standard features of a build environment are not installed)


$ make clean
$ make modules
$ make install

Add the old driver to blacklist and rename the old driver module to make sure modprobe knows not to use r8169, and that depmod doesn’t find the r8169 module:…


$ echo "blacklist r8169n" >> /etc/modprobe.d/blacklist
$ mv /lib/modules/`uname -r`/kernel/drivers/net/r8169.ko /lib/modules/`uname -r`/kernel/drivers/net/r8169.ko.old

Make suse aware of the changes:


$ depmod
$ insmod src/r8168.ko
$ rcnetwork start
$ ifconfig -a

Notice the output of “ifconfig -a” and saw how NIC was called (probably eth0 or eth1). Mine was eth0
Then I edited the networks file to add my NIC configuration. Added the below lines of code to my /etc/networks


# The Ethernet card
auto eth0
iface eth0 inet dhcp

Then restarted the card:


ifdown eth0
ifup eth0

Then I restarted my system and networkmanager started working. Right now I am posting from the suse OS :slight_smile:

Very good. Can you now try and do the same when you remove the PD-3001/AC from this setup? If it works, which I think it will, you can save yourself some money in the electricity bill. :wink:

Yup sure will try that. Right now I am in the middle of updating my system. Will try after that and report back…

Any luck with this?

Nope …

Anyhow, I have bought a USB modem from my service provider, so when I get that working ( How to configure USB modem in opensuse 11.1 - openSUSE Forums )I will surely save on my electricity bills :slight_smile: