network not working in 11.2

I’ve just upgraded from 11.1 to 11.2 on one of my computers, and I am encountering the following problem:

Networking does not work. In the Network Settings section of Yast I have two lines, both with the text

82562EZ 10/100 Ethernet Controller

on one line the text continues with “Not configured”, and on the other with “DHCP”. I tried to delete the “Not configured” line, but it will not let itself be deleted (even though there is a menu option “delete”). I might add that on 11.1 everything worked fine. Does anybody know what I should do? Answer will be appreciated.

Give the output from

/sbin/lspci -nnk

OK, the OP, a person whose n/w i/f worked fine in 11.1 is asked:

Give the output from

/sbin/lspci -nnk

which would imply that certain n/w i/f devices which were OK in 11.1 may no longer be right in 11.2. i.e. 11.2 has dropped support for some n/w devices. or, maybe, the n/w kernel drivers got reshuffled. Should forcedeth be the kernel driver used for that i/f?

Sorry to interrupt, I’m just trying to get some self-diagnosis here for my own networking problems.

Here is the requested output (I hope there aren’t too many mistakes since I had to copy it by hand):

00:00.0 Host bridge [0600]: Intel Corp. 82865G/PE/P DRAM Contr./Host-Hub Interfac. [8086:2570] (rev 02)
Subsystem:Intel Corp [82865G/PE/P DRAM Contr./Host-Hub Interface [8086:2570]
00:01.0 PCI Bridge [0604]: Intel Corp. 82865G/PE/P PCI to AGP Contr. [8086:2571] (rev 02)
00:06.0 System Peripheral [0880]: Intel Corp. 82865G/PE/P Processor to I/O Memory Interface [8086:2576] (rev 02)
00:1d.0 USB Contr. [0C03]: Intel Corp. 82801 EB/ER (ICH5/ICH5R) USB UHCI Contr. #1 [8086:24d2] (rev 02)
00:1d.1 … #2
00:1d.2 … #3
00:1d.3 … #4
00:1d.7 USB Contr. [0c03]: Intel Corp. 82801 EB/ER (ICH5/ICH5R) USB2 EHCI Contr. [086:24dd] (rev 02)
00:1e.0 PCI Bridge [0604]: Intel Corp. 82801 PCI Bridge [8086:24d0] (rev 02)
00:1f.0 ISA Bridge [0601]: Intel Corp. 82801 (ICH5/ICH5R) LPC Interface Bridge [8086:24d0] (frev 02)
00:1f.1 IDE Interface [0101]: Intel Corp. 82801 EB/ER (ICH5/ICH5R) ICE Controller [8086:24db] (rev 02)
Subsystem IBM device [1014:0285]
Kernel drive in use ata_piix
00:1f.3 SMBus [0c05]: Intel Corp 82801 EB/ER (ICH5/ICH5R) SMBus Contr. [8086:24d3] (rev 02)
Subsystem: IBM Device [1014:0285]
00:1f.5 Multimedia audio controller [040]: Intel Corp. 82801 EB/ER (ICH5/ICH5R) AC’97 Sudio Contr. [8086:24d5] (rev 02)
Subsystem IBM Device [1014:0285]
01:00.0 VGA Compatible Controller [0300]: Matrox Graphics Inc. Millenium P650/P750 [1026:2537] (rev 02)
Subsystem: Matrox Graphics Inc Millenium P650 64MB [1026:1830]
03:08.0 Ethernet Controller [0200]: Intel Corp.82562EZ 10/100 Ethernet Controller [8086:1050] (rev 02)
Subsystem: IBM Device [1014:0285]


i think, that e100 module should be loaded…
you can check it

lsmod | grep e100

if not present try load it manually

modprobe e100

then you can chceck if it works in dmesg or ifconfig -a

I tried

modprobe e100

and got the answer

module not found



which kernel are you using?

uname -a

I have the exact same problem. I upgraded from 11.1 to 11.2 and now do not have any network (well and some other problems, but I obviously have to start here).
In Yast->Network Settings I get two lines with the same (on-board) network card:
RTL-8139/8139C/8139C+ - Not configured
RTL-8139/8139C/8139C+ - 10.10.etc

I am not allowed to delete the first entry. I can delete the second. The first entry has a BusID (the correct one), the second hasn’t (No HWinfo)

ifup eth0 (that’s the second card) gives:
Interface not available

/sbin/lspci -nnk gives:
Ethernet controller [0200]:Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev10)
Subsystem: DFI Inc Device [15bd:1003]

Seems no 8139 module is loaded in the first place as “lsmod | grep 8139” returns nothing

/sbin/modprobe 8139too (or 8139cp) gives:
WARNING: All config files need .conf: /etc/modprobe.d/module-renames, it will be ignored in a future release.
FATAL: Module 8139too not found.

uname -a gives:
Linux hermes #1 SMP 2009-10-15 14:56:58 +200 i686 i686 i386 GNU/Linux

Sorry for any errors, had to type everything by hand on another PC.

One of the previous responses asked “which kernel are you using”. That prompted me to take a look at the boot menu. There are several options (default, “pae”, failsafe …). It seems that for some reason I was booting the “pae” kernel. When I changed to the default kernel everything that didn’t work before started working (network, USB drive). So that takes care of that. The remaining question is What is the pae kernel good for? Can I get simply rid of it?

Ooops, and I was booting the 11.1 kernel… (probably the old GRUB preset…)

nice one…

Thanks bostjanv!