network not starting on boot

beware in my enthusiasm to provide loads of info this post might get boring
and highly convoluted and may even disappear up it`s own /dev/null :slight_smile:

Ok I give up, I did sort of post this in the beta group as part of another
thread so here goes in the right group:

Why has my network interface stopped coming up on boot?

This is on an OpenSuSE 11.1 AMD 64 bit all updates as of this morning, the
DM/WM does not matter as this is before any desktop is initiated and most
time I do not login to an Xserver.I use runlevel 3.

The hardware is fine and works in other O/S`s as it should, it worked fine
since first install of 11.1 then maybe a month or two ago the lan just
stopped coming up on boot:

This is an onboard gigabit card so no change in hardware/driver.

<<–snip–>>

doneSetting up (localfs) network interfaces:
lo
lo IP address: 127.0.0.1/8
IP address: 127.0.0.2/8
lo
done eth0 device: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 01)
eth0 is down
eth0
failed eth0 interface could not be set up until now
failedSetting up service (localfs) network . . . . . . . . .
…failed

<<–pins–>>

Now I use the traditional method of ifup, onboot/auto, the interface is
configured with a static address and the switch and router are configured to
set this machine with that address by the MAC of the card this setup has
worked for years like this as I have a static WAN address and I login
remotely.

I do not have networkmanager installed the only thing that contains anything
is:

kdebase4-workspace

and if I try and get rid of that it throws a wobbly with loads of deps.so
there are no netman stuff here.

I have tried and put an enrty in the boot.local file for rcnetwork restart
and that fails also with the same message:

<<–snip–>>

System Boot Control: Running /etc/init.d/boot.local
Shutting down (localfs) network interfaces:
eth0 device: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 01)
eth0
doneShutting down service (localfs) network . . . . . . . . .done
Setting up (localfs) network interfaces:
lo
lo IP address: 127.0.0.1/8
IP address: 127.0.0.2/8
lo
doneWaiting for mandatory devices: eth0 NSC
0
eth0 device: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 01)
eth0 is down
eth0
failed eth0 interface could not be set up until now
failedSetting up service (localfs) network . . . . . . . . .
…failed

<<–pins–>>

I have tried with/without a wait delay just in case the card or router is a
bit lazy to set the address ( don`t forget the address is static and
hardwired in router as DMZ to the card MAC )

So for kicks I tried a seperate and different chipset pci lan car and
another router same prob, I have the card module loaded with the kernel on
boot so it is loaded before the network is brought up.

I can see some activity on the line as the system boots but it does not
setup.

I eneabled boot rom just in case the card was being set in an unstable state
by any of the other O/S`s ( especially Windows ) made no difference so
disabled again.

Once the machine is up whether console login or WM and I issue a rcnetwork
restart the lan comes up fine and is stable for as long as the machine is up
sometimes weeks.

The only prob is if I login remotely and want to reboot then I am stuffed!

Sometimes I am away for days if not weeks and if like last week I wanted to
remotely reboot to another O/S and then back to SuSE then it is a no go.

I have removed the card from the network config, removed all the config
files, rebooted the machine with it disabled in the bios then rebooted with
it turned on and reconfigured but still it will not boot and I cannot find
any error message to say why.

The only thing that could be remotely linked could be the install of vbox
and the vboxnet virtual lan as this is the only thing I can think of that
has anything network like that has changed on this machine at about the same
time, however I cannot be sure exactly when the prob occurred due to the
machine not being switched off for months prior.

I have googled till I need goggles with no definite answer, maybe I did not
use the right criteria, i ahve tried nearly every combination I can think of
with “network, virtualbox, no start suse, linux, on boot ifplug” etc…
etc…

So the £64,000 question:

HHEEEEELLPPPP!!!11!!one!!eleven!!1

Please :slight_smile:


Mark

Nullus in verba
Nil illegitimi carborundum

Check the file /etc/sysconfig/network/ifcfg-eth0

cat /etc/sysconfig/network/ifcfg-eth0

What does it say for SATRTMODE=?

baskitcaise wrote:

> The hardware is fine and works in other O/S`s as it should, it worked fine
> since first install of 11.1 then maybe a month or two ago the lan just
> stopped coming up on boot:
>
> This is an onboard gigabit card so no change in hardware/driver.
>
> <<–snip–>>
>
> doneSetting up (localfs) network interfaces:
> lo
> lo IP address: 127.0.0.1/8
> IP address: 127.0.0.2/8
> lo
> done eth0 device: Realtek Semiconductor Co., Ltd. RTL8111/8168B
> PCI Express Gigabit Ethernet controller (rev 01)

Are you dual-booting (win-suse)?

If yes, take a look into this thread:

Problems with RTL8111/8168B
http://ubuntuforums.org/showthread.php?t=437982

And this one…

No internet using r8169 module (RTL8111/8168B) using kernel > 2.6.19
http://bugs.gentoo.org/237089

THT

Greetings,


Camaleón

syampillai adjusted his/her AFDB on Thursday 18 Jun 2009 15:46 to write:

>
> Check the file /etc/sysconfig/network/ifcfg-eth0
>
> Code:
> --------------------
> cat /etc/sysconfig/network/ifcfg-eth0
> --------------------
>
> What does it say for SATRTMODE=?
>
>

That gives:

BOOTPROTO=‘static’
BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=‘192.168.1.5/24’
MTU=’’
NAME=‘RTL8111/8168B PCI Express Gigabit Ethernet controller’
NETWORK=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
USERCONTROL=‘no’

HTH

Mark

Nullus in verba
Nil illegitimi carborundum

Camaleón adjusted his/her AFDB on Thursday 18 Jun 2009 15:46 to write:

> Are you dual-booting (win-suse)?

Very rarely on this machine, I can see where you are leading but no it
happens even if I just reboot from SuSE to the same SuSE, however I get the
same result if I do boot to either XP, Vista, earlier version SuSE and
ubuntu, so windows is not the culprit ( in this case anyway )

Shame though as that would be easy to fix :slight_smile:

>
> If yes, take a look into this thread:
>
> Problems with RTL8111/8168B
> http://ubuntuforums.org/showthread.php?t=437982
>

> And this one…
>

> No internet using r8169 module (RTL8111/8168B) using kernel > 2.6.19
> http://bugs.gentoo.org/237089

Yep had seen that thread myself and has not helped at all

> Greetings,
>

Will see if I can find a different combination of things and maybe just a
bigger hammer.

Cheers.


Mark

Nullus in verba
Nil illegitimi carborundum

baskitcaise wrote:

> Shame though as that would be easy to fix :slight_smile:

Yeah. And quite easy to try :wink:

BTW; I have that card also (rtl8169 chipset based) but have no option under
windows device manager regarding “wake-up-on-something” :-?

> Will see if I can find a different combination of things and maybe just a
> bigger hammer.

X-)

Or just try “dmesg” and grep the card to check if at least link is up.

You can dig a bit more with: su -c ‘ethtool eth0’

Greetings,


Camaleón