Network nor working

I’ve been using Opensuse for some years now, but without diving into the inner workings on Linux.

I installed Opensuse 11.3 64bit yesterday and the network(not wireless) cards didn’t work properly. When updating you got an error it couldn’t get contact with the server, but if you pressed try again often enough, in the end it usally downloaded, even if very slow.

I had the same problem when installing other Opensuse from 11 onwards. Then I either used an Intel card(that I can’t use any more since the motherboard got defective, and the replacment I bought didn’t have 8 or 16 pci-e contacts, but only pci-e 1x slots) or managed to install the Realtek driver after fiddeling so much that I can’t remember what I did.

I have 2 networkcards installed. One onboard relatek r8110/r8168b card and 1 Dlink 528T card. Same problem with both of the cards regarding the built in r8169 driver.

I unloaded the driver, and then added it to a blocklist, that I fouund on this forum. Installed another driver, downloaded from Relatek site. That was a wrong driver, and I unloaded and blocked that as well.

REaltek 8168B:

Downloaded the r1000:v1.7 driver, but when writing “make install” under root I get the following error:

install cannot stat ‘r1000.ko’ no such file or directorie

I then tried a old driver I had witrh file.
Running this I got:

check old driver and unload it.

So when I write ‘modprobe -l’ I get a r8101.ko driver that is loaded.
However if I write ‘modprobe -r r8101.ko’ it tells me module 8101.ko can’t be found.

So I gave up on r8168b, and tried 528T instead.

Downloaded a driver from dlink.

Unpack it, and enter the kernel 2.4 (there is no 2.6 option).

I changed the Makefile(as the readme tells me to do) to:

NEW_INCLUDE_PART=-I /usr/src/linux-2.6.34-12/include/

When I write ‘make’ I get the following error:

from dge28.c 52:
/usr/src/linux-2.6.34-12/include/linux/prefetch.h:14:27 fatal error asm/processor.h: no such file or directory
compilation terminated

So I gave up on that as well.

Som what I need help for is to get at least 1 of the cards working, and working whitout taking a brake so often. I use it to stream video to a mediacenter I got, so a workable network card is important to me.

If you need more data that is written in the consoll please tell me(if possible) to store in on say a txt file that I can move over to my windows computer with usb-key, as I now have to manually write what I have wrote above.

Now someone may come in with a suggestion, but I was unable to get a built-in network connection to work based on the Linux driver for Realtek 8168B. It looked like it could not determine the connection speed for some reason in my case. I ended up switching to a PCIe gigabit network card made by D-Link but the model was DGE-560T and it is working very well. Anytime I am using a desktop, I have found the best path is to purchase a network card known to work with openSUSE if the built-in one does not work right for some reason. This approach does not work with a Laptop however. Are you using the default ifup mode (for wired) or the NetworkManager?

Thank You,

relatek r8110/r8168b card

Very strange: the card you report gives just one single hit in google: your own post.

Before we plunge into the details of compiling drivers can you please provide some hard reliable facts? What is the result of

lspci -k

executed as user root?

My first reply seems to have been eaten, so I will have to try again.

Vodoo: Sorry my mistake. It should be RTL8111/8168B. I assmue that was the point of the command lspci -k command.

I basicly confirmed that that I entered a wrong number.

Jdmcdaniel3: I’m using the ifup mode. No idea what the difference is however.

Tried to search for DGE-560T, but apparantly it’s not available here in Europe, or at least not where I live.

The closes I got was 560 SX, but that cost about as much as a very cheap portable.

I have had success with Intel cards in the past, so if this doesn’t work out. I may have to cave in and buy a new one.

Is there a reason why you are using 2 NICs?
The onboard NIC should be autodetected by openSUSE, since it is quite a common one.
You can’t have both nics connected at once with thesame network settings without causing a conflict - which card do I use? To get them both working at once on the same network, you need to enable bridging, which I doubt you need, unless you are running a server on a large network.
If they are connected to different networks, you have to set the routing.
Try again with only one of the cards and set the other in Yast>network as disabled.

whych @jalla02 the driver for my built-in network card was RTL8111/8168B as I remember. You might want to activate this adapter and try the following command to see if it makes any difference. For me, it could not connect with my gigabit switch right. You can edit the setup file for this port as shown below. The eth0 needs to match the actual adapter number (it could be eth1 since you have two network adapters). Using the menu Run Command:

kdesu kwrite /etc/sysconfig/network/ifcfg-eth0 (enter root password)

Find the line that says ETHTOOL_OPTS=""

and change it to:

ETHTOOL_OPTS="speed 100 duplex full autoneg off"

Save and close the file. You need to restart openSUSE. This only works using ifup I think and will force the built-in port to use only 100 mb. It is worth a try. It worked for me, but I wanted to use the highest speed.

Thank You,

The reason is that Realtek NICs have been troublesome before, so by installing the 528T, as I’ve had used in another machine before. I was hoping to get at least one of them working.

They are not set up with the same network setting. I know this would cause conflict and making it not work properly.

With the r8169 driver borh are detected, but as written earlier won’t work properly. But I will try again. Just have to find where to blockfile is again, so I can remove it.

Jdmcdaniel3: I also use the computer, sometimes, to recode video files. I therfore up and download a lot of files. Only 100 mb therfore doesn’t appeal too much to me, but has to be a last resort if I can’t get it working in another way.

Vodoo: Sorry my mistake. It should be RTL8111/8168B. I assmue that was the point of the command lspci -k command.

Exactly. Now look what I have in my ASUS Eee PC:

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
        Kernel driver in use: r8169
        Kernel modules: r8169

This works very well, at least on openSUSE 11.1. Re-install the right module. Then try again using a different Ethernet cable which is known to work.

When you say they don’t have the same network setting do you mean they are on different networks like and
If this is the case they will work. If they are on the same net like, you need to do some sort of bridging.

Try and get one working at a time.
Go to yast2>network devices and check:

  1. Check that you have it set to ‘traditional with ifup’ and ipv6 disabled. Exit and restart the network setup.
    2 Now go to the devices tab and check that the realtek is enabled and set as either static ip address or dhcp and the other is unplugged or has no ip address.
  2. Check the general tab and check the network is activated at boot.

Exit and see if you get a network (If you had the realtek plugged in when you installed and the other unplugged, you should have had a network connection.)

You can then try configuring the other one.

Once the network is running

Here is mine, when I write lspci -k:

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

Subsystem: ASUSTeK Computer Inc. Device 8367

Kernel driver in use: r8169

05:00.0 Ethernet controller: D-Link System Inc DGE-528T Gigabit Ethernet Adapter (rev 10)

Subsystem: D-Link System Inc DGE-528T Gigabit Ethernet Adapter

Kernel driver in use: r8169

I never found out how to reinstall the module, so I ended up reinstalling the whole OS.
I’ve not configured 528T, so that should be out of the picture.

Still the same problem, but after after I set the speed to a 100 instead of 1000 as Jdmcdaniel3 suggested, it works better than it did before, if not perfect.

I would rather have one of them fully working, at full speed.

PS. Why do I have to go to previous thread, then back agin to post. If I don’t. I get an error saying the token has expired.

They was in the same network in the range 192.168.10.* . One had a static(onboard). The other DHCP.
But as I wrote to Vodoo I reinstalled 11.3, and with the speed reduction it works better, if not perfect.

I wil try to remove that line, and do as you suggest, and see if it will work.

I’ve now tried it, and after having problems with trying to get smppd downloaded via a connection that doesn’t work, it now works fairly well.

It’s still a bit slow compared to my win7 machines, but it I can stream video without stuttering, and that is the important part.

I’ll keep it like this, and if it doesn’t work longterm Iw ill just have to cave in a by a non Realtek ethenet card.

Thank you, all who have responded, for tew help you have given me.

jalla02, at least you are up and running. I would look around for a good buy on a new gigabit network card. Make sure your PC can handle the card type you purchase. I always make a point to test out the next revision of openSUSE as well as that card might start working next year with openSUSE 11.4 or what ever version it will be called.

Thank You,

This is what I told you in the beginning. You CANNOT have 2 cards running at once on the same network. unless you set up a bridge
You can have one running on 192.168.1.x and the other on 192.168.2.x, but you CANNOT have them both on 192.168.1.x - because they are on the same network.

If you don know how to configure the tables, rather use yast2>network devices>network settings to set up the cards.
Now disable the realtek connection and only have the d-link and see whether it improves.

Your problem with expired tokens is perhaps you forgot to login.

I have disablet the d-link card, and will keep, it that way. Whenever I try to fix something that don’t need fixing, I usally break it so it doesn’t work at all.

But I will remember not to have two networkcards connected to the same network. I din’t acctually know that.

No, I was logged inn. I only needed to hit the “Previous Thread” button, and then “Next Thread” to get back again. Then I could post.

Hey Guys,

I’ve been using Linux Mint and having the same issue with this very same NIC in my laptop. I can get it to work and after a few days it will break again. I then re-install the 8168 Driver from Realtek and it works again. Sometimes it will break to the point of reinstalling the driver wont even fix the issue. At that point i have to unplug the power cord, take out the battery and hold the power button down for about 15 seconds. This drains any remaining charge and then when i power up again everything is working fine. It seems like the solution according to this thread is to set the NIC to run at 100Mbps as opposed to 1000Mbps. I’m wondering a few things:

  1. Is this a realtek issue or a linux issue?
  2. Can this cause permanent damage to the NIC?

P.S. - the reason i am in this forums was to search and see if this issue exists with Open suse before trying it out. Does anyone know if there is a permanent fix coming for this? One that would let me use my NIC at full Gigabit speed? Thanks everyone.

So anyone that might be searching on the subject of the Realtek RTL8111D 10/100/1000 Ethernet LAN chip I have determined you merely need to add the Ethtool Options of “autoneg off”, without the quotes here. This is in YaST / Network Devices / Network Settings / Hardware Tab and Edit your network interface and the option windows is on the page where your kernel module is shown. I just felt I needed to amend this thread with this new information as I got the interface to finally work with this simple setting.

The manual way to do this is as follows:

kdesu kwrite /etc/sysconfig/network/ifcfg-eth0 (enter root password)

Find the line that says ETHTOOL_OPTS=""

and change it to:

ETHTOOL_OPTS="autoneg off"

Thank You,