Network managers, do they ever work properly?

I got a reocurring problem of the networkmanager never working properly which happens on openSUSE 10.3, 11.0 and 11.1.
Happens on my laptop with a intel 4695AGN wifi card, both with ndiswrapper windows drivers and the drivers openSUSE installs.
Same problem on an older laptop with a broadcom 43xx chip.

The problem with the KDE3 and Gnome network managers is that they only see the network sometimes… and I’m clueless as to why.
100% successrate with any of the following:

  1. ifup*]iwlist scan*]Windows Vista*]wicd, but
    ]Is giving me a bunch of errors on startup]A pain to install as the one click install from webpin is outdated, and that version has a bug preventing it from working properly*]Compiling it myself… doesn’t work, but if I do it after the webpin one click install I do end up with a functional application

Other problem I have it that I’ve never been successful to connect to the college network, which makes use of PEAP. Not to mention wicd shows me EVERY single accesspoint, which isn’t too nice if you’re in range of like 15.
So at college I’m always forced to work under Vista as again the network works fine there.
They also mention on their site that they support TTLS-PAP (EAP-TTLS) for Linux systems… but that never worked for me either on any of the networkmanagers, and there seems to be no option for it in YaST network settings.

So is there a decent network manager out there that
A) Handles PEAP properly
B) ALWAYS works, instead of just sometimes

Hmm, never had any of your problems & i use intel,broadcom,rtl & zd based devices ( when the mood appears or i get bored & need to fiddle :slight_smile: ) You tried wifi-radar ?

Andy

Not yet, is it still current though? Last update seems to be 142 days ago, which is either very encouring cause it’s so good it hardly needs updates… or it’s not being maintained :stuck_out_tongue:
The website is down and the RPM is for 11.0, so my guess would be that it’s no longer maintained.

11.0 RPM just seems to crash YaST software management without any error.

If you can grab the source you can recompile it for your system,or just do an rpm --rebuild for your arch & away you go. I used to compile my own from tar.gz, I think it’s still maintained at sourceforge

Andy

Hi
If your going to try the 11 rpm’s it is better to build from the src as
there have been name changes to some of the packages…


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 1 day 13:22, 1 user, load average: 0.50, 0.34, 0.23
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Need to do some googling on it then I guess as the site is down.
And here a nice demonstration of why I don’t understand that other people don’t seem to have this problem.
http://thumbnails10.imagebam.com/2412/9977af24119065.gif](http://www.imagebam.com/image/9977af24119065)
That’s a fresh install, as you can see at the bottomright the updates are even still rolling in ;).
That happens all the time…

Well, tried ‘cnetworkmanager’ as I can not find the source for wifi radar anywhere… all links are to the original site which is as dead as it can be.

cnetworkmanager did detect that I already had the kde3 network manager running, didn’t give me a working connection though… did spit out a huge wall of text

Guess I’ll work my way trough the tips in the sticky post then, maybe someone notices something that’s not configured properly…

/sbin/lspci
0e:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

/sbin/lspci -n
0e:00.0 0280: 8086:4229 (rev 61)

dmesg | less
iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
iwlagn: Copyright(c) 2003-2008 Intel Corporation
vendor=8086 device=2944
iwlagn 0000:0e:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
iwlagn 0000:0e:00.0: setting latency timer to 64
iwlagn: Detected Intel Wireless WiFi Link 4965AGN REV=0x4
iwlagn: Tunable channels: 13 802.11bg, 19 802.11a channels
vendor=8086 device=2944
iwlagn 0000:0e:00.0: PCI INT A disabled

Guess that’s all as it was to be expected, as it does work… just the network managers behaving oddly.

Network manager is seeing the network at the moment… rare occurrence.

ifconfig wlan0
wlan0
Link encap:Ethernet HWaddr 00:1D:E0:19:80:A7
inet addr:192.168.1.35 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::21d:e0ff:fe19:80a7/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:96 errors:0 dropped:0 overruns:0 frame:0
TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:38348 (37.4 Kb) TX bytes:6820 (6.6 Kb)

Have you tried using the compat-wireless drivers ? i’ve heard that they are sometimes better on the original drivers. IIRC intel dropped the ball when doing the drivers & the linux-wireless guys had to pick up the fumble.Have a look here Welcome - Linux Wireless for more info & also join their mailing lists,beware,there can be as much as 1500 mails a month :smiley:

Andy

Mmh thanks for the tip, any way of installing it without having to compile it? I seem to remember a wireless repository… but can’t find it.

I’m not -that- fond of compiling and it being kernel related just makes it worse.

Schmolle’s the place you want, just add it to your repo list Schmolle’s repo

Andy

Seems to lack a 11.1 specific one :frowning:

Hrmph,typical.There i was raving about someone’s repo & they don’t have 11.1.Try here

Andy

Bah, either getting:

Software installation
Installation was only partially successful.
The following packages could not be installed
compat-wireless
or
strigi-0.6.3-19.5.x86_64 requires libc.so.6()(64bit), but this requirement cannot be provided

 ] do not install compat-wireless-kmp-pae-2.6.20081218_2.6.27.7_9.1-4.1.i586
 ] Ignore some dependencies of strigi

Ignoring dependencies is never a smart thing to do afaik, so I tried uninstalling strigi before trying it again.
Turns out strigi wont go without taking plasma_workspace away along with it, which can’t be good either.

http://packages.opensuse-community.org/index.jsp?searchTerm=libc.so.6 Only comes up with 11.0 again.

Crikey!! it never rains but it pours :smiley: :smiley: try this 64bit

Andy

Keep getting

Software installation
Installation was only partially successful.
The following packages could not be installed
compat-wireless

The Xen Kernel? seems to install fine though, though I missclicked that.
Not using Xen.

weird, never happened to me, try downloading the compat-wireless rpm & install via the console

Andy

Okay so I went into YaST software management and manually added the repository so I could manually install it, turns it out it IS installed, even though I got the message it didn’t before.

No idea if it solved my problem, seems good after the first reboot at least, 11 networks showing up in KDE3 network manager. Usually only see 10 over iwlist scan and 0-5 in network manager.

Excellent, glad you got it sorted.Now enjoy :slight_smile:

Andy