Network Manager & WPA

I’ve got some wierd problems with KNetwork Manager on OpenSuSE 11.1 (KDE 3.5), I think it is related to handling of the WPA key:
@home: everything works (AP: ZyXEL, WPA-key: alphanumeric, starting with K)
@work: I can not connect (AP: LinkSys, WPA-key: alfanumeric, starting with #)
@friends home: I can not connect (AP: Cisco, WPA-key: digits only)
If I change from Network Manager to ifup everything works…

Any suggestions (except the obvious: “use ifup instead of Network Manager”) ?

How about:

“Use ifup together with SCPM”


It’s somehow funny, that you have this problem with a new version, because KnetworkManager 0.7 uses wpa_passphrase internally in order to avoid such problems with special characters (’#*`§$&/ etc.).

Your sig. got the answer to that solution :wink:
I’m investigating this problem mostly because I’ve been asked by a couple of my colleagues to help them install Linux (preferably SuSE, which we use on some of our servers) on their laptops, they are very Windows-oriented so the solution should be “as easy as on Windows”.
SCPM is afaik not an easy solution (in this specific situation).

SCPM is very easy to use (IMHO), you can even choose the Profile to be loaded before you start booting (Bootscreen) and you have a small applet to change it in the running system.

Why should it be “as easy as in windows”? Do you really want to make their systems so complicated, intransparent and lacking features? :slight_smile:


I will try to reproduce your scenario on one of my old APs.

Tried it with my old netgear router, WPA and the “password”


on openSUSE 11.1, KDE 3.5.10 and knetworkmanager.

  • chose “New connection” => “wlan0”

  • added ESSID from the little window showing the scan results

  • added “password” #1234567890

  • used the default settings for the rest of it (dhcp …)

  • chose the newly added connection … turning gear on the Networkmanager icon in systray … …

iwconfig wlan0

wlan0     IEEE 802.11abgn  ESSID:"NETGEAR"
          Mode:Managed  Frequency:2.462 GHz  Access Point: MA:CA:DR:ES:SE
          Bit Rate=54 Mb/s   Tx-Power=15 dBm
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-20 dBm  Noise level=-92 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

ifconfig wlan0
wlan0     Link encap:Ethernet  Hardware Adresse MA:CA:DR:ES:SE
          inet Adresse:  Bcast:  Maske:
          RX packets:5617 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5518 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 Sendewarteschlangenlänge:1000
          RX bytes:4504431 (4.2 Mb)  TX bytes:1392879 (1.3 Mb)

ping -c4
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=1.75 ms
64 bytes from icmp_seq=2 ttl=64 time=1.84 ms
64 bytes from icmp_seq=3 ttl=64 time=1.48 ms
64 bytes from icmp_seq=4 ttl=64 time=1.46 ms

--- ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3010ms
rtt min/avg/max/mdev = 1.464/1.635/1.840/0.170 ms

Works for me™.

Interesting… what can be the problem then ?

There’s a lot of misery going on about the Networkmanager. I’m using WICD (available from Software Search) and it works flawlessly.