Network manager won't connect to wireless router

All settings are correct as far as i can tell.
The wep key works on all my windows boxes.
When i have connect automatically enabled it never tries to connect. if I go to edit it it pops kde wallet up i put in credentials. wallet goes away then nothing happens.
if i double click connection to my router also nothing happens.
I have the wep key in there and i even made it visible to make sure.

If possible try WPA

Have you checked the wireless help section?

Could try. But my friend doesn’t like linux. changing it just for one linux laptop doesn’t make sense. It really should work with wep. Where is the link to wireless help?

Getting Your Wireless to Work - openSUSE Forums

Wireless - openSUSE Forums

there is another way to make it work
go to Yast->network devices and enable "traditionl method with ifUP "
and then choose your wireless card and set the ip address or DHCP
and hit Next ,set the SSID and the wep key and you’re finished

if you’re using a specific ip address dont (not DHCP) dont forget DNS and Routing

A bit late but:
I just solved a similar Network Manager problem [openSuse 11.3 x32] with new ADSL wifi router. It just asked endlessly for the WEP 128 password. I solved it by upgrading the router and the machines to WPA-PSK.

Related issue: this also solve problems with printing from SUSE via an XP machine on the LAN.