Network manager won't accept my security key

The network manager will ask me for my security key and it will not accept it. Instead when I use the show password feature to see what I typed in was correct, it shows something completely different than what I typed. For instance if my Key was : helpnow1
when it pops up and ask to for me to retype it again it shows something completely different in hex. Is there anyway I can use a different network manager?

What sort of network are you trying to access, WEP, WPA or something more complex? My best guess is that your network is using WPA or ‘WEP 40/128 Passphrase’ and that you have the type set to ‘WEP 40/128 Hexadecimal’ or ‘WEP 40/128 ASCII’.

I was trying to connect to a WPA security network. However, I have madwifi installed, but I don’t really know the commands that I could use to configure my wireless card, so I can use it. I’m stuck with network manager. The module that I’m using is ath9k. It won’t connect to anything even though it detects networks.

How are you using networkmanager? There are multiple options when configuring. There may be a problem with ath9k not supported by networkmanager when connected to encrypted networks. I would check the forums on that.

Do the following tests: 1)try to connect to an unencrypted network. 2)Use wpa_supplicant+wpa_supplicant.conf file+dhclient to get a connection. You should find enough information on configuring a wpa_supplicant.conf file online.

If those two fail, check the log in /var/log/messages for anything interesting.

How do I install dhclient? I can’t find anyway to install it. Also how do I install the other things as well? Are they available via rpm?

I have this problem as well, although it comes and goes. nm-applet used to work, but now, no matter how many times I type in the correct WPA2 passphrase, it gets it wrong (I type in the correct passphrase, it fails to connect, I have it show what passphrase it used and it’s garbage, repeat). Sometimes, if I disable and re-enable Wireless (right click on the network manager icon) a few times, it’ll start working.

dhclient and wpa_supplicant should both be installed if networkmanager is. There are alternatives but not suggested for new users.

I just solved a similar Network Manager problem [openSuse 11.3 x32] with new ADSL wifi router. It just asked endlessly for the WEP 128 password. I solved it by upgrading the router and the machines to WPA-PSK.

Related issue: this also solve problems with printing from SUSE via an XP machine on the LAN.

Recommend for starters verifying the WPA password hash is correct.

  1. If you have been successful in at least configuring a connection to your WPA Access Point (not necessarily connecting) you should find the configuration listed in /etc/wpa_supplicant/wpa_supplicant.conf
  2. If you know the correct passphrase, you can now generate the hash to compare with what is entered in wpa_supplicant.conf by using the utility wpa_passphrase.

If they match, then you’re sending the correct hash. If they don’t match, try using the newly hashed string you just created and if you are successful then check the configured hash again in the future to see if it was overwritten.