Network Manager sees networks can't connect

Used to work perfectly. I attempted to install VPN client, result is can’t connect to anything. Networks are seen by network manager, nothing happens when click connect.

Assistance much appreciated. Have done my best to follow instructions in sticky for wireless problems. Results below:

Wireless LAN present in Hardware information. Atheros AR242x 802.11abg Wireless PCI Express Adapter (wlan0)
Kernel Driver: ath5k
168c:001c

/var/log/boot.msg
search of document does not find any use of word ‘firmware’
no sign of mention of ‘radio kill switch’
document starts:
“Inspecting /boot/System.map-2.6.27.45-0.1-default
Cannot find map file.
No module symbols loaded - kernel modules not enabled.”
Typing “dmesg | grep firmware” gives nothing in terminal.

Access Points
“sudo /usr/sbin/iwlist scan”
results are close to example given

Have encryption key

wpa_supplicant present in YaST

Association and authentication
With NetworkManager. Recognises various available networks. Select my network and menu closes, no response or connection.
Not connected, “/usr/sbin/iwconfig” does not give IP address or MAC address. “Access point: Not-Associated”

Advice is to use output of dmesg command to find problem, but as above I don’t get any results for this in terminal.

attempt to ping external site
linux-cfi6:~ # ping -c 66.70.73.150
Usage: ping -LRUbdfnqrvVaA] -c count] -i interval] -w deadline]
-p pattern] -s packetsize] -t ttl] -I interface or address]
-M mtu discovery hint] -S sndbuf]
-T timestamp option ] -Q tos ] [hop1 …] destination

I do not know the solution to your main problem, however I noticed that you were using ping wrong:

attempt to ping external site
linux-cfi6:~ # ping -c 66.70.73.150
Usage: ping -LRUbdfnqrvVaA] -c count] -i interval] -w deadline]
-p pattern] -s packetsize] -t ttl] -I interface or address]
-M mtu discovery hint] -S sndbuf]
-T timestamp option ] -Q tos ] [hop1 …] destination

You use the -c paramater which needs a ‘count’ (how many packets to transmit), try instead:

ping -c 3 66.70.73.150

For your main problem, have you tried manually providing the information to iwconfig? I used the following for my old WEP connection when I couldnt get the GUI applications to connect when provided with the correct information.

iwconfig wlan0 essid MY_ESSID
iwconfig wlan0 key MY_NETWORK_KEY

Make sure that the network is visible via:

iwlist wlan0 scanning