Network Manager not "seeing" networks

I have installed opensuse 13.2 (love it so far) with the KDE desktop but I have not internet.
What I mean by that is that the network manager is not scanning and displaying available networks.
The hardware manager sees the network/WIFI card and says it is active.
During installation, I set the static IP to 8.8.8.8 and named it google after that setup scanned for networks and found some but after installation was dno scanning and not finding
Is there something else I need to do?
I am new to linux so anything you tell me to do must be spelled out in detail.

ifconfig produces the following;



enp1s0    Link encap:Ethernet  HWaddr B8:70:F4:81:8D:F1  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:32 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1920 (1.8 Kb)  TX bytes:1920 (1.8 Kb)

That usvery strange, it says it is UP, but there is no IP address!?!

BTW, you say something about the 8.8.8.8 address. What did you exactly do with that. And with “exactly” I do not mean some story, but things like the ifconfig output above.

BTW it is much better to copy/past things like your ifconfig including the prompt, the command, the output (the only thing you posted) and the next prompt. That give us more information, like the exect commnad you typed.

You need to make sure that you have NetworkManager selected via YaST. This guide may be helpful with getting started

https://doc.opensuse.org/documentation/html/openSUSE_113/opensuse-startup/cha.nm.html#sec.nm.activat

If you’re connecting to a DSL router, then it would be usual to have a DHCP server running. If that is the case, then the IP addressing is automatically assigned, so you need to explain why you thought a statci IP address was required. BTW, 8.8.8.8 pertains to a public Google DNS address, and not relevant to assigning yourself a private IP address.

To help us further, if you need to report the output of requested commands (without the machine being connected to the internet), you can use a memory stick to cut and paste, and transfer to an internet-connected machine.

This information will be of benefit to us

systemctl status NetworkManager
systemctl status wicked
ip address
netstat -r
cat /etc/resolv.conf |grep name

ifconfig is ancient and should no longer be used; use ‘ip address’ (or ‘ip
a’ for short) instead.

When you click on the NetworkManager icon do you see a button to ‘Show
More’? Tried that?

How do you know your system is not scanning for networks? Are you
assuming as much because you do not see networks listed, or are you
actually doing steps that would otherwise show scanning happening and not
seeing anything?


Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below…

Thank you all for your time and quick responses and thank you for the documentation link.
I will read that and do all you say .

Here is some info gathered from the above commands;


linux-ltkl:/home/redrider # systemctl status NetworkManager
NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
   Active: active (running) since Sun 2015-01-11 12:22:22 EST; 3min 43s ago
 Main PID: 846 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           └─846 /usr/sbin/NetworkManager --no-daemon

Jan 11 12:22:23 linux-ltkl.site NetworkManager[846]: <info> (wlp2s0): driver supports Access Point (AP) mode
Jan 11 12:22:23 linux-ltkl.site NetworkManager[846]: <info> (wlp2s0): new 802.11 WiFi device (driver: 'brcmsmac' ifindex: 3)
Jan 11 12:22:23 linux-ltkl.site NetworkManager[846]: <info> (wlp2s0): exported as /org/freedesktop/NetworkManager/Devices/2
Jan 11 12:22:23 linux-ltkl.site NetworkManager[846]: <info> (wlp2s0): device state change: unmanaged -> unavailable (reas...20 2]
Jan 11 12:22:23 linux-ltkl.site NetworkManager[846]: <error> [1420996943.050408] [platform/nm-linux-platform.c:2246] link...ound)
Jan 11 12:22:23 linux-ltkl.site NetworkManager[846]: <warn> (wlp2s0): firmware may be missing.
Jan 11 12:22:23 linux-ltkl.site NetworkManager[846]: <info> (wlp2s0): preparing device
Jan 11 12:22:23 linux-ltkl.site NetworkManager[846]: <info> ModemManager available in the bus
Jan 11 12:22:28 linux-ltkl.site NetworkManager[846]: <info> startup complete
Jan 11 12:22:52 linux-ltkl.site NetworkManager[846]: <info> use BlueZ version 5
Hint: Some lines were ellipsized, use -l to show in full.


linux-ltkl:/home/redrider # systemctl status wicked
wicked.service - wicked managed network interfaces
   Loaded: loaded (/usr/lib/systemd/system/wicked.service; disabled)
   Active: inactive (dead)



linux-ltkl:/home/redrider # ip address
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp1s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether b8:70:f4:81:8d:f1 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether c0:f8:da:85:60:1a brd ff:ff:ff:ff:ff:ff


linux-fb1d:/home/redrider # netstat -r
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface




linux-ltkl:/home/redrider # cat /etc/resolv.conf |grep name
returned no values


As far as I cn see nothing is configured. What did you do to configure your network. And please no story of what you think you did, but an exact description of what you did. Like I started YaST > Network Devices > Network Settings and I filled in in tab Global Options …

And please tell us if you want to use DHCP (from your ISP’s router) or not.
And if you want to use Network Manager or not.

That is the problem. These devices require firmware to be downloaded. Please try to install kernel-firmware package and reboot. If it does not help, most likely your specific Broadcom chip is not supported. In this case ask on Wireless forum, there will be more experts there; post output of “lspci -nnk” to see exact identification of your wireless device.

OK, skip my posts above and follow avidjaar’s advice.

But I still wonder what you wanted to do with that IP address of 8.8.8.8.

It was assigned as the IP during installation/network setup

ok, i don’t know how to “install kernel-firmware package”. A few hints please?

Did you install by DVD? It should be possible to install the package from there

zypper in kernel-firmware

Otherwise, if you can connect temporraily to a wired internet connection, then run the command.

You should really find out which wireless chipset is installed first, since the steps can be different

A basic guide
http://opensuse-guide.org/wlan.php

A command that can help with reporting that

/usr/sbin/hwinfo --wlan

You can not “invent” your IP address by your own! That is an existing IP address. After you managed to get your wireless running, do not use that adress again please. Try to use your DHCP server in your router as is normaly done in home situation.

I have downloaded the firmware from Broadcom and moved into my linux platform - what now?


linux-ltkl:/home/redrider # hwinfo --wlan 
15: PCI 200.0: 0282 WLAN controller                             
  [Created at pci.328]
  Unique ID: qru8.Ssv+p5ilq98
  Parent ID: qTvu.yPTGdCnX0XF
  SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Broadcom BCM4313 802.11b/g/n Wireless LAN Controller"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4727 "BCM4313 802.11b/g/n Wireless LAN Controller"
  SubVendor: pci 0x14e4 "Broadcom"
  SubDevice: pci 0x0510 
  Revision: 0x01
  Driver: "bcma-pci-bridge"
  Driver Modules: "bcma"
  Device File: wlp2s0
  Features: WLAN
  Memory Range: 0xd2400000-0xd2403fff (rw,non-prefetchable)
  IRQ: 17 (no events)
  HW Address: c0:f8:da:85:60:1a
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000014E4d00004727sv000014E4sd00000510bc02sc80i00"
  Driver Info #0:
    Driver Status: bcma is active
    Driver Activation Cmd: "modprobe bcma"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #7 (PCI bridge)
linux-ltkl:/home/redrider # 



en:users:drivers:brcm80211 [Linux Wireless] states this:

Please note: at least BCM4313 is not fully supported. Some models appears to work (users reported success), but some don’t, and there’s no indication that this is going to change.

So you probably should install the proprietary broadcom-wl driver, available in the Packman repo (you need two packages: broadcom-wl and broadcom-wl-kmp-xxx according to your kernel)

If you want/need to download it manually, you can do so here:

If you can connect via a wire e.g., it would probably be easier to just add the Packman repo in YaST->Software Repositories->Add->Community Repositories, and install the packages with YaST->Software Management.

If you can connect via a wire e.g., it would probably be easier to just add the Packman repo in YaST->Software Repositories->Add->Community Repositories, and install the packages with YaST->Software Management.

I have downloaded the packages you recommended.
I can only access internet via wireless on the the windows side so the install must be without it

Ok.
Then transfer the packages to your Linux system, and install them with:

sudo rpm -i broadcom-wl.rpm broadcom-wl-kmp-desktop.rpm

(or whatever the actual filenames are)

Just opening them in the filemanager should allow you to install them as well. (in case you use KDE: due to a bug in Apper/PackageKit-Qt you might get an error the first time, just try again and it should work)

After a reboot, the wireless should work.

no joy


linux-ltkl:/home/redrider/Desktop # sudo rpm -i broadcom-wl-kmp-desktop-6.30.223.248_k3.17.4_1-1.11.i586.rpm broadcom-wl-kmp-desktop-6.30.223.248_k3.17.4_1-1.11.i586.rpm
warning: broadcom-wl-kmp-desktop-6.30.223.248_k3.17.4_1-1.11.i586.rpm: Header V4 RSA/SHA1 Signature, key ID 1abd1afb: NOKEY
error: Failed dependencies:
        broadcom-wl is needed by broadcom-wl-kmp-desktop-6.30.223.248_k3.17.4_1-1.11.i586
        kernel-uname-r = 3.17.4-1-desktop is needed by broadcom-wl-kmp-desktop-6.30.223.248_k3.17.4_1-1.11.i586