Network Manager not detecting wireless device! open Suse 11.3

I just solved a similar Network Manager problem [openSuse 11.3 x32] after installing a new ADSL wifi router. It just asked endlessly for the WEP 128 password. I solved it by upgrading the router and the machines from WEP to WPA-PSK.

Related issue: this also solve problems when printing from SUSE via an XP machine on the LAN. This issue also existed prior to the router upgrade although file sharing worked and the other Linux machine (Linpus) could print without problem.

My impression is that Network Manager is flawed.

Just googling the device ID “1737:0079” gives quite some interesting results.

I won’t give any advice which solution might be the best one, but if there is really someone out there, who

a) has a device with this USB-ID (1737:0079)

b) uses a distribution with a rather recent kernel (>= 2.6.31)

c) is willing to do some simple tests if the device is supported by rt2870sta from inside the kernel

we might get “in business” with my goal to add this device ID to the in-kernel driver (only IF the device actually is supported, of course) and pushing this change upstream while the person willing to play the “guinea pig” might get a rather simple solution on how to get this baby up and running without having to compile anything (again, IF the device is supported by rt2870sta).

On 10/25/2010 05:06 AM, pacolaser wrote:
>
> I just solved a similar Network Manager problem [openSuse 11.3 x32]
> after installing a new ADSL wifi router. It just asked endlessly for the
> WEP 128 password. I solved it by upgrading the router and the machines
> from WEP to WPA-PSK.
>
> Related issue: this also solve problems when printing from SUSE via an
> XP machine on the LAN. This issue also existed prior to the router
> upgrade although file sharing worked and the other Linux machine
> (Linpus) could print without problem.
>
> My impression is that Network Manager is flawed.

I think that your problem was trying to use a passphrase rather than the hex
key. As has been discussed many, many times here, you must use the key, not the
phrase that works for Windows!!!

Well that statement would be completely wrong. I’ve been using 128 bit WEP encryption with passphrase 13 characters long (as required with WEP), not the hex key and it worked well. I had the same problem as mentioned here with endless asking to enter the phrase again and again and if I remember correctly it was only with K Network Manager. Since I have Atheros network adapter, usually installing ath_pci driver solved the problem, because ath5k or 9k were not so good, but now they work better too. GNOME NM had different problems. That’s why I started to use Wicd.

Since OP did not post nothing recently, I won’t comment about his/her problems, but for the sake of the thread I wonder if he tried the ifup method which I did use on my 11.3 because it works much better than KNM. Of course, the driver and firmwire should already be installed and configured, but since I don’t have hardware as OP I don’t know how things are in that area, when we speak about Linux, that would be.

All in all, wireless is very well suported today on Linux, it’s that some applications and (sometimes) the “lack” of preinstalled software or bad performance of it, so as the end user’s ignorance, no matter if he is asking for or want to help, make it not available.

And to clarify some things, as can be found on the internet;

Choosing and using a WEP (Wired Equivalent Privacy) password can be a challenge, because WEP is an older security protocol that was developed before members of the Wi-Fi Alliance had agreed on a uniform way to treat passwords. The result is that a WEP password may not work for all computers in a multiplatform environment.

However, this is the easy trick you can use to make a WEP password work for everybody on your network:

For a 40 bit WEP network, always choose a 5-character password.
For a 128 bit WEP network, always choose a 13-character password. Be sure to use a password that is secure.

Understanding the numbers:

A WEP network uses either a 64 bit or 128 bit encryption key, but the Wi-Fi industry usually refers to the former as “40 bit.” Though a bit inconsistent, this naming convention is easy to understand: The password you enter takes up either 40 or 104 bits, and in both cases a 24 bit random number is added, totaling 64 bit and 128 bit keys. You may see 40/64 and 104/128 used interchangeably as appropriate in context. The larger numbers refer to the total key, and the smaller numbers to the actual password.

The multiplatform issue:

Being an older protocol, WEP password treatment was not implemented uniformly by all wireless hardware and operating system manufacturers. Some products require users to enter relatively cryptic hexadecimal characters (four bits each), while others allow “plain language” password entry. A plain language password, like “linux”, uses standard ASCII characters that are 8 bits each.

Products that allow plain language (ASCII) password entry may not force the network administrator to create 5- or 13-character passwords that would result in the required 40 (58) and 104 (138) bit-length passwords. Instead, they use a “hashing” routine to convert an odd-length password to the correct bit length. The multiplatform issue arises when the hashing results of products from two different manufacturers don’t match each other. The resulting “network equivalent passwords,” which are always given in hexadecimal format, are different.

How choosing 5 or 13 characters avoids the issue:

Every standard Roman character has a 2-character hexadecimal equivalent. If you select 5 characters for a 40 bit password or 13 characters for a 104 bit password, then no hashing will be required. All wireless manufacturers convert each roman (ASCII) character directly into a hexadecimal when there is no hashing.

For example: If your 40 bit password is “apple”, the hex value equivalent is 6170706C65 (a=61, p=70, p=70, l=6C, e= 65). This is true regardless of manufacturer.

Today cracking WEP Wireless Networks isn’t a big problem, so I suggest that you consider using the strongest WPA RADIUS encryption possible, not PSK.

And if anyone is interested in those kind of things I recommend reading this for start;Cracking WEP and WPA Wireless Networks - Docupedia

Obviously the OP knows everything; however, for the rest of us, there are two
ways to convert a WEP passphrase to the hex key used to authenticate the
connection. Windows uses one method, and Linux uses the other. To avoid
confusion, get the hex key from your AP and use it.

I am new to this forum and just read the faq.
Where do I find wireless drivers for the open suse 11.3?
Thanks,
Ken

Ken,

Can you tell us what your wireless device is?
If you open a terminal and enter the following, and post the result

/sbin/lspci -nnk

No such file or directory Is the result…
I am using a Dell computer with a 1450 USB wireless adapter on a desktop computer.
Thanks,
Ken
-====-

On 11/15/2010 08:06 AM, kwieringo wrote:
>
> caf4926;2251796 Wrote:
>> Ken,
>>
>> Can you tell us what your wireless device is?
>> If you open a terminal and enter the following, and post the result
>>
>>>
> Code:
> --------------------
> > > /sbin/lspci -nnk
> --------------------
>>>
>
> No such file or directory Is the result…
> I am using a Dell computer with a 1450 USB wireless adapter on a
> desktop computer.

If you got the “No such file or directory” message, then you entered the command
incorrectly. The program ‘/sbin/lspci’ is on every system.

As you have a Dell Wireless 1450 USB device, you need to use a slightly
different command:


lsusb

If that command comes back with the same message, then you need to install the
usbutils package using a wired connection.

My suspicion is that you are missing firmware for that device. You can check
that with the command


dmesg | grep firmware

If that command produces any output, please post it.

lsusb = bus 001 device 002: id 413c:8104 Dell computer corp Wireless 1450 dual band (wireless 802.11 ab&G) usb 2.0 adapter.
Unfortunatly I don’t have a wired connection to use or I would be using it all the time instead of wireless.
Thanks,
ken
-=====-

On 11/15/2010 11:06 AM, kwieringo wrote:
>
> lsusb = bus 001 device 002: id 413c:8104 Dell computer corp Wireless
> 1450 dual band (wireless 802.11 ab&G) usb 2.0 adapter.
> Unfortunatly I don’t have a wired connection to use or I would be using
> it all the time instead of wireless.
> Thanks,
> ken
> -=====-

You need firmware. Go to http://linuxwireless.org/en/users/Drivers/p54#firmware
for the links.

My DW1450 needs firmware 2.13.1.0.arm.bin from
http://daemonizer.de/prism54/prism54-fw/fw-usb/2.13.1.0.arm.0, but loads it from
/lib/firmware/isl3887usb. If yours is the 2nd generation, then you need
http://daemonizer.de/prism54/prism54-fw/fw-usb/2.13.24.0.lm87.arm. Whichever,
you should copy it to /lib/firmware under the name shown in the dmesg output.
Once the correct file is there, the device should work.

Guys, these are steps I followed and worked for me in a Dell Inspiron 1525.

Requires Internet connection thru LAN

  1. Yast -> Network Devices -> Network Settings
  2. Click on Global Options Tab -> Choose “Traditional Method with ifup”
  3. Click on Overview Tab -> Edit the BCM43xxx (WLAN interface)
  4. Open a Terminal window and type the following:
    $ sudo /usr/sbin/install_bcm43xx_firmware
  5. After firmware is dowloaded and installed. It all works.
  6. Click on Global Options Tab -> Choose “User Controlled Network Manager” again.

Hope this works for you guys too!:wink:

Beautiful…still worked today!!! Owe you a drank!