Network Manager "Network Inactive"

I upgraded from 13.1 to leap 42.1 (KDE). I am confused by what is now Network Manager because it’s not the straight forward GUI from 13.1.

I honestly don’t know if NM is on or how to turn it on. I see what looks like a red monitor, but get popup message “Network Inactive” when I mouse over it.

Then there are popup check boxes next to a wifi symbol and an airplane mode symbol? Then I see old wifi connections in the popup connection editor, but the connect and disconnect buttons are greyed out. Where do I turn this thing on? In 13.1, I have a checkbox that says “enable networking.” Where is it in leap 42.1?

Then I look up anything to do with networks. I activated all the network services. Under network settings, I changed wicked to network manager under the global tab. Same results. It worked in 13.1!

Here’s my hardware:

/sbin/lspci -nnk | grep -iA3 net
02:00.0 Network controller [0280]: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe [1814:0781]
        Subsystem: ASUSTeK Computer Inc. Device [1043:130f]
        Kernel driver in use: rt2800pci
        Kernel modules: rt2800pci

When I try to scan:

sudo /usr/sbin/iwlist scan

wlan0     Interface doesn't support scanning : Network is down

But I have no idea if NM is on or not.

I doubt there’s a firmware problem since it worked in 13.1. All the code from dmesg | less looks the same as in leap 42.1.

Leap recognizes that I have a wireless device:


wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

But how do I fix that off status? I can’t find the manual for leap 42.1 either. Could you please help me?

Thanks in advance

What about a leap 42.1 manual? Is there a manual? Then I won’t have to bother anyone too much.

On Tue, 17 Nov 2015 02:06:02 +0000, HealingMindNOS wrote:

> What about a leap 42.1 manual? Is there a manual? Then I won’t have to
> bother anyone too much.

I’d probably start here:


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at

What does the following return?

systemctl status network

If you check modinfo rt2800pci you’ll see that firmware is required…

# modinfo rt2800pci
filename:       /lib/modules/3.16.7-29-desktop/kernel/drivers/net/wireless/rt2x00/rt2800pci.ko
license:        GPL
firmware:       rt2860.bin

Do you have the kernel-firmware package installed?

Thanks for the reference. I saw that manual for 12.3. Problem is my inability to interpret the present leap NM.

systemctl status network
NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
   Active: active (running) since Mon 2015-11-16 22:45:57 PST; 4min 26s ago
 Main PID: 908 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           └─908 /usr/sbin/NetworkManager --no-daemon

modinfo rt2800pci
filename:       /lib/modules/4.1.12-1-default/kernel/drivers/net/wireless/rt2x00/rt2800pci.ko
license:        GPL
firmware:       rt2860.bin
description:    Ralink RT2800 PCI & PCMCIA Wireless LAN driver.
version:        2.3.0
srcversion:     5C7768FC9D600016BB9062C
alias:          pci:v00001814d0000539Fsv*sd*bc*sc*i*
alias:          pci:v00001814d0000539Bsv*sd*bc*sc*i*
alias:          pci:v00001814d0000539Asv*sd*bc*sc*i*
alias:          pci:v00001814d00005392sv*sd*bc*sc*i*
alias:          pci:v00001814d00005390sv*sd*bc*sc*i*
alias:          pci:v00001814d00005362sv*sd*bc*sc*i*
alias:          pci:v00001814d00005360sv*sd*bc*sc*i*
alias:          pci:v00001814d0000359Fsv*sd*bc*sc*i*
alias:          pci:v00001814d00003593sv*sd*bc*sc*i*
alias:          pci:v00001814d00003592sv*sd*bc*sc*i*
alias:          pci:v00001814d00003562sv*sd*bc*sc*i*
alias:          pci:v00001814d00003062sv*sd*bc*sc*i*
alias:          pci:v00001814d00003060sv*sd*bc*sc*i*
alias:          pci:v00001432d00007722sv*sd*bc*sc*i*
alias:          pci:v00001432d00007711sv*sd*bc*sc*i*
alias:          pci:v00001814d00003390sv*sd*bc*sc*i*
alias:          pci:v00001814d00003290sv*sd*bc*sc*i*
alias:          pci:v00001A3Bd00001059sv*sd*bc*sc*i*
alias:          pci:v00001462d0000891Asv*sd*bc*sc*i*
alias:          pci:v00001432d00007768sv*sd*bc*sc*i*
alias:          pci:v00001432d00007758sv*sd*bc*sc*i*
alias:          pci:v00001432d00007748sv*sd*bc*sc*i*
alias:          pci:v00001432d00007738sv*sd*bc*sc*i*
alias:          pci:v00001432d00007728sv*sd*bc*sc*i*
alias:          pci:v00001432d00007727sv*sd*bc*sc*i*
alias:          pci:v00001432d00007708sv*sd*bc*sc*i*
alias:          pci:v00001814d00003092sv*sd*bc*sc*i*
alias:          pci:v00001814d00003091sv*sd*bc*sc*i*
alias:          pci:v00001814d00003090sv*sd*bc*sc*i*
alias:          pci:v00001814d00000781sv*sd*bc*sc*i*
alias:          pci:v00001814d00000701sv*sd*bc*sc*i*
alias:          pci:v00001814d00000681sv*sd*bc*sc*i*
alias:          pci:v00001814d00000601sv*sd*bc*sc*i*
depends:        rt2x00lib,rt2800lib,rt2800mmio,rt2x00mmio,rt2x00pci,eeprom_93cx6
intree:         Y
vermagic:       4.1.12-1-default SMP preempt mod_unload modversions 
signer:         openSUSE Secure Boot Signkey
sig_key:        03:32:FA:9C:BF:0D:88:BF:21:92:4B:0D:E8:2A:09:A5:4D:5D:EF:C8
sig_hashalgo:   sha256
parm:           nohwcrypt:Disable hardware encryption. (bool)

Okay, so you are using Network Manager.

BTW, I didn’t need you to post the output from the modinfo command - it was used to illustrate that firmware is required. Do you have the kernel-firmware package installed? Check with

rpm -q kernel-firmware

On Tue, 17 Nov 2015 07:16:01 +0000, HealingMindNOS wrote:

> hendersj;2737936 Wrote:
>> On Tue, 17 Nov 2015 02:06:02 +0000, HealingMindNOS wrote:
>> I’d probably start here:
>> Jim –
>> Jim Henderson openSUSE Forums Administrator Forum Use Terms &
>> Conditions at
> Thanks for the reference. I saw that manual for 12.3. Problem is my
> inability to interpret the present leap NM.

It should be pretty similar to what’s in Factory, though it’s probably
not exactly the same.


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at

sorry for the belated reply - from leap:

rpm -q kernel-firmware

BTW: The firmware looks different from 13.1 (wherein I know how to use NM)

rpm -q kernel-firmware

Check that the wireless device is not disabled

/usr/sbin/rfkill list

If it is soft-blocked, you can enable with

sudo /usr/sbin/rfkill unblock wifi

If it is hard-blocked, this usually means a wireless switch or fn key needs to be used to enable the device first.

Please excuse my belated reply:

/usr/sbin/rfkill list
bash: /usr/sbin/rfkill: No such file or directory

sudo /usr/sbin/rfkill unblock wifi
sudo: /usr/sbin/rfkill: command not found

During installation, one of the set up pages asked me to set up a network, but I skipped it. Is this why I’m getting these unknowns? Thanks in advance.

You need to install the rfkill package. Do you have access to internet via wired ethernet?

Install with

zypper in rfkill

Unfortunately, I don’t. I had Sprint’s WiMax until it was shut down. At the moment I’m using Xfinity which has been sketchy.

I notice that I don’t have rfkill in 13.1 either wherein wifi works. But I will look into installing rfkill in leap and let you know the result. Thanks in advance.

Check that it isn’t as simple as a wifi switch (or key) that needs to be used to re-enable your wireless device.

I’ve been looking at the manual (KDE). I would like to know if that red monitor icon wherein there should be interface and control sections means trouble - if so, what does it usually mean? I assume the greyed out connect/disconnect buttons means trouble. There’s also no facility for scanning APs:

I only get little pop up windws on that red monitor icon. There’s a similar red icon on the task bar w the same pop up window. Thanks in advance.

I decided to reinstall leap to see what happens. When the upgrade asked for network settings, I set up a wifi connection this time after an adhoc scan. The upgrade was a success except for one complaint about a checksum changing with a repository (to which I said no).

The point is the wifi connection worked and was stable during the upgrade. It seems that I now have a full installation of leap.

Unfortunately, the new upgrade has latched onto the same problems - which tells me that there’s a software switch somewhere that I don’t know about.

Since the full installation of leap, the Network Monitor has changed:

But the Connection Editor remains the same:
I have a belief that I am missing drop down menu(s) wherein the software switch is hidden for scanning/activating wifi networks. Could someone please hold my hand for a moment and tell me how to put back the dropdown menu in this window?

Thanks in advance!

P.S. I have changed global settings from wicked to network managed and activated all networks.

The problem still remains from last year wherein I am being fooled by the drastically different GUIs in Leap from 13.1. The tick boxes are obvious. Upon activation, visible access points on the other side of the applet are obvious.

In Leap, however, I remained clueless as to what to expect until I found the following popup graphic of NM (the way it’s supposed to behave):
But this is what I’ve been getting in my upgrade (blanks):
As I understand, networking (including wifi) should work right “out of the box” for OSS, esp. if it’s the same machine. Right now, I have Leap on a different HDD, but on the same machine as 13.1. But I see yet another difference that concerns me. I can see my wifi network interface in 13.1:
But not in Leap:

Since I did have networking/downloads during the upgrade, I realize there’s probably a very simple switch/setting somewhere that I have yet to find. What is obvious in 13.1 is just not obvious to me in Leap. Could someone please indicate where those controls are to me? Thanks in advance.

Starting from the top, please show us the output of

/usr/sbin/hwinfo --netcard
nmcli d