Network manager missing from Plasma 5.3 (Tumbleweed up)


I’ve been struggling with the new Tumbleweed update. Thus far I haven’t been able to get “zypper dup” working at all and the system variously jams or crashes and is virtually unusable. I’ve run several re-intallations of the distro to no avail. Now I ran “zypper up” and it is much better - I have functioning desktop even in the ordinary mode (“zypper dup” attempts could use recovery mode after all).

However, there’s a problem as I don’t have network manager and thus no way to connect to internet. I don’t know why it is missing. YaST Software manager lists it as installed but I just can’t access it from anywhere.

Any tips for solving this without new round of distro installation are highly appreciated.



PS: My machine is Lenovo X200 Thinkpad. The release is 20150528-1.2.

PPS: I’m excited for the new upgraded desktop - this looks so good. I just wish to get it working.

Make sure plasma-nm5 is installed (not plasma-nm, that’s the KDE4 version), in YaST->Software Management e.g.
If you get conflicts when installing it, please ask. But in general you should just coose to remove plasma-nm-xxx (without ‘5’).

If there is a big difference between “zypper dup” and “zypper up”, then you probably have additional repos configured.

In that case, “zypper up” is probably better for you anyway.

However, you might want to occasionally follow that “zypper up” with

# zypper dup --dry-run

to see what else zypper dup would want to do. Then you can manually make which of those changes seem appropriate.

I do have plasma-nm5 installed. In all, I have plasma-nm5, plasma-nm5-openvpn, plasma-nm5-pptp and plasma-nm5-vpnc (all versions 5.3.0-3.1). No other package with “plasma-nm” string in its names is installed.

The current version is 5.3.1, but that should not matter really.

So, are you actually using Plasma5, or are you still on KDE4? If it’s the latter, you’d need plasma-nm instead, not plasma-nm5.

Otherwise, make sure that NetworkManager itself (not “Wicked Service”) is actually active in YaST->Network Devices->Network Settings->Global Options, the applet is not loaded if NetworkManager is not running.

And look into the system tray settings (right-click on the small up-arrow just left of the digital clock) whether “Networkmanagement” is enabled.

Thank you so much! It was the last item, the system tray settings that solved my problem.