Network Manager issue...

Hello people,

I am having a issue with my network manager for a long time … asked for help here and then moved to the kde forums since I couldn’t fine much help here. They told me I have to upgrade my Network Manger packages.

This is what I did.

Updated all packages regarding network Manager.
upgraded to plasmoid version. and I myself don’t know what all

I’ll post the link to my thread in kde forums

KNetworkManager - System Tray • KDE Community Forums

And this is what a KDE developer had to say about opensuse…

Look, it was Opensuse guys that created those packates, not KDE and fore sure it was not me or any other Plasma NM developer. I have seen several people having problems with packages created by distributions, specialy by Opensuse and (K)Ubuntu, who insist in shipping very outdated packages even though they are full of already fixed bugs. The package NetworkManager-kde4-libs -0.9.svn1192577-7.2 for example, it is one year old! I myself fixed about 60 bugs since that package were created, including several crashes. It does not help anybody Opensuse letting that package be easily found by any Opensuse user.

If you really want to fix this once and for all drop the Opensuse package and compile Plasma NM yourself. Most people who tried compiling by theirselves do not have problems anymore. The fact that Opensuse splits Plasma NM into several packages creates a mess when you use several repositories with several different versions of Plasma NM.

Why this has to happen with openSUSE when we are striving to create the most user friendly system. !!!

On 11/04/2011 12:16 PM, melvinjose wrote:
> Why this has to happen with openSUSE when we are striving to create the
> most user friendly system.

are you an openSUSE developer?

who is the “we” in your statement?

and, who told you that openSUSE is striving to create the most user
friendly system???

openSUSE®, the “German Automobiles” of operating systems

On 2011-11-04 12:16, melvinjose wrote:

> And this is what a KDE developer had to say about opensuse…

Well, if you have issues with the network manager, you could create a
bugzilla and tell them what the KDE folk think.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On my 11.4 system it shows exactly that version the KDE developers recommend
I wonder what shows your system?

If that is not good enough you can get a newer version from KDE:UpdatedApps
repository, but first check that you are at least on the version I showed

PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
| 16GB Ram
Eee PC 1201n: oS 12.1 RC2 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.2 |
nVidia ION | 3GB Ram

I thought I can be part of it since this is a community. Well, if thats your attitude you go ahead and develop opensuse and you can use it…

@ martin_helm…

I had the monolithic version shipped with the opensuse 11.4. I had updated to the same as your … .plasmoid-networkmanagement-0.9.svn1192577-7.2. And then the network manager wouldn’t start. I posted this in the kde forums and then they gave me the reply I posted above. Since I had no other option I deleted all that and reverted back to stock from DVD.

With the stock installation it wouldn’t show me different connections, won’t allow me to add a new connection and all. It used to work well only for the first few weeks and have been in the current state after I did a system update…

The details are there in kde posts (link in my first post)


Try creating another user, then adding new connections to the network manager. Does the new user account work ok? If so, it may be necessary to delete the config files


and start over with the connections again.


I’ll try that as soon as possible. I tried to compile the sources manually as told by a kde developer and everything is in a mess now. It says some DBUS issue… contact administrator or distribution. I’ll try this as soon as I can roll back