Network Manager broken 11.3 RC2

I have the same issue as this thread
11.3 M7 Network Manager broken

I have a gateway t-1616 I put it to sleep, but the system hung up. When I did a force rebooting, the network manager never was started.

I got this message when I run nm-tool:
NetworkManager Tool

State: asleep

  • Device: eth0 -----------------------------------------------------------------
    Type: Wired
    Driver: ATL1E
    State: unmanaged
    Default: no
    HW Address: 00:24:8C:66:14:26

Carrier Detect: yes

Wired Properties
Carrier: off

  • Device: wlan0 ----------------------------------------------------------------
    Type: 802.11 WiFi
    Driver: rt73usb
    State: unmanaged
    Default: no
    HW Address: 00:18:39:0E:5F:1D


Wireless Properties
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Access Points

Also, when I run #iwlist scan the wireless nic detects AP signals but never gets connected to any of them.

Finally, according to the other thread a possible solution is running #solid-network set networking enable, but I got the message:

#solid-network set networking enabled
QApplications: qAppName: Please instantiate the QApplication object first.
kdeinit4: preparing to launch /usr/lib64/
Klauncher(5921) kdemain: No DBUS session-bus found. Check if you have started the DBUS Server
Kdeinit4: Communication error with launcher. Exiting!
solid-network(7481): No ksycoca4 database available!

solid-network(7481)/kdecore (trader) KserviceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType: “SolidNetworkManager” Not found
debug: newotk interface list contains: 0 entries

I can easily fix this reinstalling the whole system, but that’s not the idea. I appreciate helping me to find a solution.

Has a bug report been raised on this.
It’s OK for me though.

If re-installing will fix it. I’m just wondering what changed since you installed until now…?

I just did a replacement-install of 11.3 RC2 and did not have that issue.

I have two network adapters (one internal wired gigabit, one USB wireless); as is typical, the wireless adapter requires a firmware install and a utility (zd1211-firmware is included on the openSuSE DVD, and has been since 11.0; however, it’s not present on the live images; also, the iw utility is not on either the DVD or the images). With the wired adapter connected (nVidia MCP73 gigabit picked up on-the-fly during install with autoconfigured DHCP), it grabbed the iw utility via Yast, configured the adapter with the settings I gave it (WPA2), and that was that.


same problem after suspend here. Seems to be reported as but not solved yet.

Maybe you could join the bug discussion.

And did you try

chris@linux-gekz:/usr/share/man> solid-network set networking enabled  

(as suggested here:11.3 M7 Network Manager broken? That worked for me.

Edit: You did so and produced an error ("QApplications: qAppName: …) - did you tried the command above as “root” or as the user currently logged into the graphical system ? I get this error when i log in as normal user and execute the command in a root shell, when executing as normal user it works.