Network Manager and static IP setup

Hi all,

I’d like to have a set up where my Ethernet card has a static IP set up but my WiFi card doesn’t.

Currently I have a profile for this set up in Network Manager, however on boot up and every time I replug the cable Network Manager chooses the default “auto eth1” profile. I manually have to choose my own profile for the Ethernet card every time. How can I make it default??

I know the workaround would be to use ifup but then I lose the ability to quickly change access points for my WiFi card so that’s not a solution for me.

What do you guys recommend?

thanks
Hachre

Somewhat confused by what you say.

Is it not possible that you should just delete eth1

And in any case the IP you are talking about is the LAN IP and that is assigned by (usually a router).

I don’t have a eth setting in NM at all only wlan
yet eth0 show when connected

My Ethernet card is called “eth1”. NetworkManager has a default profile “auto eth1” for it that uses DHCP. When I try to change it, it creats a new profile instead. If I click on the NetworkManager I can then select both profiles:

  • auto eth1
  • my own

The problem is that on start up of the computer or when I replug the cable it always chooses “auto eth1”. There seems to be no way to tell it to use “my own” profile. I always have to manually change the profile used by clicking NetworkManager and choosing it there.

What I was saying is that the alternative (ifup) would mean that I lose the ability to handle my WiFi card over NetworkManager, so that’s not a solution for me.

Is it more clear now? :wink:

The question is why are you creating/having more than eth0
eth0 being the default.
Do you need more than one eth setup?

I can tell you though, in my box which has no wireless, I have eth0 and eth1 and I have set eth1 to default, eth1 is a pci card, eth0 is on-board. I prefer eth0.

You need to temp change settings to ifup and set the default eth then re-enable NM

Because I want my LAN card to use static IP settings and not DHCP. I have not found any way to change that without making a new NetworkManager profile for the card.

The reason it’s called ‘eth1’ is also unclear to me, but it doesn’t really matter. My WiFi card is ‘eth2’. When I look at ‘dmesg’ it says that eth0 gets renamed to eth1, for whatever reason.

Where on earth is your wireless listed as eth2?

In NetworkManager:

http://hachre.de/forumhost/eth2.png

Is this a VM?

No. I just also have VirtualBox installed, which added that vboxnet0 card.

It looks seriously messed up to me. All my machines have Vbox but not that.

http://thumbnails26.imagebam.com/6340/97612963397118.gif](http://www.imagebam.com/image/97612963397118/)

I would delete it all and start again. You are barking up the wrong tree IMO with static IP’s - not necessary.

Did you check the box “Connect automatically” for the profile?

Yes.

The message you have entered is too short. Please lengthen your message to at least 10 characters.

Just for the record. I solved this problem, my leaving NetworkManager and embracing “wicd”.

Info on it can be found here: Wicd - openSUSE

Basically disable Network Manager in Yast Networking, set all interfaces to Manual start up and change the Networking Backend in KDE (Personal Settings -> Advanced -> Hardware)

Then restart.

I like Wicd far more than Network Manager.