Network management disabled after start on 11.2

Some time ago, I tried connect to internet through iPhone (bluetooth tether), so I followed one tutorial… It said I have to change “networkmanager” to “ifup” in yast>network settings, and make some other changes… I did it, but I couldn’t connect via iphone… OK… I put back all changes, also changed ifpu to networkmanager.
After reboot, Knetowrkmanager gives me “network management disabled” on startup, instead of list of my networks.
Of course, I google for solution, but without any luck. And then, I don’t know why, I killed Knetworkmanager, start it again, and… it worked!
But now, I have to kill it, and start again always, when I reboot my laptop… that’s really annoying.

(HP Compaq 6720s, BCM4312, KDE 4.3.4)

There is an update for NetworkManager available in the update repo. Did you apply it? Does it resolv your problem?

Thanks! It solved my prob :smiley:
BTW…I thought Updater applet search for all updates… but “zypper update” gave me 195MB of updates for download :open_mouth:

Thanks again :slight_smile:

The applet only warns you for security and recommended ones, but when you open it, the other ones are behind the other Tab.

Hmmmmm… it’s back…
it was OK, after first reboot, but I start happening again… I tried reboot 3 times today, and I always get “network management disabled” mesage… :frowning:
(everything updated now)

In my case reinstalling NetworkManager packages or rebooting didn’t help. Following command did the trick:

rm /var/lib/NetworkManager/NetworkManager.state

Similar problem:
Network Management Disabled - openSUSE Forums